TP-Link Archer A7 - Revert to Stock Firmware failed

Hi all, I took a try on the snapshot with TP-Link Archer A7 v5 (stable not available AFAIK), but was not happy with the wireless speed (at least halved compared to stock firmware). So I would like to move back to stock.

I have read many times how to revert, on different websites and also here, specifically for TP-Link routers. I followed the TFTP recovery steps - downloaded Archer A7 the official .bin, rename it to ArcherC7v5_tp_recovery.bin (as per, turn on recovery mode (WPS LED was on), TFTP to the router with fixed IP, and saw a spike in the outbound network graph. But the router kept on booting up OpenWrt.

Have I missed a step or done something wrong?

Same problem here. Did you figure out how to solve this?

I recorded the process:

It's working for OpenWrt's firmware but when I try to put back the stock firmware, it seems to go fine but it returns to OpenWrt.

You can attempt serial installation. Please see for details.

Good luck.


I could, finally, figure it out.

For some strage reason, I couldn't get back to stock firmware if OpenWrt 22.03 was installed.

But I could downgrade OpenWrt to 19.07.10, then, I tried to inject via TFTP the stock firmware and, for my joy, it worked.

It's really strange but at least it solved the issue.

1 Like

If you cannot revert to stock firmware, it's worth trying to downgrade to an older OpenWrt firmware (19.07.10 worked for me).

Then, you must be able to revert to stock firmware.

OpenWrt Firmware Selector

Thanks this worked great. Now if I could glue all the hair I pulled the last two days trying to revert back to the old firmware. Thanks again.

1 Like

Can't believe I've spent so much time on such silly issue! THANK YOU for this solution and it worked perfectly.
Rolling back from latest Openwrt version to stock TP Link firmware makes the router appear bricked. Installing 19.07.10 resuscitates the router, as well as allows the stock TP Link firmware to be installed onto the router. All these steps are done via FTTP.

Sorry that this post is so long, but I wanted to give as much information as I could:

I have tried to do this, but no matter what I do I am stuck at OpenWrt version 23.05.0. I tried downgrading to the older version of OpenWrt (19.07.10), but when I login to the GUI it still shows 23.05.0. I have tried downgrading from the GUI, and it gives me an error that the file is does not pass the file check.

I have also tried these steps from another thread, and get the same results OpenWrt 23.05.0.

  1. First Flash DD-WRT TP Link Archer A7v5 - DD-WRT Wiki using the factory-to-ddwrt.bin by using tftp.
  2. After it flashes, and reboots into dd-wrt download this recovery stock file from the that wiki page, and do the tftp recovery method again Download this recovery firmware file
  3. Once it flashes you end up on stock router web page at you can either update the firmware from firmware upgrade page, or you can another tftp recovery, and from this page Download for Archer A7 | TP-Link

I have tried several TFTP servers on Windows, the transfers go ok, but it is never

I am stuck in the version 23 firmware.

Robert McMahan