TpLink A7v5 unable to revert to stock firmware

I currently have a couple of A7v5 running 21.02.2. Apparently I am unable to revert back to stock TP-Link firmware and seem to be stuck in OpenWrt purgatory. I am running tftp32/tftp64 and neither made any difference. I set my ethernet card IP to and I can see the file being read 100% by the router, but after a minute or so I am being brought back into OpenWrt. I doesn't matter which version of the A7 firmware I download it just doesn't take it. Looks like I am unable to flash anything other than OpenWrt Builds onto the router. Not sure why.
Both routers have the exact same problem.
Can anyone help?

Can you still get into Luci?

If so try renaming the Archer file to the name of the image you used. I take no responsibility for this bricking you router.

Did you see this Forum:
[Archer A7 v5 revert to stock firmware]( There seems to be a complete recovery method from dd-wrt, have a look. There is even a recovery firmware link...

The recovery firmware linked in the dd-wrt wiki is the revision Archer A7(US)_V5_190403, published at 2019-04-15. The TP-Link Website doesn't show this revision anymore, but it's still accessible at it's original download location: This is exactly the same as the one proposed by the dd-wrt's wiki.)


I posted here after I tried that dd-wrt method. I even used the tftp32 and the stock a7v5 firmware provided in that link, same outcome both times.

Yes. I can get into LuCI and that should be apparent from my above post. The TFTP client on the router essentially retrieves the file correctly upto 100% but the update never happens. Router just boots into 21.02 with LuCI and my settings intact. The routers are at my parents place so I can't try anything right now, but I think I will attempt next to install an older version of OpenWrt (18.x) and see if I can use that as a baseline to then go back to the TPLink Stock Firmware.
And before I forget, let me answer the other question. I would have to be out of my mind uploading the file into stock firmware using LuCI front end updater, that's asking for trouble and would surely brick a working router.

^^^^^ I'm so happpppppy to read that ^^^^^
I had a weak moment

For TFTP recovery/revert, the firmware file needs to be renamed ArcherC7v5_tp_recovery.bin (not A7).

A common issue is the computer firewall....temporarily disable it.

It's a good idea to use an unmanaged switch between the router and the computer. It avoids the link-down event, and link training.

Yes, already know the procedure as I know the back of my palm. What you should be aware of is that the same mode of flashing firmware through TFTP takes OpenWrt firmware, but not Archer firmware. I don't specifically go in and disable the firewall. Still think this is a firewall issue ? I do see that my router is showing v5.8 on the label (i hope this is still considered v5), otherwise I am lost as to how the A7v5 Openwrt firmwares are working at all.

Online support Guys are the worst kind or real friends... You know why?

Because if we were drinking a beer together at a cookout and you said that outloud we'd all bust out laughing and pointing...

But, hey this is coming from the dufus (me) that told you to brick your router. So my self shame ought to bring a smile to your face.

I really appreciate any help I can get on this.
I simply cannot get this thing to take Archer firmware and I am literally baffled/stumped (lots of other expletives also come to mind).

It is one of the "common" issues.

The other is the link-down event, and link training when directly connected to the router without an unmanaged switch.

That said, using the wrong version of the stock firmware, and using the wrong firmware for your geographic location are also common.

It may be that the first n bytes of the header in the stock firmware may need to be stripped.

Not a problem for me with my C7 V2, but it is for other TP-Link firmware.

Do a forum search for the A7 V5.

I've triple checked on the version firmware I've got and it is infact A7v5 downloaded and renamed to the appropriate files. I've tried all the available version that I've seen (including the dd-wrt link), etc.
I am going to try disabling the firewall. But if I need to strip out n number of bytes, that is certainly not something I will need help with.

You might also fire up Wireshark, and see what's happening with the packets.

Have you seen these?

Use the URL in the right column...the live links don't work for me.

I am facing the exact same problem as @cchhat01. So far I've tried all tricks in the hat, namely:

  1. Following the instructions mentioned on the DDWRT Archer A7 page.
  2. Renaming the file to exclude A7 and include C7 in the filename.

The TFTP transfer succeeds, and the router reboots shortly into OpenWRT.

This is the EU version of A7v5. Not sure if it makes a difference, since it doesn't make a difference while installing OpenWRT. Anyhow, I did try flashing the EU version of the file as well which results in the same outcome.

I'm gravitating towards the fact that there is something in the OpenWRT build which is causing this to happen, but I'll leave it the pros to figure that out. Meanwhile, any help on this would be appreciated.

Edit: The entire procedure doesn't even reset the existing settings on the router. It reboots into OpenWRT with the same settings as before.