Anyone work with Cudy WR2100

Is there anyone work with Cudy WR2100, seems it is good for OpenWRT, and they open the develop information.
DTS&GPIO of Cudy WR2100
Amazon Link
Chipset: M7621DA + MT7615E+ MT7603E

The Cudy WR1300 has a development thread:
and it looks like they are providing Source in accordance with the GPL.
Also there is an OpenWrt binary:

I think this vendor has realized that a number of their sales were destined for OpenWrt.

1 Like

thanks for your info, i will buy one to have a try, the price is really competitive...

I took one from amazon, at 50€ is a real deal. The original fw lack basic functions to use it with my provider but the openwrt build works very well. The only issue is that the firmware they provide is based on a snapshot and the wireguard module available from the current snapshot does not load, so I guess I'll have to compile it myself unless someone decides these devices can be officially supported.

Someone is working on it, hope it could officially released.

I cloned and build a FW from yogo1212 repo, flashed over cudy's openwrt release.
It works quite well, there is some difference in LAN device naming so the configuration saved from cudy's openwrt image can not be directly restored.
The main difference I noticed is the wireless connection speed, with cudy's image it constantly reaches 512mbps in download, the image I compiled sometimes reaches the same speed but most of the times stays around 280mbps.
Cable tests always reach almost the theoretical max of my FFTH, 1gbps

Did a second test, cloned branch openwrt-19.07 and applied the files that cudy provides in his "openwrt for developers" archive.
The image generated works perfectly, like the one they provide, with wifi speeds up to500mbps, which I never have been to achieve with the firmware generated from master.

1 Like

Could you tell me if you have configured something to have a symmetric 1gb transfer? I have a symmetric 1gb ffth connection and I can't get a 1gb transfer, at most 600/500 mb upload / download.

The same thing happens to me with cudy wr2100 official firmware and OpenWrt firmware.

1 Like

With the factory firmware, the result is same as you, but after i upgrade to the latest cudy official firmware, i could get 900+ download/upload speed, you could have a try!

I have installed the official firmware version 1.7.1 of the day 20210220. Actually the version that worked best for me was 1.5.2 but at that time my ftth connection was 600 / 600mb symmetrical. Since then my internet provider offers me 1gb / 1gb and that is when it no longer works beyond 600 download 500 upload.
I have tested versions 1.6.2 and 1.6.10 with the same result as now with 1.7.1 and OpenWRT downloaded from Cudy's website.

I also have an Asus rt-ac66u router with AsusWrt and Linksys Velop MX4200. With these routers I don't have these low transfer problems.

which speed do you mean? wired or wireless speed?through ethernet cable, i can achieve the speed of 900+(version 1.7.1), wifi speed less than that, maybe only 4 x 4 wifi card can reach that speed, i'm have that wifi card, really expensive.

The speed that I mean is always by ethernet cable, the wifi has not yet been configured when seeing such a low transfer by ethernet cable.
I use my asus router daily because the speed is correct.

This is my asus router:

And this is my Cudy WR2100 router with OpenWRT (wifi not configured):

I only configured vlan6:

I tried Cudy OpenWRT today, result similar with you, seems openwrt driver doesn’t has Hardware NAT.

But in Cudy Official FW, it has Hardware NAT. The ETH speed is 900+.

Thanks fatreedl, I saw that option but I didn't try to change it. I know there is one enabled, I do not know if it was HNAT or the other option that I do not remember the name.

The problem is now bricking the router, I try by all means to unbrick it with this option proposed by Cudy but it doesn't work for me. I cannot access the red and blue lights mode, when I turn it on it remains with a red light and I do not access any webif and if I turn it on with the reset button it turns on with purple light and it stays with that light forever. The tftps32.exe program is not responding in any way.

Cudy has contacted me by email, I'll see if you can help me unbrick the router.

Thanks again for your help.


Finally if I was able to unbrick the WR2100 router, following the instructions provided by Cudy support (and taking some action like disabling the firewall, resetting the tcp-ip protocol, disabling Hyper-V, etc.).

Even what I could not use is my maximum transfer by ethernet cable, I do not know why doing a speed test gives me a speed of half of my contract. With other routers like Asus, Linksys Velop, official router of movistar spain (Mitrastar HGW-2501GN-R2 from the year 2015) if I receive my maximum speed, 1gb symmetric.

The HNAT option did not work on Cudy firmware 1.6.2 or 1.7.1.

so you get your router back? and still cannot get maximum speed? that's really weird. Is the same ethernet cable, same computer and same test server? have you try to Reset the router and test again?

Yes, it's just like you say.

I explain how my installation is:
The fiber optic cable (ftth) connects to my ONT, and I connect my Cudy WR2100 router, or Asus RT-AC66U, or Linksys Velop MX4200, or Movistar router from 2015 with a cat 5e ethernet cable to the wan port. I connect my PC to the router's lan port with a cat 5e cable.
I configure in my router the PPPoE connection (username / password) and internet vlan (in my case vlan 6 priority 1). Depending on which router uses Triple vlan setting or not, (Linksys Velop MX4200 does not support Triple vlan). I normally use Clouflare DNS and

I do all the speed tests on the following website, official of my internet company.

The tests are variable:
Movistar router gives the maximum speed, 930/925 (+ or-) same as Linksys Velop MX4200.
Asus router a little below, 900/900.
Cudy WR2100 router half speed, 700/500.

I have not done a speed test for wifi since at the moment I am not interested in wireless speed until I solve my ethernet problem.

Now I am testing to connect the Cudy WR2100 router as an access point on my Asus router. The speed is 900/835 but I am not interested in using this configuration because I am looking to completely replace one router with another and the speed is very low in router mode.

These images are using Cudy WR2100 as an access point on my Asus router.

Sorry my English, I use google translator.

@Flecky From your picture on cudy management page(on Access point mode?), seems the speed is achieve 900.

Seems the you use some complicate configurations, you may just use PPPoE to dial and do not configure other settings and then test the speed.

Maybe the configuration affect the speed(may have bugs about these function), i guess.

PS: Google translator is really good. :grinning:

Another thing, i noticed that, this picture is not in true access point mode, it work as DHCP client, you just plug it after ASUS router(didn't use Access Point mode or disable the DHCP server on Cudy), so Cudy still has a NAT. Base on that, from this picture with 900M+ speed, i'm pretty sure your router can achieve 900+ speed when working on Router mode. Maybe the configuration or some other things affect it.

In the last images the speed is 900+ because the Cudy WR2100 router is in bridge mode, the one that manages PPPoE and vlan is my other Asus RT-AC66U router.
Cudy WR2100 works correctly with maximum speed, 900+. If I remove my Asus router and manage PPPoE and vlan in Cudy WR2100 the speed is no longer 900+, it would go to 700/500 + or-