Cudy WR1300 support?

Is anyone working on support for the Cudy WR1300?

1 Like

I think this just hit the market. My search:

I'm guessing mt7621a based (dual core, Gigabyte LAN). If so, should be attractive and doable.

i asked their technical support team, and get the information as below:
Item Description
Chipset MT7621AN CPU
MT7612EN 5G Wi-Fi
MT7603EN 2.4G Wi-Fi
RF 2.4G iPA、iLNA
Flash 16MB SPI Flash
DDR 128MB DDR3,16bit,1200MHz
Reset/WPS GPIO Reset Button GPIO#18, Active low
WPS Button GPIO#3, Active low
USB_LED GPIO#14,Active high
WPS_LED GPIO#13,Active low
SYS_LED GPIO#15,Active high
WAN/LAN_LED Controled by Driver
2.4G/5G LED Controled by Driver
Ehternet LAN LAN LAN LAN WAN LAN is Port #0 ~ #3, WAN is Port #4

That should be quite easily supportable, but it still needs someone with the device on their desk to actually do the porting work.

Cudy devices are cost competitive but I've not seen the one I linked in my prior post on US sites. It is competing with the Newifi D2, which is already ported, and can be had for ~&45-50USD. Shipped with uncertainty from Hong Kong/China The Newifi D2 has more Flash/RAM but still should be a good base to start from.
This also raise the question as to why the Cudy device would be a more attractive purchase than the Newifi? Both have the same form factor, same # of Gigabyt LAN ports.

A cudy wr1300 showed up on Amazon yesterday

The case is thinner, tighter fitting and white as opposed to my earlier product link. An OpenWRT-based firmware is available on the manufacturers web site. The price is good but there is a comment that the unvented case runs hot.

I'm going to keep shopping for a mt7621a, 4 LAN device.

I have one... Bought it last Thursday and it showed up the following Saturday from Amazon. I bought it specifically to use easytether with it in a mobile application and figured it would work right out of the box since it claimed openwrt support. The firmware included with it is a very basic firmware with almost zero options. The company emailed me asking if i would give feedback, i let them know their advertising was misleading and i couldn't accomplish what i intended to do with it out of the box. They reply saying the device is "openwrt ready" and they need to openwrt community to work on it because their staffing is limited. I guess that means they will provide all details to anyone interested in getting a full version of openwrt working on it.

I have this router too since I got it off of Amazon for a good price. Cudy does have an OpenWRT build for this router available on their website, and it does (mostly) work.

Except for this:

root@OpenWrt:~# opkg install luci-app-sqm
Installing luci-app-sqm (1.2.4-1) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-sqm:
 *      kernel (= 4.14.171-1-16b77c6fbb9d9192d39ab642ba67d11a)
 * opkg_install_cmd: Cannot install package luci-app-sqm. 
root@OpenWrt:~# uname -a
Linux OpenWrt 4.14.171 #0 SMP Thu Feb 27 21:25:59 2020 mips GNU/Linux 

It seems there's a mismatch between whatever kernel they built and the one expected for kmods? I sent them an email detailing everything hoping they could fix it.

Seeing that they have a working build though, does anyone know what it'd take to make an official release build? It'd be much preferred over sending emails to them and hoping for something to be done. I'd really like to get SQM working. :smile:

Are you having any thermal issues or problems with dropped connections?

Ideally, you should be able to extract the key parts of their OpenWrt build and make you own.
For the dts; Partitions, LED's, Switch, MAC's. For the image padding; signatures, etc. Once done, your pacakges should build in sync.

I haven't used it much yet, but I've only ever noticed it getting warm. I ran iperf over Wi-Fi for about 15 minutes straight and it seemed stable.

There's ventilation on the bottom, by the way.

As for the firmware build, I figured it'd be something like that.. unfortunately I don't have any real experience with this sort of thing. The first time I used OpenWRT was a few days ago. :laughing: I'd be happy to try and help if I can, I'm just not sure of the best way to go about it.

Also, I figure it'd be good to mention this here just in case anyone needs it:
There is TFTP recovery for the router, the information is here. It already saved me once from a soft-brick. :relieved:

Cudy provides some key info for your own builds in the Developer Download - *.dts file.
You should be able to plug it into a git pull for v18.06.8, edit 4 other files and build your own firmware/packages.

Quick Image build guide w/ setup

The other files that need edits

I'm considering buying this. It's my understanding you are now running the basic OEM-OpenWrt based firmware, right? So if the temperature and stability is OK, what else can you say about the throughput and coverage? Thanks,

I actually managed to get in touch with the manufacturer and they gave me a build that, among other things, has SQM built in. There were a lot of unnecessary packages I had to remove though, and it still has the kmods problem. With SQM enabled on my 12/1 DSL line, CPU usage tops at ~10%.

Anyway, I set it up as my primary home router and it has been working great actually. Wi-Fi coverage seems to be better than my ISP's all-in-one gateway. It's on the second floor of the house and 2.4 GHz and some 5 GHz still comes in in the basement. Performance is what you'd expect, at close range 5 GHz will push near 300 Mbps (80 MHz), and 2.4 GHz just over 100 (20 MHz).

Really I'm just holding out for an official build so I could experiment with OpenWRT more, and maybe try out a 19.x build.

Here's an iperf + ping test on my laptop from the basement with the router two floors up.

Good. Did they give you the binary, or the sources and/or recipe? Because if you want to update the package list in order to install new packages, you may get the kernel mismatch error, but if you build the firmware yourself (on a Linux computer, better if with a .config file provided), you probably will be able to update your packages info and/or customize your installation and save flash space.

They only gave me a binary unfortunately.

Here's a compilation of all the information/files I have for this router, including all the development/recovery documents. I checked their website and it doesn't look like they posted the new build that they emailed me anywhere. Maybe it'd be of use to someone.

Hi, i dusted off my wr1300 and applied the largest openwrt firmware file provided in lrussell887s post.

Everything seemed to work fine (after 2 mins of browsing web config pages for first time) so i decided to install easy tether package and see if i could make it work.

I found the easytether driver made for the MT7621 chipset and SCP'd it into the routers home directory and used opkg to install the package. I then followed the instructions of easytether website for installing to openwrt by changing the ifname from eth0.2 to "tun-easytether" in /etc/config/network.

After plugging in my phone to the routers USB port and accepting the RSA key on my phone, i can use the ping command inside an SSH on the router itself and on my ubuntu laptop terminal connected to the routers lan port and it resolves the host name i provided to an ip address just fine but it seems as though easytether restricts icmp so i never get any packets to respond as expected. i am also able to resolve host names using nslookup just fine.

Although i am not able to browse webpages from my ubuntu laptop!

Checking the routers network/interface page it shows the WAN port with a red banner on the box and interface as tap-easytether, it also shows the uptime counter couting up and it also shows the expected ip address that the phone assigned to it through dhcp.

I noticed if i open an SSH terminal and type "ifup wan" sometimes the banner for the wan port will turn green momentarly, also i can browse the internet just fine on my laptop. But after about 30-45seconds the wan banner turns red and i can no longer browse the internet. If i type "ifup wan" in SSH i get ability to browse internet again for about 45 seconds.

It seems like something is turning off the network connection after a certain amount of time. Ive read somewhere theres a watchdog script running on openwrt that checks internet access via icmp, if easytether doesnt pass icmp info perhaps this watchdog is closing the connection?

First i would like to get the connection to work without closing out after 45 seconds

Second i would prefer to be able to use wan port as primary internet access through a cable modem and when it fail then automatically fall back to easytether over the usb tun/tap interface. I assume i cannot set ifname as tap-easytether in /etc/config/network for this type of functionality and instead need a more elaborate setup perhaps using mwan3 or something like that.

Any help is greatly appreciated.

found the mwan3 was auto disconnecting the wan port. Temporarly i went into /etc/config/mwan3 and removed references to list track_ip values for wan and wan6. I then added in wan a lisst track_ip of, this is the ip of the phone on the other end of the usb cable. It seems to stay connected now.

I just sent along a message to Cudy's support email, hoping to make them aware of this thread.

Given the price point (~$40 USD), general availability (Amazon US), and reasonable specifications, surely this device is an attractive candidate for OpenWRT support? Then again, I'm not sure how many OpenWRT devs are US based.

I'm kind of surprised they haven't tried to push support themselves though, given that their stock firmware already uses it (a customized 17.x build), and that they have a standard (mostly) working 18.x build released on their own website. Surely someone on their dev team would be able to? They even put the .dts file in their "developer download". It's almost irritating that they plaster "OpenWRT support" on their Amazon listing and on the box. :sweat_smile:

As @slh said, the biggest hurdle is getting the device in the hands of a willing developer, and I mentioned as much in my email. If they aren't willing to give out a device to one, I may be persuaded to do so myself.

That, or maybe I should dive head-first into learning how to add device support.. I guess I'll see what comes up in the next few days. I could see myself being able to make good use out of a few more of these routers.

@lrussell887 would be nice if you share your progress. I'm also interested on this model and I'm thinking in buying one.

I bought this router earlier this week as a lockdown project for fun. Cudy provides the dts file they used, so it was very easy to get it to compile against openwrt HEAD. I can confirm that I have a working openwrt snapshot image - the ethernet interfaces, and wifi works, and the usb port correctly detects things I plug into it. I've pushed my changes here in case someone wants to take a look.

I have a question though - my last commit (which drops the memory nodes) should have worked based on what I see done for similar hardware, but in my case it results in a panic. Can someone with more experience take a look and comment?