Add support for Xiaomi AX1800 Wifi 6 router

My laptop finally recognizes the network as 802.11ac but the speed limit is still blocked at 54mbps.
I update the qualcomm driver but nothing changes. It seems the issue comes from my laptop.

its from speedtest 54mbps or link speed from wifi ? if it link speed usually its only 5ghz A 20Mhz channel

54mbps link speed from wifi and even worse 20mbps from speedtest (on a 80mhz channel). I can't find any logic because on my smartphone i have 100mbps from speedtest with xiaomi ax1800 and 30mbps with my iap box whereas on my laptop i had 500mbps with my iap box and 20mbps with xiaomi ax1800 from speedtest.

just download wifi analyzer, wifi info view, or winfi you will know which channel you are using, if not just use 2ghz N that way faster

i think wifi 4 is only for 2ghz N , and if you use 5ghz only go with 5ghz channel A and 5ghz chanel A only 20Mbps max

Screenshot_4

i almost forgot, N channel only support 40Mhz bandwith or channel width in 5ghz, so try setting, the AX1800 40mhz


These are the results in winfi. I can't understand the limitation on the xiaomi..


and from my isp box

Have you tried disabling MU-MIMO option and enabling the Wi-Fi 5 compatibility mode from wireless config menu?

Didn't see it mentioned but the exact same process to gain permanent ssh/telnet access and be able to permanently change the router's CountryCode for the AX3600 works perfectly on the AX1800 with the same crash_unlock.img and instructions.

Download the crash_unlock.img file from here:

Follow this guide:
https://www.5v13.com/mesh/26276.html#

I tried this too. Think i'm gonna give up...

What wireless card is in your laptop?

Also I think maybe you need to do a full reset on the AX1800 and start from scratch.

Before the reset you can achieve permanent ssh to make it easier afterwards.

A little bit off, but... FW 1.0.385 was pushed on my router recently. Was anyone in similar situation brave enough to experiment with the SSH hack? I mean if it still works or just bricks the whole thing or... ?

1 Like

I did the bdata ssh perm mod a while back so I didn't have to worry about ssh hack access getting blocked.

I find my router updated with version 1.0.385 on returning from vacation .. and no more root access

What can I do to find it?

Thanks for your help

After Easter I'll order a standby router (a white ax1800 this time, 'cause why not). Before that I can't risk disconnecting from the internet for days in case something goes wrong.

So my best bet is downgrading back to 1.0.378 and do the ssh exploit again. Google for miwifi_rm1800_firmware_ed621_1.0.378.bin to find an old firmware.

For permanent ssh (Gingernut's 'bdata ssh perm mod') the best source I've found so far is this, note the github link with all the scripts that cover the steps of the original chinese article. Again, don't send your S/N to anywhere, the scripts will generate telnet password too.

1 Like

I am wondering if my /etc/rc.local still exists or if it was overwritten or destroyed by this update.

I have no tools to find out.

You can downgrade to the official 1.0.378 fw and use xqrepack https://github.com/geekman/xqrepack to generate a 1.0.385 rootfs image with ssh enabled and flash to the secondary rootfs partition.
Xqrepack will remove the xiaomi data collection software, so after flashing the rootfs partition the Miwifi app will not work.
Xqrepack is is compatible with the AX1800 firmware image, you must use the --data flag in the ubinize.sh step https://github.com/geekman/xqrepack/issues/1

1 Like

I downloaded firmware version 1.0.378 but upon flashing from the web interface, I get a “File verification failed” error. I’m currently running version 1.0.44.
Any advice please?

Is yours an international device?

edit: Just checked and 1.0.44 is a Redmi AX5 firmware, 1.0.378 is for the Xiaomi AX1800.