Add support for Xiaomi AX1800 Wifi 6 router

Thanks, yes I have enabled it. But as far as I remember even when it was disabled it was the same. Currently, I use it to connect all our phones at home, Alexa and TV. All connect without any issues, but phones disconnect when it goes to sleep mode while in a call (ex. WhatsApp calls).

I'll retry again deactivating MU-MIMO. Thanks.

After setting the MU-MIMO to off, still the same, call get cutoff 45 seconds after screen goes to sleep. Only happen with AX1800. I have another router with a different make using MU-MIMO, does not have this problem with it.

One more thing you can try is update the wireless firmware.

I used WinSCP to transfer the files to my AX1800.

Download and unzip https://github.com/kvalo/ath11k-firmware/archive/master.zip

With WinSCP connect to your AX1800 and navigate to /lib/firmware/IPQ6018/WIFI_FW

Make a backup of the WIFI_FW if you wish

From the unzipped file copy the contents of /master/IPQ6018/hw1.0/testing/2.5.0.1.r1/WLAN.HK.2.5.0.1.r1-00004-QCAHKSWPL_SILICONZ-1/ to the WIFI_FW directory on your AX1800 overwriting all the existing files.

Reboot the AX1800

@Gingernut Does this wireless driver update affect positively connection stability too?
More particularly my problem is that I have intermittent connection outages. I have a 1Gbps FTTH connection, but my network provider fails sometimes on LCP echoes and who knows what else. So I've tweaked my network config

option keepalive '365 86400'
option pppd_options 'debug kdebug 7'
option force_link '1'

and also have daily reboots scheduled. With that I've eliminated most of my outages, but unfortunately not all of them. I guess the root of the problem is with openwrt18.06.

Despite 'debug kdebug 7' the most I can find in the logs is a 'Modem hangup' message.

Hi Andy,

Managed to get the wireless drivers to the /lib/firmware/IPQ6018/WIFI_FW as above advise and left MU-MIMO switched off. Still the same, it does not like when the phone screen is off while in a call and disconnects it.

Anyway thanks , learned few things with chromium as I can't use WinSCP on it :slight_smile:

I doubt it.

Any serious security concerns anyone has noticed running these in stock?

The Chinese black tower versions looks great for the price. And wouldn't mind replacing my kit with these till openwrt is working well on them.

@spastro "till openwrt is working well on them" If stability is a factor too, see my comment above.
Some additional notes:
Sometimes it suddenly asks you to log into wifi network, so it leads you to a chinese error page that states that connection to the internet fails (so not even a "lido style" login page at the end).
Sometimes I (also others according the internet) can't use google in one of my browsers, because it claims having an incorrect certificate (google certificate is somehow replaced with some miwifi certificate. Sorry, can't find the forum about that.
PPP reconnects may take up to exactly 60 minutes. Meanwhile, some of the usernames of the attempts are not mine but a different one (always the same one). Getting rid of it may require several reboots of both the router and the modem of the provider in a row.
I think the chinese made an awsome hardware, but made openwrt18.06 even worse than it originally was. After all of the above I can imagine any other easter eggs too.
Until actual openwrt support arrives, it is an useless piece of iron to me. And seeing that it is in the shadow of AX3600 (that will fall into the shadow of AX6000 soon) I don't have high hopes to have it soon.
I've just ordered yesterday a TP-Link with so-so reputation (Broadcom and openwrt... yeah, I'll see).

Thanks for the advise.
What to to TPlink did you get? Might look into that.

Did you try the ax1800 with stock firmware? Any issues you could see or here running it with stock?

I think we just take the whole thread offtopic...
Since the ax1800 runs yet only on stock (openwrt@xiaomi) firmware, I use that. I have some shallow experience with openwrt to tweak its network configuration better, but not enough to make it perfect. I've just listed all the major issues I've faced in the previous comments.

Thanks for the heads-up !

I managed to install: Adblock-full (the 3.x version), bcp38, stubby (for DNS over tls), DDNS scripts for dynu.net, I just miss SQM, but it almost feels like a complete OpenWRT for me.

3 Likes

Hi everyone. I've got some issues with the AX1800. Despite the european channels are enabled, I can only use channel 36 in 5Ghz, and i can't understand why the connexion speed is limited at 54mbps (in 2.4ghz my limit is 144!). I've tried some tips i saw in this thread but nobody seems to have the same issue.
Thanks for your help!

Edit. I notice that when I success connecting on a 5ghz band, my laptop identify a WIFI 4 connection (802.11n). Is there a command to force 802.11ac or ax?

Is this on all your 5ghz clients or just in one? Try editing the 5ghz radio in the /etc/config/wireless file (backup it first) for something like:

config wifi-device 'wifi0'
	option type 'qcawificfg80211'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	option hwmode '11axa'
	option htmode 'HT80'
	option country 'CN'
	option disabled '0'
	option txpwr 'max'
	option txbf '3'
	option channel '36'
	option autoch '0'
	option bw '80'
	option ax '1'
    option require_mode 'ac'

This is my AX1800 5GHz radio config and I have no issues connecting to channel 100.

root@XiaoQiang:~# nvram get CountryCode
EU
config wifi-device 'wifi0'
	option type 'qcawificfg80211'
	option macaddr 'xxxxxxxxxxxx'
	option hwmode '11axa'
	option htmode 'HT80'
	option country 'ES'
	option disabled '0'
	option txpwr 'max'
	option ax '1'
	option autoch '0'
	option bw '0'
	option txbf '0'
	option channel '100'

config wifi-iface
	option device 'wifi0'
	option ifname 'wl0'
	option network 'lan'
	option mode 'ap'
	option wpsdevicename 'XiaoMiRouter'
	option macfilter 'disabled'
	option miwifi_mesh '0'
	option key 'xxxxxxxxxxxx'
	option wscconfigstatus '2'
	option disabled '0'
	option encryption 'psk2+ccmp'
	option hidden '0'
	option bsd '1'
	option rrm '1'
	option wnm '1'
	option ssid 'xxxxxxxx'
	option wpa_group_rekey '86400'
	option sae '1'
	option sae_password 'xxxxxxxxx'
	option ieee80211w '1'

Thank you for the answers. That's weird because my config options look similar to yours. How can I edit files in /etc/config/wireless? (sorry i'm a noob)

WinSCP is an easy way.

I have an access to the router via win scp but i don't know what file i need to modify inside.

The wireless configuration file is in /etc/config/wireless

After editing save the file then reboot the router.

thank you i'll try this