Add support for Xiaomi AX1800 Wifi 6 router

In theory yes, i practice looks limited to 28/26 by any country configuration applied. For some channels Could rise to 33dBm.

Hi Makunan when you have time to check this please kindly let me know
ty
have a nice day

Hi all,

Ok, tested commit commands

For any nvram set "X"
nvram commit

For uci set wireless.wifi"X".country='YY'
uci commit wireless.wifi"X".country

Reg set can´t be a persistent change because you need to compile again the DB regulatory.bin

But iw commands look like don´t need commit command to be saved, could you change the txpower and reboot the router to know if it is persistent o not?

No it's not persistent.
there's someway to execute a script at boot to have them set?

ty

Hi, guys i dont understand that much about router but it will be possible to enable 160mhz channels in this router?

It's not be possible, you need 4x4 antena for 160Mhz

Hello

I don't quite understand how the 'channel option' works. Do we enter the desired or refused channels? I made several tries and no changes.

I wanted to determine the power with 'option txpower' but again no effect.

In EU country mode, only channel 36 in 5Ghz seems to work normally. Channel 96 is missing and channels from 100 do not work properly (some devices do not connect to it).

Thank you all for your essential help.

Hi, changing CountryCode you only enable channels availables to be selected, but to enable those channels in the wifi radio you need to change the Wifi Code too.
Example:

nvram CountryCode=EU to enable european channels between 36-64, 100-144 (over 144 are forbidden)
nvram commit to save changes

uci set wireless.wifi0.country='ES' for Spain 5Ghz
uci commit wireless.wifi0.country to save changes

uci set wireless.wifi1.country='ES' for Spain 2,4Ghz
uci commit wireless.wifi1.country to save changes

It also limit the TX transmision power by your country laws, for Spain 2,4 is limited to 199mw and 250mw for the 5Ghz

For your country you need to check the right code

I think so, i'm checking the ax3600 forum to know how to add a boot script in the router.

I have created /etc/rc.local with :

sleep 7
iwconfig wl1 txpower 20
iwconfig wl0 txpower 20
exit 0

chmod +x

so power is set on startup

2 Likes

I'm pleased to see the Xiaomi AX1800 getting some love..

I can access SHH by following the guides but would like to enable maximum power on both 2.4Ghz and 5Ghz frequencies.

I am from the UK

How best to achieve this and what would the start up script look like to enable this on every boot?

Thank you.

Hi @Mitch21,
I set this up but in most of the cases at reboot the 5ghz interface is not working anymore

I did a reboot yesterday to test, no problem.

I noticed that in 5Ghz, only channels 36 and following work correctly. I did not continue the tests, channel 36 satisfies me perfectly.

Hello,

I am new to forums hoping someone can help answer some questions i have please.

I am looking to purchase 3-4 Xiaomi AX1800 routers to run as mesh but needed to confirm few things.

  1. I have my own router/firewall so can i run this in AP mode only?
  2. Can i create two SIID's one for guest access with VLAN Tagging so i can control what they can access using my firewall?
  3. Does it work as Mesh wired or wireless?

with default mi firmware you cant create guest ssids.

Yes you can, but via the MiWifi app. If you are willing to tinker with the router files in /etc/config, you can also create more than one guest SSID on both 2.4 & 5Ghz

1 Like

Is router mode not mandatory to use Mesh mode?

Anyone know if it would be possible to build a bootable firmware based on OpenWRT from Qualcomm's QSDK?

Hi
I have a Xiaomi AX1800 setup as a AP and thanks to this forum managed to set the country codes and txpower setup to 20dbm using ssh access. I have the 1.0.506 version installed.

The router works perfectly with no connection drops but have one anoying problem. While in voip calls it drop the connection and trying to reconnect to WiFi when screen goes to sleep mode. Vedio call works perfectly too, no drop of the calls since the screen keep awake all the time. My other access points does not have this issue.

Any advise is appreciated.

Do you have MU-MIMO enabled on the AX1800?

I seem to have connection problems with a few devices when it's enabled.