Xiaomi ax3600 ssh guide

There is a good description here, how to get a permanent ssh after firmware upgrade:
https://www.5v13.com/mesh/26276.html#

However I also stuck, with write back step.

root@XiaoQiang:~# mtd write /tmp/bdata_mtd9.img bdata
Could not open mtd device: bdata
Can't open device for writing!

There is anyone figured out how to solve it?

The crash_unlock.img is written sucessfuljy, at least seems to it.

root@XiaoQiang:~# mtd write /tmp/crash_unlock.img crash
Unlocking crash ...

Writing from /tmp/crash_unlock.img to crash ...
root@XiaoQiang:~#

You normally need to install the kmod-mtd-rw package to be able to write mtd partitions.

1 Like

Yeah, actually the crash_unlock.img file supposed to get the mtd partitions writeable.
I also tried the way as kmod-mtd-rw package wasn not available at all at https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/packages/
I got this
https://mgmt.saar.freifunk.net/openwrt/releases/18.06.8/targets/mvebu/cortexa53/kmods/4.14.171-1-e2d32c880dc65b62ec0410e12611f89c/kmod-mtd-rw_4.14.171+git-20160214-1_aarch64_cortex-a53.ipk
then copy to the router /tmp folder, then install to the memory

root@XiaoQiang:~# opkg install --nodeps --dest ram /tmp/kmod-mtd-rw_4.14.171+git
-20160214-1_aarch64_cortex-a53.ipk
Installing kmod-mtd-rw (4.14.171+git-20160214-1) to ram...
Configuring kmod-mtd-rw.
root@XiaoQiang:~# insmod mtd-rw i_want_a_brick=1
Failed to find mtd-rw. Maybe it is a built in module ?

But still no luck! :frowning:

1 Like

Kernel modules must match the running kernel exactly (not just the same upstream version, but also the same patches and configuration), there is only very little leeway. Non-matching kernel versions usually just result in the module not being considered, same version but non-matching patches/ config likely causes crashes.

In order to match, you'd need the 4.4.60 based OEM kernel, but you don't have its source.

Thank You!

I thought so, but it worth a try and opgk upgrade it not possible to run on the the router with the miwifi_r3600_firmware_5da25_1.0.17 firmware even with ssh access.

Finally managed to get a different crash_unlock.img file from https://www.wutaijie.cn/?p=254, which is really got the mtd partition writable. I completed all the rest of the steps, but instead of having ssh permanently even the existing one is disappeared. After upgrade to the miwifi_r3600_firmware_f7f3e_1.0.67 firmware telnet is working, so then I was able to turn turn back ssh!!!

All the files collected for this or other methods are here:

4 Likes

1.0.67 is old firmware 1.0.227 is the newest

On miwifi web the latest one is 1.0.67 still. Where do you have 1.0.227 from?

Currently on http://www.miwifi.com/miwifi_download.html the latest is still 1.0.67 as well the router does not offer any update.

1 Like

Great. Can you share the source, where it comes from? Thanks

1 Like

Just performed these steps on my device. it works! I'm on the latest firmware and have ssh access.

  • I did need to remove the crash file since the WiFi got bricked without it.
1 Like

Hello,

It runs perfectly on my Redmi AX5 with 1.0.16 firmware.
Just a question, what is the default password for root, I can open ssh conenction but I can't find this password ..
Thank you !

I used the explanation on https://openwrt.org/inbox/toh/xiaomi/xiaomi_ax3600 to set the password.

There's a line for how to inject the root password (search for < PASSWORD > on the page)

Thank you, it works great !

A last question, cas I update firmware after ssh activation ?

Yes, you can. But then you have to re-enable ssh via telnet.

I also upgraded from 1.0.404 to 1.0.17 and then 1.0.67 but with xqrepack method. Working so far fine and have ssh access (can't update or install anything though using opkg). Also upgraded to international version 1.0.322 also but had issue with wifi so decided to redo step from 1.0.17 to 1.0.67 with xqrepack.

I wrote a more thorough tutorial that you might find useful. also pasted in the main channel: https://oded.dev/2020/11/30/AX3600-1

1 Like

Nice guide...do you intend to make a video for a noob like me? Trying to upgrade ax3600 and keep ssh ... thanks

If you need a video, please reconsider if this device is an option for you right now. This isn't meant to be sarcastic, but you really do need to understand what you're doing (and why), before considering this. The situation should become easier once OpenWrt fully supports this device (as this would merely involve downgrading the version once and flashing OpenWrt from there), but right now it is the way it is (given that Xiaomi doesn't want to allow you access).