A modern web interface for OpenWrt implemented in vue.js and element-ui

Home: https://github.com/zhaojh329/oui
Features:

  • Fast: Use static pages; access any kind of system data via ubus
  • Multi User: Support for multi-user and access management
  • Vue + Element-UI: Enjoy the dev experience of Vue + Element-UI


(upload://ptbEim6xZqtN9cFkJsqbcg80jTK.png)

9 Likes

Looks interesting, might have a dabble with this on my WRT32X.

Looks nice but the sidebar might be a little too bland. I have yet to find a theme that really lures me away from bootstrap.

4 Likes
  • darkreader :wink:
1 Like

I felt the same way for a long time, but then I found out about luci-theme-atmaterial, which is an OpenWrt theme based on the interface from the (now discontinued) AdvancedTomato firmware. You can see screenshots of AdvancedTomato here: https://advancedtomato.com

For some reason, though, @solidus1983 chose to make that theme specific to Davidc502's unofficial builds for four Linksys routers, rather than making it available to OpenWrt users in general. Why he chose that, I really don't know.

@wterlave89 check your dm's

Right now on topic struggling to compile oui for some reason I followed all the steps marked on your site however it still hits out error 2 and dies.

I don't see it anywhere.

chrome plugin

1 Like

How do I try it?

Have you seen this? https://zhaojh329.github.io/oui/guide/compile.html#update-feed

Tried compiling myself however it was erroring out like a madman.

i cannot compile ?

make[1]: *** [package/feeds/oui/oui-ui-core/compile] Error 2

Same error I get everytime.

Can you provide a more detailed log output?
What does make -j1 V=s prints...?

Will try tonight after cloning my working build directory to a new folder.

make[4]: Entering directory '/home/test/B/openwrt/build_dir/target-mips_24kc_musl/oui-ui-core-2019-10-02-ff73aac'
make[4]: /home/test/B/openwrt/staging_dir/host/bin/node: Command not found
node: 
make[4]: /home/test/B/openwrt/staging_dir/host/bin/npm: Command not found
npm: 
make[4]: /home/test/B/openwrt/staging_dir/host/bin/node: Command not found
Makefile:12: *** "Node required at least v8.16, current not installed".  Stop.
make[4]: Leaving directory '/home/test/B/openwrt/build_dir/target-mips_24kc_musl/oui-ui-core-2019-10-02-ff73aac'
Makefile:76: recipe for target '/home/test/B/openwrt/build_dir/target-mips_24kc_musl/oui-ui-core-2019-10-02-ff73aac/.built' failed
make[3]: *** [/home/test/B/openwrt/build_dir/target-mips_24kc_musl/oui-ui-core-2019-10-02-ff73aac/.built] Error 2
make[3]: Leaving directory '/home/test/B/openwrt/feeds/oui/oui-ui-core'
time: package/feeds/oui/oui-ui-core/compile#0.05#0.01#0.17
package/Makefile:111: recipe for target 'package/feeds/oui/oui-ui-core/compile' failed
make[2]: *** [package/feeds/oui/oui-ui-core/compile] Error 2
make[2]: Leaving directory '/home/test/B/openwrt'
package/Makefile:107: recipe for target '/home/test/B/openwrt/staging_dir/target-mips_24kc_musl/stamp/.package_compile' failed
make[1]: *** [/home/test/B/openwrt/staging_dir/target-mips_24kc_musl/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/test/B/openwrt'
/home/test/B/openwrt/include/toplevel.mk:225 : la recette pour la cible « world » a échouée
make: *** [world] Erreur 2

NodeJS missing in the build environment by the looks of it.

1 Like

Right in the end it compiled for me. However unless your using a WRT3200 or WRT32X with firmware compiled for neon-vfpv3 there is no point in sharing the ipk's

i have add node.js in my debian

but i have not found parameters in Menuconfig -> Language -> Node.js ???

found ??? i think node.js is not supported for ramips

parameters exist but for anothers Target System as for Allwinner A1x/A20/Axx/R40 or BroadCom27xx ...