5GHz Low performance on TP-Link Archer C6 V2


Please let us know how it goes with the last version.

Waiting to hear about it to flash mine.

Thank you!

As I wrote before the newer releases included the official one is fine with 5Ghz performance. Was fixed some month ago with a snapshot with my router.

1 Like

I tested 21.02.1, unfortunately issue with 5Ghz performance is still not fixed. In my case C6 is configured as Access point NAT is not used at all.

I run 21.02.1 and can hit 500Mbit/sec in iperf3 on C7. (with overclock and only to local iperf3 server, using 2x2 device on 5GHz). I can see from your screenshot that you are not using iperf3 but some sort of "internet speed" app. So you are not measuring 5GHz performance, you are measuring performance of complete chain, including router/NAT/firewal/WiFi etc.

1 Like

internet connection is not the issue while we see CPU is stuck in sys IRQ, same result is with iperf (two computers in same 1G LAN network):

My NAS reaches 56Mbyte/s through WI-FI. That far enough compared with the speed before.

Run iperf3 server on local machine (preferably a PC). Run iperf3 client on a mobile device capable of running 2x2 on 5GHz (for example, newer iPhone). Make sure your AP is using 80MHz channels on 5GHz and that measuring device is near the router.

Measure throughput and report back.

Unfortunately I do not have iphone at all, my setup look like this - two computers, first machine is connected over Ethernet, second to LAN network over 5Ghz network. I tested with different radio client and result are the same.

Radio RX/TX rate parameters connection:
866.7 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 2, Short GI
866.7 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 2, Short GI

iperf3 no big difference to iperf:

That is basically what you can expect from single core QCA9563 @ 775MHz entry level router. 35MB/sec is a good speed. You can always try to overclock it. Performance scales in linear fashion. My C7 (using QCA9558) will overclock to 1GHz and at that point, CPU and WiFi curves intersect and there is couple of CPU % left.

Max performance is about 350Mbit/s due the slow CPU

Tested with iperf3 between two computers

bridge mode
CPU load at 100 percent during the test (in Archer C6v2 router)

DOWN: 250-300 Mbit/s
UP: 350-400Mbit/s

Yeah, it is CPU bound. But as I said before, 30MB/sec on WiFi is really good for what it is: a low-tier single core 2x2 .ac router.

tried this router as mesh ap on 5ghz. Performance is terrible.

Is anyone still having issues with 5Ghz wifi performance when using the latest OpenWRT firmware: 21.02.2 ??? I bought this router today, thinking that it has no real wifi issue until I happened to bump into this forum link during a Google search. :roll_eyes:

It is not that fast compared with more powerful routers like R7800 but as you can read in the last post the general issues is solved. But it is still a slow router because of CPU and not used hardware offloading.

Thanks for replying.

I am not expecting a cheap router like this Archer C6 to outperform an expensive router like R7800.

I am interested in the 5GHz performance throughput.

If I install 21.02.2 Openwrt firmware, does the Iperf3 performance fare better or worse or on par compared using Tp-link OEM firmware? That is my main concern here. If you have any experience in testing this router's WIFI performance on the 5GHz freq. Please share. Thank you. :slightly_smiling_face:

I am intending to use the router as an AP, with no NAT function involved, all this job is left to my pfSense router to handle it. So, whether hardware offloading is ON or OFF, should not be applicable to my case.

In my case using it also as AP only and it works flawless with up to 50Mbtye/s. But there are other experiences that it will reach 35Mbyte/s only which is also very good compared with the time before the issue was solved. You can find everything in comments in this post.

But be aware that it is not that easy to go back to OEM firmware...

1 Like

Yes, I did notice it is not easy to revert back to the original tp-link firmware

I tried as in the beginning 5Ghz was unusable and did not get it to revert. But actually it runs very fine so install it. The very small memory of the EU version is a little annoying only.

It it worth to install wrt in current status instead of tplink firmware which has no updates currently?
It is my primary router so nating and dhcp server is must have. Will be worse or better on owrt? I'm using a6 in wds bridging Mode also for extending wifi range.

This is iperf3 on C7 v2, measuring upload from my iphone. Using latest image, 80MHz 5GHz channel. 1GHz OC. Download is slightly slower (around 500Mbit/sec). I use them as dumb AP's so throughput is LAN to LAN only.

This is quite fantastic for 8 year old router and it will take long time for me to justify move to .ax