Slow lan and wifi speed

Hi everyone! Just installed OpenWRT to my TP-Link Archer C6 router. Did it because of the last situation and incoming full controll of the internet in my country (Russia). I just wanted to install a VPN on the entire router so that I could also use the VPN on my TV, and unfortunately, TPLINK routers have the only one way to put a VPN on the router,- use openWRT.
I set up a connection through PPPoE, since my internet provider connects directly through this tunnel protocol. Then I figured out how to create a wifi access point. I must also say, that I did not change any checkmarks and settings.
So, I have a problem that through patch cable speed of internet is about 180 mbps, and thgough wifi is just 70-80 mps, but before, on the original TPlink driver it was 650 mpbs through patch catble and 350-400 through wifi connection. what i have to do now, to have same speed as i had before? This settings are hard asf cuz i didnt see interfaces like this never before in my life, and dont even have engineer education xD Hope to get your help, what i have to change in the settings

1 Like

I can't offer specific support about the speed issue you are experiencing, but a few things...

Do you mean PPPoE? Most ISPs don't use VPN protocols for their connections (PPTP = a VPN protocol, PPPoE is a connection protocol for establishing internet connectivity for many types of connections).

And on the topic of VPNs -- do not use PPTP as your VPN protocol -- it is effectively useless in terms of security (to the point that it is considered unsuitable for use on the internet -- it is so trivial to hack). Consider Wireguard or OpenVPN for VPN protocols which are far more secure. Most commercial VPN providers support at least OpenVPN, but WG is becoming more popular because it is easier to configure, much higher performance, and modern/secure with a few other benefits under the hood.

As an aside (and with an attempt to stay apolitical), with the situation fast evolving both within Russia and countries beyond your borders, it is certainly possible that commercial VPNs outside Russia may become difficult to use. You'll probably need to select a VPN service that has many different international servers and that works to provide service even where governments may attempt to block such services. I don't know what the current situation is on that front and how it could change, but just something to be aware of.

Ye, im sorry, internet connection through PPPoE, not PPTP
about VPN, i have an account of VPN provider, that supports OpenVPN protocol .

Btw, i just turned ON Software flow offloading and Hardware flow offloading in firewall settings and my LAN internet speed back to the moon . May i ask one more thing, how can i create two Wi-Fi access points, 2.4 ghz and 5 ghz and combine them into one network, depending on the device and the distance from the router, as it was in the original firmware of my router?
PS sorry for my stupid question

You just configure them individually, but using the same access credentials (encryption type, PSK, country code).

1 Like

You will not get the performance line before as OpenWRT does not use some hardware offloading. But it should be better like you can see above. So perhaps change the Wifi driver and enable offloading. That is all you can do…the CPU is the bottleneck. But if I am right you got this already.

1 Like

Hey, I have the same problem, I've turned ON Software flow offloading and Hardware flow offloading in firewall settings and I'm still getting around 90 Mbps instead 300 Mbps.
I'm on 5 GHz AC and the only channel that DOESN'T do any problems is 36 (if I'm choosing AUTO or other channel, there are some devices like raspberry pi 4 that doesn't see the network)

If you have a Archer C6 router

If you're not aware,
Hardware revisions 3.0 and 3.2 using MT7621 SoC supports hardware flow offloading.
Earlier revisions only supports the software flow offloading.

1 Like

I have TP-Link Archer C6 v2 (EU/RU/JP) so do I have v2 hardware version?
If not, how can I know?
Is the drop of speed expected?

More on my problem:


another Image: https://forum.openwrt.org/t/5ghz-low-performance-on-tp-link-archer-c6-v2/73107/67?u=ashr123

root@OpenWrt:~$ cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option country 'IL'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'Roy&Karin'
	option encryption 'sae-mixed'
	option key 'EngineeringPoyke'
	option wpa_disable_eapol_key_retries '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT40'
	option country 'IL'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'RoyAndKarin'
	option encryption 'sae-mixed'
	option key 'EngineeringPoyke'
	option wpa_disable_eapol_key_retries '1'
royash@Roys-MBP ~ % /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport -I
     agrCtlRSSI: -35
     agrExtRSSI: 0
    agrCtlNoise: -92
    agrExtNoise: 0
          state: running
        op mode: station 
     lastTxRate: 780
        maxRate: 867
lastAssocStatus: 0
    802.11 auth: open
      link auth: wpa3-sae
          BSSID:
           SSID: Roy&Karin
            MCS: 9
  guardInterval: 800
            NSS: 2
        channel: 36,80

My ISP gives me 300 Mbps download and 30 Mbps upload.
In addition, when I choose in openwrt the frequency to be on auto mode, the network doesn't appear on my raspberry pi 4.

Is there any way to improve the download speed?

It looks to me like your uplink (from your C6 to your modem/ONT) is running at 100Mbps, not gigabit speeds. If that is the case, check the cables.

With cable:



OpenWrt 22.03.2, r19803-9a599fee93

Ok... that >100Mbps speed means my earlier assumption was incorrect. Nevermind that issue.

1 Like

So... do you have any suggestion? :slightly_smiling_face:

Correct.
That router uses Qualcomm Atheros QCA9563 not a MediaTek SoC.
It is not even a dual core.
Hardware flow offloading is not supported.

The original factory tp-link drivers resulting in 650 Mb/s was very likely due to proprietary hardware flow offloading being implemented and no VPN running.
Running a VPN on a typical consumer router will cause massive drop in throughput, whether using stock firmware or thirdy party firmware.

So, just to make sure, you're saying that because OpenWrt lacks TP-Link's proprietary drivers, and there isn't support for hardware acceleration, I'm stuck (pun intended) on ~90 Mbps on WiFi and ~170 Mbps via cable...

That is correct.

I'm not using VPN..
I've changed the minimum I needed (connecting to the carrier via PPPoE), changed DNS forwarding settings (running 𝜋 Hole on Raspberry pi), WiFi on WPA2/WPA3 40/80 Mhz... nothing special, unless you have any idea...

I am not familiar with the QCA9563 SoC but your 180 Mb/s results is somewhat lower than I would expect, considering VPN is not implemented.
NB: Just enable Software flow offloading and view results.
NOT Hardware flow offloading.

You may want to wait for others more familiar with QCA9563 to comment about the throughput results.

EDIT: Just remembered that you use PPPoE protocol. That would take up resources on your router and lower throughput; compared to DHCP.

1 Like
  1. Why PPPoE takes more resources? how much more?
  2. I don't think I have a choice...

150-200 MBit/s is in line with expectations for ath79, PPPoE is a significant burden on top - software flow-offloading might help a little, but the limits are still there.