23.05.0 Update breaks WAN - RT-AX53U/1800U

Same issue as I tried once with latest release for 22.03.5-rc4
It seems that issue comes back with every update.
I got back to Stable 22.03.5 release again.

1 Like

I can confim, I noticed the same WAN interface problems with version 23.05.0.
No problems with 22.03.5.

This is the original post which the OP is referring to, but it got automatically closed:

1 Like

Anyone know if 23.05.2 fixed this? I don't see any mention of it on the changelog

I don't know exactly what the original issue was but I just installed a virgin RT-AX1800U with OpenWrt 23.05.2.
Under network I have a Wireless page. It shows me the radios and a list of associated stations.

I picked up the image from https://downloads.openwrt.org/releases/23.05.2/targets/ramips/mt7621/ (the wiki page of the device still lists 23.05.0 as the latest version)

Note that I did not modify the image in any way. I just flashed the factory image using mtd-write on my new AX1800U

Does the WAN port work? That's what the wiki page said was broken.

Does the WAN port work? That's what the wiki page said was broken.

Yes it does. I connected the router through the wan port and connected my phone to the wireless. The phone gets the connection and can use it.
I also connected my laptop to the lan port and the laptop also gets an active internet connection. Actually that is what I am using to type this.

Note that I used the factory image as provided. I did not use the firmware selector or so

I am also using it as a fiber modem. Can I switch from version 22.03.5 to version 23.05.2 smoothly, Is Wi-Fi problem solved?

yesterday, after I upgraded it to 23.05.2, the internet stopped working. then I downgraded to 22.03.5 and it worked again. I use pppoe:
pppd[3325]: Remote message: Too many sessions^J
pppd[3325]: PAP authentication failed
pppd[3325]: Connection terminated.

After flashing 23.05.2, the WAN port and Wifi tab seems to be both working fine on my device.

However, the network performance is horrendous for some reason. I can barely get 150Mbps down on my 500Mbps connection with speedtest.net, and only ~350Mbps on local gigabit crossing VLANs using iperf3. Even when I reset the settings and configured it as a dumb AP/switch connected to a Rpi4 router, I still get similar degraded speeds for the local connection.

Downgrading to 22.03.5 doesn't have these issues, at least as a dumb AP/switch. Getting ~450Mbps with WAN and ~950Mbps on local gigabit across VLANs, so I guess I'll stay on 22.03.5 for this device.