2.4 GHz and 5 GHz under the same SSID or separate ones?

I have not had previously a router with AC (5GHz), so I am novel using that frecuency.

You can configure both channels using the same SSID and password, in openWRT.
It seems to work, you see only one wireless net, but when you connect it seems that the device uses both frequencies.

But in my informal tests, it seems that speed suffers a bit.
If I use a separate SSID_5G (80MHz wide) the speed seem to be higher.
I am correct?

The 2.4 GHz channels are quite busy near me.

Which are the pros and cons?

Thanks in advance for any comment.

Do you have any evidence that supports that? I would think that the client device will connect to one of the networks but not both. I believe most typical client devices (i.e. laptops and phones) will work on one band or another. Some (or most) dual-band router clients could connect to both though.

Anyway, generally speaking, 5 GHz will be faster at close range, while 2.4 GHz will have longer range. So if you want you client devices to roam between the two, you can have the same SSID, but selecting which band to connect to will be left to the device, however smart or dumb it's. If, on the other hand, you would like to have control of forcing a particular band at a time, then you would need to make different SSIDs.

If your 5 GHz provides good coverage in your house, and all your devices support 5 GHz, you can turn 2.4 off altogether.

You can set them to same SSID, clients will choose which one to connect.And you should config roaming for better efficient. (Need wpad instead of wpad-mini tho)

This is my config:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '1'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
	option htmode 'HT40'
	option country 'VN'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid <My SSID>
	option key <My secret key>
	option encryption 'psk-mixed'
	option ieee80211r '1'
	option mobility_domain 'e612'
	option ft_psk_generate_local '1'
	option ft_over_ds '1'
	option pmk_r1_push '1'
	option wps_pushbutton '0'
	option network 'lan'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option country 'VN'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option ssid <My SSID>
	option key <My secret key>
	option encryption 'psk-mixed'
	option ieee80211r '1'
	option mobility_domain 'e612'
	option ft_psk_generate_local '1'
	option ft_over_ds '1'
	option pmk_r1_push '1'
	option wps_pushbutton '0'
	option network 'lan'
1 Like

Thank again for your time and kindness.

The router documentations says that it can use both radios combined to get 1200 Gb/s.

When I use the same SSID the speed tests seem to give lower results.

But I don't trust the speed test I am using.
It gives erratic results (may be due to the crowded wifi) and uses internet to do the test.

I am getting 6-8 mb/s upload and 17-20 download.

How may I make a trustable speed test locally to measure just wifi speed?

It seems more appropiate to use two SSID and be sure what you are using.

Thanks, it seems we have posted at the same time.

So you think It is better to use same SSID and activate mobility…

I am using Same SSID and password in the 2.4 GHz with another router in order to be able to do roaming when I go from one place in the house to another place.
And it seems to work.

But I did not know that I should configure a mobility ID...

I have installed wpad and uninstall wpad-mini.
In luci interface under wireless security, I have checked "802.11r Fast Transition" in 2.4 and 5 GHz and checked thy have the same MDID.

So you think best option is to use same SSID and password and configure same mobility_domain in 2.4 and 5 GHz, and I guess I should do the same in the other router.

Thus each client would select best channel in each moment… am I right?

How may I measure wifi performance in a trustable way?

Radios near me are changing their channels frequently (seems they are all configured as auto channel). So I get very different speeds each moment.

I am using auto too, as if I configure a fixed not crowded channel now, in a few moments i can be the worse channel.

I have made this config:

2.4 GHz

SSID openwrt
PASSWD pass
channel auto
power auto
channel width 40 MHz (not forced if channels overlap as there seems to be compatibility issues if you activate it)
legacy 802.11b rates: off
Fast Transition: enabled
MDID: e4e4

5 GHz

SSID openwrt
PASSWD pass
channel auto
power auto
channel width 40 MHz (not forced if channels overlap as there seems to be compatibility issues if you activate it)
legacy 802.11b rates: off
Fast Transition: enabled
MDID: e4e4

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/soc/a000000.wifi'
        option disabled '0'
        option legacy_rates '0'
        option country 'ES'
        option channel 'auto'
        option htmode 'HT40'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'platform/soc/a800000.wifi'
        option htmode 'VHT80'
        option country 'ES'
        option legacy_rates '0'
        option channel 'auto'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option key 'password'
        option wpa_disable_eapol_key_retries '1'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option mobility_domain 'e4e4'
        option ssid 'openwrt'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'openwrt'
        option network 'lan'
        option encryption 'psk2+ccmp'
        option key 'password'
       option wpa_disable_eapol_key_retries '1'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option mobility_domain 'e4e4'

Using a mobile and WI-FI sweetspots app (now CloudCheck) I have meassure about 150 Mbps -53 dbm, much better than the about 80 Mbps -41 dbm I get on my other router.

Luci in the wireless interface tells me its connected in 150 Mbits 40MHz through the ac interface.

But it is far from the 866 Mbps promised by the router.

I suppose this is due to limitations in my mobile radio, that I am using for testing.

am I correct?

no, this is marketing vs reality

150mbit real-world throughput per spatial-stream is ok.

just having the two bands on same ssid/pw without any special sauce is the best option imo.
create a bridge over the wifi-interfaces and you got seamless roaming.

I've been making tests and config combinations with no success.

I have been testing many channels in 5GHz, separating the 2.4 an 5 GHz, but I could not improve the !50 Mbps maximun, that I get from Android app seetspots.

More or less the same than when I use 2.4+5 GHz in the same SSID and a mobility domain.
2.4 GHz configured as 40 MHz (but it only uses 20 MHz as there are too many overlapped nets) and 5 GHz configured as 80 MHz (in a channel that there is nobody or at least sometime one ssid with low poser detected from my site).

I have configured two separate networks (2.4 and 5 GHz) in order to be able to detect easily which one am I connected to.

I get 150 Mbps measured in my mobile with sweetspot in the 5 GHz and about 60-70 in the 2.4 GHz.

In 5 GHz I just get about 145-150 Mbps using this program.

I have tried with my laptop with windows 10.
Windows says that it is connected with 866 MHz (that is what says the properties tab of the wifi device). Sometime less (500 or 600).

The luci interface of the router says I am connected to wlan1 with speeds that usualy vary from 500 to 750 MHz or so.

But I have measured the real speed using NetIo a client/server program that just sends TCP packets between my laptop (as client) and a PC connected trhough 1 Gbit ethernet to the router.

The program gives me just 6 MBytes/sec that are at most 60 Mbps.

That is a ridiculous speed for a router that promises 866 Mbps.

Under 2.4 GHz I get 20 or 3 Mbytes/s.

I would have expected about 4 times that speed, at least.

In 5 GHz? I would have expected 300 MHz at least, in a channel not saturated.

Any way you that should be about 15 Mbytes/s file transfer and I get just 6.

I am trying to detect why.

Once I have got a decent connection, I will configured the nets as you, @danghuy1994 and @Hegabo recommend, both under the same SSID and with the same MMID.

And when I get my new router from the ISP (that will be in the other part of the house, to get wifi there) it will be configure the same way, with the same MDID if I find the way to configure the MDID in it or to get the MDID it is using.

My old two routers were under the same SSID and same config, but I did not use the MDID (web interface of the routers had no way to configure that).
I was able to move from one place to another with my mobile or laptop, and it changed the wifi AP.
But it will develope better with MDID.

Drop 802.11r for now as there are many other parameters configured and it is unlikely your ISP-supplied router even supports it, not to mention configures it the same way. 802.11r is not required for roaming and is supported by very few clients. Auto for channel does not change the channel dynamically.

The speed “problems” may be the clients. Very few are even multi-stream. None that I know of are multi-band at the same time. Mobile clients and even laptops/desktops may not be able to source or sink gigabit rates.

Might consider iperf3 to test with on two desktop/laptops. Running on the router is well known to be inaccurate due to CPU load. I’d expect phones have similar issues.

Disabling legacy rates may help. Ensuring you haven’t disabled a feature required for 802.11ac is also worth a check.

OK, so you think it would work better with no roaming activated, just the same SSID and password, due to compatibility problems with client and other router firmware.
That is how I had it configuered till now in my ISP gateway and my DD-WRT router, and it worked, may be not so quick changes from one AP to another, but it worked.

I have some experience in wired networking but no so used to wifi configuration.

When you say "multe-stream" what are you meaning?

My FritzBox ac router is supposed to provide 866 GHz in a 80 MHz channel under 5 GHz.
Combining it with the 2.4 GHz they say 1200, but that seems to be marketing as ac wifi does not combine both frequencies under one connection, you connect to one or the other ( wifi x seems to do that and marketing says you can use 2.4 GHz for mail or web navigation and 5 GHz for streaming, but I don't expect that).

My laptop seems to connect correctly using 866 MHz, but the real speed seems much, much lower.

I have legacy rates disabled (802.11b) in both 2.4 and 5 GHz.

I have used a client/server program similar to iperf3, runing in my laptop and a PC (a capable one) with 1 Gbit wired ethernet. And I get 6 Mbytes/s.

I will try with iperf3 if I can have it working.

The high rates spec-ed by 802.11ac and, arguably deceptively, advertised in aggregate by manufacturers come from two "real" things:

  • Higher-order modulation on a per-stream basis
  • Multiple streams per station

In both cases, if the client doesn't support the features of the AP, they can't be used. This includes bandwidth, modulation type, and number of streams, among other things.

802.11ac, under perfect laboratory conditions, and not including overhead can support modulation bit rates up to:

  • 86 Mbps on a 20 MHz channel
  • 200 Mbps on a 40 MHz channel
  • 433 Mpbs on an 80 MHz channel
  • (160 MHz channels basically are unusable anywhere outside of the lab)

per stream. So a claim of "866" suggests that you've got a 2-stream device.

In real-world operation, getting roughly half of these rates for throughput under high-SNR / strong-signal conditions is typical.

Note that even with an 80 or 40 MHz channel, when it comes time to transmit, it will fall-back to 40 or even 20 MHz in the presence of interference at that moment.

That you're seeing 100-150 Mbps throughput seems very reasonable for a single-stream client on a 40/80 MHz channel, especially in what you've described as a congested area. You're fighting for time slices will all your neighbors and 802.11 is basically a "listen for quiet before talking" scheme.

Note also that many devices don't support 802.11ac, even as recent and popular as things like the iPhone 5. 802.11n only supports up to 72 / 150 Mbps modulation rates.

If a "short guard interval" isn't working (channel congestion is a common reason for this), the radios may fall back to a standard guard interval, which will reduce throughput as well.

Since I've never heard of "Netlo" and can't easily find it with an Internet search, I don't have any confidence in it as a benchmark tool. There are a lot of mobile/phone/GUI apps out there that supposedly provide useful information. At least in my opinion, very few if any of the consumer-targeted ones have much value to diagnose anything, even if they do provide pretty pictures and a warm, fuzzy feeling for users. Hence the recommendation to use something "standard" like iperf3 that is reasonably well-known by the networking community.

2 Likes

Thanks a lot.

But the congested net is in the 2.4 MHz, the 36 channel in the 5 GHz is free most of the time, I am the only SSID there.

I have expected something between 300 an 500.

Both, my mobile and my laptop support wifi ac, as denotes being able to connect to the 5GHz ssid when i separate 2.4 and 5 GHz nets. And I can scan 2,4 and 5 GHz with ten wifi scanner apps.

Link in the laptop says it is 866 and in the router it says betwwen 500 and 800 at 80 MHz I think dependending in the emission power at the moment.

Getting 6 Mbytes at the end seems too scarce.
I don' t know where to start looking.
Netio https://sourceforge.net/projects/netiogui/
I will try iperf3.

Thos is the network congestion in 2.4 GHz, the filled orange curve is my network.

And this the 5ghz channel congestion, mine is the filled green curve:

Good that you're using a wifi analyzer to check your neighborhood spectrum. That's always a good first step. But, why are you still on ch6, on 2.4? :slightly_smiling_face:

Looks like youre on 20 and 40mhz bw, and that looks optimal for where you and your neighbors are currently laid out.

FWIW, I get 60-80mbit on 2.4, as much as 280mbit on 5ghz, with a C7 on a 300/30 cable connection. A C7 is a 3x3 radio, I think all my client things are 2x2 at the most. My bw settings are 20 on 2.4 and 80 on 5ghz.

I didnt think that there was an auto bw function that would drop you back if interfered with? Hence the common reccomendation to not even bother w 40mhz on 2.4, if its busy. All devices supposed have that feature, or only some?
Probably better to not have it toggling between bandwidths as neighborhood traffic goes up and down. I'd guess it would have to drop the link or at least pause while things reconfigured and synced up. More slowing down...

BTW, nice wifi analyzer... :slightly_smiling_face: is that available?

I have been reading about the best channels in 2.4 GHz

It seems that it is recommended to use 1,6 or 11 only, as they do not overlap.

But everybody around me seems to be using auto channels (they jump a lot) and the routers configuring intermediate channels (8,4, 10, etc).

So I ended up using auto, and openWRT decides usually that 6 is my best channel and does not change it often.

As you say I have activated 40 MHz channels, just in case one day my neighbours are not using the wifi, but the router usually connects only 20 MHz channel as it is imposible to find two adjacent channels.

I am getting 70 Mbps in 2.4 GHz, not so bad if you take that crowded environment in mind

The problem is the 5 GHz channels, that should get much better speeds, as it is not crowded at all.

Thant wifi net analyzer is netstop for windows.
You can get in in the windows store and as a traditional executable with intalation from their web.

I have been testing from my laptop and the desktop pc (wired 1 Gbit) with iperf3 for windows (last version for 64 bits).

I get more or less the same results, about 60 Mbps

This is what the router says about the wireles connection from the laptop:

You can see the link says more than 500 Mbps, it changes over time, other times says 750, I think it changes as the power emisión changes, when there is no activity.

While testing, it rises till maximum 750, sometimes 866.

But iperf3 gives you very low transfer speeds

I have tried from my wife's laptop with similar results 50-60 Mbps this is what luci reports while transmitting

Actually, it only means that it supports 5 GHz, as the AP will fall back to "n" (or older)

if the client doesn't support ac. Case in point is the iPhone 5, which will connect to an ac-capable AP, though without any of the new features ac provides.

Yes, that is the general recommendation, even where four channels can be used, as "most" home devices still seem to stick on 1, 6, or 11.

As it is crowded on 2.4 GHz, you might as well give in and start with 20 MHz channels. At least in my experience, having co- and adjacent-channel interference only 10-20 dB down will result on nothing more than 20 MHz bandwidth being used. The "spectrum analyzer" apps generally just draws pretty pictures of what the beacons offer, not that your neighbors' APs are actually using 40 MHz channels at any time.

I would look at errored packets and retransmissions. I agree that in-close (same room) on 5 GHz should be providing better than 50 mbps. However, if you're not in the same room, depending on the construction of your building, 50 mbps may be all you can get. 5 GHz penetrates even wood and plasterboard even more poorly than does 2.4 GHz

Yes I am in the same room and with strong signa, -36 -40dbm

If my client (laptop) does not support ac and only N (it is possible, I will try to investigate that), would windows still report a 866 MHz channel and luci openwrt show 700 and 800 Mbps links?

For a wifi N with 20 MHz and strong signal which is the expected speed?
It seems that it gives me 65 Mbps.

Having 150 in 5 GHz with a 40MHz channel in wifi N would be coherent with that, as it is more or less double than that (double channel width and less busy, so more than double speed).

Anyway 50 Mbps from iperf3 is very few for transfer, is the link is 150 Mbps...