19.07 BT Hub 5A: Mesh not working on 5ghz radio -> must load driver with rawmode=1 to add mesh interfaces

Tried a couple of the release snapshots. Latest was openwrt-19.07-snapshot-r10306

Mesh doesn't start up on 5ghz, but still appears to be ok on 2.4ghz radio.

Got these errors in the log after fiddling with the settings.

ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
ath10k_pci 0000:02:00.0: must load driver with rawmode=1 to add mesh interfaces

It may be is likely that you've run into that "Wave 1" chips don't support 802.11s with the -CT drivers. You might try the "plain" ath10k driver and firmware. Those are required for 802.11s on the Archer C7v2, which has a QCA9880 wireless chip.


I had tried replacing the -ct version with the other versions, and it hadn't worked, but I tried again thanks to your advice and that fixed it. I guess I must have forgot to reboot, rebooted the wrong router, or done something else equally stupid.

Mesh starts up ok and is working using ath10k-firmware-qca988x, which installs /lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin, in place of firmware-2.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.