Zyxel NBG6817 - random restarts

Hi folks,
My router is acting weird for few months. Every few days (usualy 7-14) it restarts itself. Last two restarts it wasn't able to boot successfuly. It froze during booting process and I had to powercycle it few times before it started successfuly.
Also since last freeze syslog started to show this error :

Tue Mar 10 22:29:53 2020 kern.notice kernel: [  315.354260] EXT4-fs (loop0): error count since last fsck: 38
Tue Mar 10 22:29:53 2020 kern.notice kernel: [  315.354301] EXT4-fs (loop0): initial error at time 13: ext4_xattr_block_get:533: inode 125
Tue Mar 10 22:29:53 2020 kern.notice kernel: [  315.359028] EXT4-fs (loop0): last error at time 13: htree_dirblock_to_tree:994: inode 722

Reboots (freezes) are totally random or at least I didn't find any patern. Doesn't matter if router is under heavy load or idle.

I am on 19.07.0, r10860-a3ffeb413b with latest packages installed.
Is flash memory somehow demaged and would I need a new device ?

Please try a recent master snapshot, the stmmac ethernet driver in kernel 4.14 is known to expose this problem with certain jumbo frames on the wire. This is supposed to be fixed in 4.19 (master).

Thank you.
Will do and will post restults :slight_smile:

After flashing latest snapshot at the time (r12515-ec8e8e2ef0) the error seems to disappeared. Router is so far stable, even openvpn speeds are higher (60/60 Mbps vs. 40/40 Mbps with 19.07.0).
Thank you for your advice :slight_smile:

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

I'm on 19.07.2 and experience same problem. It's very frustrating. Any tips?

Read this topic and find the solution. :slight_smile:

Sorry I tried to install the snapshot to fix this issue but it will not let me install Luci so now I am not sure what to do.

root@OpenWrt:~# opkg install luci 
Installing luci (git-20.089.25318-f89efcf-1) to root...
Downloading http://downloads.openwrt.org/snapshots/packages/arm_cortex-a15_neon-vfpv4/luci/luci_git-20.089.25318-f89efcf-1_all.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci:
 *      libiwinfo20181126
 * opkg_install_cmd: Cannot install package luci.
root@OpenWrt:~# opkg install libiwinfo20181126
 Unknown package 'libiwinfo20181126'.
Collected errors:
* opkg_install_cmd: Cannot install package libiwinfo20181126.

I've since rolled back to 19.7.02 until I can find a way to get this libiwinfo20181126 issue resolved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.