ZyXEL NBG6817 / Armor Z2 (AC2600) - Lede(openwrt) Terrible performance

I bought myself the AC2600 and i have 400/40 mbit network speed.
Bufferbloat is horrible on this device.
Besides the bufferbloat i can't even reach my network speeds.
It goes up to 400mbit then it drops all the way to 200, upload stays relatively stable between 35-42mbit.
I used my provider wifi-modem before and that one gave me 412mbit constant + 40-42mbit upload constant.

If anyone knows what i need to do with this device because i have the urge to get this back to the store because i doesn't satisfy my needs neither does it reach my network speeds.

--
I decided to install "SQM QoS"
And did the following:

config queue 'eth1'
        option enabled '1'
        option debug_logging '0'
        option verbosity '5'
        option qdisc_advanced '1'
        option squash_dscp '1'
        option egress_ecn 'ECN'
        option qdisc 'cake'
        option ingress_ecn 'ECN'
        option script 'piece_of_cake.qos'
        option interface 'eth0.2'
        option download '348160'
        option upload '34816'
        option qdisc_really_really_advanced '1'
        option iqdisc_opts 'nat dual-dsthost'
        option eqdisc_opts 'nat dual-srchost'
        option squash_ingress '1'
        option linklayer 'ethernet'
        option overhead '18'

So i took a few mbits of the original speeds resulting into this:


&

&

There is no way in hell with only 2 wifi devices(smartphone) and 1 computer with Cat6 cable that allows such drastic network speed decrease for that amount of bufferbloat.

So i come here with the question, what do i need to do now?
After 2-3 sleepless nights and actually pulling hair out of my head i'am giving up.

(BTW)
I do have some devices over WIFI but they don't require high speed network.
I am a cable guy myself need high performance over cable.

Okay, slow down. Let's try to tackle the different issues one by one instead of trying to fix all at the same time. First of all:

  1. What build are you currently running on your router?
  2. Please reset your router to Lede defaults and hook up the WAN port to your ISP. Do not install any additional packages such as SQM just yet and do not configure things you do not need for testing such as WiFi, VPNs, etc. Keep it as close to default as possible.
  3. How is the router connected exactly? Is it connected to your ISP modem? Is the modem properly configured in bridge mode?
  4. Next, connect a PC/Laptop over ethernet to one of your router's LAN ports and run some speed tests. Your router should easily route and NAT your 400mbit connection.

For reference, please also post the output of the cat /etc/config/network command.

Let's get your speeds in order before we have a look at your bufferbloat issues.

How exactly can i restart LEDE in full default?

EDIT:
BusyBox v1.27.2 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r6549-287f5ebd2f
 -----------------------------------------------------

The router is connected to LAN1 on the modem, the modem is set to bridgemode by the ISP.

@Mushoz

My ISP is ziggo.
They converted the "Connect Box - Compal" to bridge mode, I did a 15-20 sec hard reset to make sure the modem was flushed.

Now i did a full reset of the Router-LEDE nothing installed just the blank snapshot: OpenWrt SNAPSHOT, r6549-287f5ebd2f

I did a speed test just now and this is the result: http://www.dslreports.com/speedtest/31369275

That looks a lot better. A bufferbloat grade of C without SQM is nothing out of the ordinary.

  1. Do you get a steady 400mbit with the ISP provided router? The download result could be better, but that might be congestion on the ISP side of things.
  2. Could you please post the output of cat /etc/config/network
  3. And the output of ifconfig to double check that you indeed have a public IP associated to your WAN port (ie, the modem is properly bridged).
  4. Unless you have a good reason to use snapshot images, I would suggest sticking with the stable release for now. You can always start tinkering once the basic setup is working properly. Stable images for your router can be found here: https://downloads.lede-project.org/releases/17.01.4/targets/ipq806x/generic/

Make sure you use the sysupgrade image (since you are upgrading from lede to lede) and untick the keep settings checkbox.

@Mushoz

I can only post 2 links.

  1. I had a steady stable linear line 400-412mbit with the ISP provided router.
  2. https://hastebin.com/otufeweyay.go
  3. https://hastebin.com/lobidumomo.rb
  4. NBG6817-squashfs-sysupgrade.tar < that is the one i'am using right now which apparently is a snapshot?
    4.1. There was a few packages i installed and it prevented me to save settings after reboot which is reason why i use this snapshot?

This is the 4th or 5th test: http://www.dslreports.com/speedtest/31369456

Okay i came across a few issues, i tried sysupgrade through SSH and got an error:

root@OpenWrt:/tmp# sysupgrade lede-17.01.4-ipq806x-NBG6817-squashfs-sysupgrade.tar
Device zyxel,nbg6817 not supported by this image
Supported devices: nbg6817
Image check 'fwtool_check_image' failed.

Okay i fixed this issue with adding the other files required with the sysupgrade:
Kernel, rootfs. Did the sysupgrade and as expected, everytime i reboot the router it doesn't save any of my settings, like after every reboot it completely resets itself.

How to fix this issue?

@Mushoz
Okay now i have the "stable" branch installed as you suggest, but now i remembered why i used an snapshot:

So what do you suggest me to do now?

This definitely fits the following criteria :wink:

For the following tests it doesn't really matter which image you are using, but please post the result of the following commands:

  1. cat /etc/config/network
  2. ifconfig
  3. And what device are you using as your modem?

At this moment i have been going through full HELL.
After the kernel/rootfs install of the suggested branch you told me i wanted to revert back to the branch i had working stable. Since then i had no internet and STILL my internet is doing weird stuff.

Apperently my PC which is set to LAN1 is now getting the IP of the provider?

I fixed majority but with unstable stable release:

cat /etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb0:2791:f4f0::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth1'
        option macaddr '60:31:97:3e:85:b0'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config device 'wan_dev'
        option name 'eth0'
        option macaddr '60:31:97:3e:85:b1'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0'

br-lan    Link encap:Ethernet  HWaddr 60:31:97:3E:85:B0
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6231:97ff:fe3e:85b0/64 Scope:Link
          inet6 addr: fdb0:2791:f4f0::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5409 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4761 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:832786 (813.2 KiB)  TX bytes:2785950 (2.6 MiB)

eth0      Link encap:Ethernet  HWaddr 60:31:97:3E:85:B1
          inet addr:83.86.212.152  Bcast:83.86.213.255  Mask:255.255.254.0
          inet6 addr: fe80::6231:97ff:fe3e:85b1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:22404 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2485 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3185916 (3.0 MiB)  TX bytes:440561 (430.2 KiB)
          Interrupt:29

eth1      Link encap:Ethernet  HWaddr 60:31:97:3E:85:B0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5457 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5129 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:912500 (891.1 KiB)  TX bytes:2807764 (2.6 MiB)
          Interrupt:30

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:128 errors:0 dropped:0 overruns:0 frame:0
          TX packets:128 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:11929 (11.6 KiB)  TX bytes:11929 (11.6 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:34:56:78:92:92
          inet6 addr: fe80::234:56ff:fe78:9292/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:448 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:141735 (138.4 KiB)

wlan1     Link encap:Ethernet  HWaddr 00:03:7F:12:09:09
          inet6 addr: fe80::203:7fff:fe12:909/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:442 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:139886 (136.6 KiB)

Modem device: Connectbox Compal(ziggo)

Have you tried to downgrade to chaos calmer (in case your device was supported back then)? CC is way faster than lede, but way slower than BB which is still way slower than AA. I think this is called progress :wink:

Besides the obvious security implications, ipq806x as a arch itself wasn't supported in the stone age (including CC) of OpenWrt - not even talking about support for the specific device.

I'm not saying to use stone age version, just to try it. And I'm not saying lede is bad because it is new. There's just some new feature optimized really badly. If develepores will care, I'm sure it can work same as before. Compare how windows and linux run on old hardware - just because linux developers cared and MS did not.

To spell it out again, the ipq806x architecture wasn't supported at all before 17.01.x - it didn't exist in CC and before. Support for the particular device in question even requires snapshots (backported to lede-17.01, so it will be fixed in 17.01.5) to get a persistent overlay (read, to retain your configuration over a reboot).

Even if you wanted to try try it, disregarding basic security, there are no images for CC, BB or AA - neither the SOC, nor the devices themselves existed in 2015, 2014 or 2012.

After some stressful calling to the ISP checking out the wifi-modem, plus checking the possible cable/network adapter issue i got the router to update kernel/rootfs and sysupgrade to the snapshot again.
17.01.4(stable) is the worst firmware for this specific router.

But apparently there are some network issues with either the wifi-modem/wall cable, but that doesn't take away the massive SQM takeaway speed..

Tested speeds right now which is because of the modem : 300/40.
with SQM (Not tested yet) it will go down straight to 90-120/40 < which makes zero to no sense if i have a 400mbit package.
I did some more DSL report research and i found this guy: http://www.dslreports.com/speedtest/31368309
That guy has the Ziggo business package which is 500/50 and look at that insane bufferbloat/speed....
I can not figure out who this person is or what hardware he is using, but i for sure want to taste that hardware for my own needs or if you guys can figure out what is going on with that guy.

What are your SQM settings? Check the output of "cat /etc/config/sqm" if you don't have sqm in luci. Make sure your download and upload are set correctly. Example:

option download '100000'
option upload '10000'

This would limit you to a max of 100/10. Make sure these aren't accidentally set low.

Another thing is did you compile your firmware with irqbalance? If not I recommend you do. It helps balance the load across both cores of your NBG6817.

Finally if you want to see the build I'm using you can get it here. I have a lot of stuff you don't need but you could use it to see if irqbalance makes a difference.

Hey just woke up, i have to wait for my ISP to send my new modem since there are some network issues.
The modem will come in the next coming 6-8 hours.

But no, i did not compile my own firmware, i used the latest push they did for this one ( snapshots ).
My settings for sure was correct these we're the settings:

config queue 'eth1'
        option enabled '1'
        option debug_logging '0'
        option verbosity '5'
        option qdisc_advanced '1'
        option squash_dscp '1'
        option egress_ecn 'ECN'
        option qdisc 'cake'
        option ingress_ecn 'ECN'
        option script 'piece_of_cake.qos'
        option interface 'eth0.2'
        option download '348160'
        option upload '34816'
        option qdisc_really_really_advanced '1'
        option iqdisc_opts 'nat dual-dsthost'
        option eqdisc_opts 'nat dual-srchost'
        option squash_ingress '1'
        option linklayer 'ethernet'
        option overhead '18'

Which basically sets the speed to what i was gaining with speedtest.
BUT i will try to install your google stuff now and see what happens.