ZBT Z8103AX-D: upgrading from 21.02 to 23.05

Thanks for that info. I have now recovered the router and can login to lede web interface.
Connect UART cable. in Mac terminal "screen /dev/tty.usbserial-11240 115200 "

  1. Clear Uboot environment variables:

Repower the device and press "0" during the uboot countdown. It will enter the command line mode.

##Compatible with 64M

Enter the command accordingly:

env default -f -a


setenv mtdparts nmbm0:1024k(bl2),512k(u-boot-env),2048k(factory),2048k(fip),nmbm0:1024k(b12),512k(u-boot-env),2048k(factory),2048k(flip),265536k(INTERRUPT)

setenv mtdparts nmbm0:1024k(bl2),512k(u-boot-env),2048k(factory),2048k(fip),65536k(ubi)

Then on the uboot menu I selected the 'start web falisafe ', connected browser to, upload the vendor supplied Z8103AX-W_V23.06.28_wifi6.bin file.
Now the router is back to normal.
Next step is to upgrade to pure Openwrt image. Any links to the correct image file? or is it not ready yet?

Good news. The latest snapshot build from OpenWRT (openwrt-mediatek-filogic-zbtlink_zbt-z8103ax-squashfs-factory.bin) succesfully loaded. Luci and luci-ssl, etc. all added on. all fine.

Now back to more research.

1 Like


I'm an absolute beginner and I just purchased a Z8103AX-D router these days.
I selected it because it has openwrt and I intend to implement NordVPN on it (Nord VPN propose an how-to for openwrt using Luci).

When I connect it, the interface is labeled as Z8103AX-W and looks as follow. It's not Luci interface. The firmware version is 23.11.02.
As it's not Luci interface, that's seems not ok to follow the how-to for NordVPN.

Is it possible for me to change the firmware and interface ? There is an "update" option to do so, but I'm not so confident in my skills and fear to block the device :slight_smile:...

I tried to connect with SSH from my Windows 10 on the device to have a look on it, but I experience some trouble (I think because it's the very first time I try SSH :slight_smile:) :

I type : ssh holiv@ (my name and the device address), the ssh asks for a password. I tried the device password but it doesn't work. Something seems special for me : on password line, there is no return from keyboard.
Then after 3 attemps the ssh disconnect, is it normal ?

I know my questions may be very simple, but I'm really an ABSOLUTE beginner :smile:.

Thank you for your help.


Contact the manufacturer and request an updated version of the firmware

The version of the firmware is the latest version from the manufacturer.

The problem I have is that this firmware GUI don't have any option or add-on to allow openvpn I need to implement my NordVPN on this router.

I just want to replace if possible the firmware by standard openwrt with Luci in order to be able to follow the NordVPN howto, see here :

By reading this topic, I've seen darknblack for example, succeeding to replace the firmware by another one. So I need some help to do so :wink:.


It would be great if you can comment the specs of your router here.

My router, a Z8103AX-D, came with the same OS (Intelligent Router) as yours when the seller shipped it to me. So there's a chance it would work just fine. You could also ask the seller whether to know whether there's a difference between those two variant.

Send us a picture of your router as well for reference for people out there :slight_smile:

I think it's the same model as yours : Z8103AX-D.

I just looked at the seller's page, and it seems I could have order it directly with an OpenWRT firmware :wink:. Unfortunately I didn't see the advice from the seller, so I'll have to change it...

Here are the specifications of the router (as described on aliexpress at the supplier page). more infos on the seller's page. There is also some photos on this page.
I'll send one of my device in the next message.

Z8103AX-D router

  1. Adopt MT7981B+MT7976CN solution, dual-core ARM Cotext-A53 CPU, main frequency up to 1.30GHz
  2. Adopt independent WIFI chip, 2.4G is QCN5022, 5.8G is QCN5052
  3. Up to 3000Mbps, 2.4G wifi rate up to 1200Mbps, 5.8G wifi rate up to 17500Mbps, support MU-MIMO
  4. 128MB NAND Flash + 256MB DDR3 RAM
  5. One-click mesh connects more routers and covers a wider WiFi range.
  6. 6 antenna supports MU-MINO, uses network speed quickly, and supports 128 device connection.

WIFI6 Product's Feature

  1. Support setting"one-click flash mode"
  2. Wireless signal covering 360-degree corner
  3. 2* 5dbi External omnidirectional 2.4G antennas, 2* 5dbi External omnidirectional 5.8G antennas
  4. 1* WAN, 3*LAN ports 1000Mbps support auto MDI/MDIX, Meet IEEE 802.3/802.3u/802.ab Protocol
  5. Size LWH = 17122047.5 mm


  • 5G Wi-Fi Transmission Rate


Wired Transfer Rate


  • Wi-Fi Transmission Standard


2.4G Wi-Fi Transmission Rate


  • Wi-Fi Supported Frequency

2.4G & 5G

Supports WPS


  • Supports WDS


Number of USB Interfaces


  • WAN Ports

1 x10/100/1000Mbps

LAN Ports


  • Function




  • Package


Standards And Protocols

Wi-Fi 802.11g,Wi-Fi 802.11b,Wi-Fi 802.11n,Wi-Fi 802.11ac

  • Max. LAN Data Rate


With Modem Function


  • Type


Brand Name


  • CIOSWI Model



Mainland China

  • Certification



Z8103AX-D router

  • Wifi type

wifi 6 , MESH

Wifi rate

Up to 1800Mbps

  • SIM Card

no support

Z8101AX-D Ram


  • Z8101AX-D Flash

128MB NAND Flash


3 x 1000Mbps LAN

  • Feature

Dual-band 2.4G + 5.8G


IEEE 802.11n/g/b/a/ac/ax , IEEE802.3/802.3u/802.ab

  • 6 antenna

5dbi antenna

I also had gone thru same issues, and successfully loaded the latest snapshot build of openwrt, after getting this link in this same thread.
ZBT Z8103AX-D: upgrading from 21.02 to 23.05 - #61 by Justinhei
So as the first step can you try to get to the Uboot web page by following the steps in page 4 of the linked document, which goes by:

  1. Set the PC’s IP address to 192.168.1.x;

  2. Press and hold the reset button, then power on the device. You can use the cmd window to ping the IP address of After about 10 seconds, the ping will be successful. At this time, you can release your hand;

  3. Open the browser (it is recommended to use the Google kernel browser), enter the IP address as in the address bar,

Hi joshymg,
thanks for your help !

First comment and question :
There is this "upgrade" page on the seller's GUI, can I use it and flash an openwrt firmware ?

if yes, where can I find the proper file to get a standard openwrt and Luci GUI firmware ?

if not : I'll try to follow your advice. Some "absolute" beginner's questions :wink: :

  • what is "PC's IP address" ? the IP address of the router ? how to "set" it ? what means "x" on the latest digit 192.168.1.x ?

If it's the IP address of the router, mine has the address. I tried to change it to with the seller's interface, and the router don't want ! At the end it takes the IP again...

  • can I use the present IP for the following ?

if ok, question about point 4) of the howto : where to find the proper file for flashing to standard openwrt and GUI ?

Thank you :wink:


precision on my laptop system :

Windows 10 64 bits

Hi @darknblack,

Some pictures of my Z8103AX-D router, and some questions :wink:

The box

The model

The router in place

Questions :

  1. I found this release on the Openwrt firmware selector :wink:

Is it possible to upgrade the router with the factory image, using the seller's "intelligent router" upgrade option ?

  1. Another question :wink:

I don't understand why, but the router IP is instead of as written on the box label.

Maybe because it's after the optic fiber router from my internet supplier (Nokia white box just beside the Z8103) ???

I tried to change the Z8103 IP address to from the seller's GUI, but the router doesn't accept and automatically return to IP

Thank you,


Thank you :wink:


I'd like to share more of my experience with upgrading its firmware. I've had two units, one ordered from AliExpress in Feb-March last year, and another purchased in May-June last year.

Successful Upgrade of Second Router

My second router is working fine after upgrading to OpenWRT snapshot using the openwrt-mediatek-filogic-zbtlink_zbt-z8103ax-squashfs-factory.bin file. Here's how I did it:

• Connected a UART cable to access the terminal
• Discovered the "U-boot web fail safe" option, which allowed me to upload the firmware via
• Successfully upgraded the router, and all is well

However, I'm still unsure if there's a way to activate the U-boot web page without a UART cable. If anyone has a solution, please share!

Challenges with First Router

When I tried to replicate the process with my first router today, I encountered issues:

• Couldn't access the "U-boot web console" in the boot menu, despite multiple attempts
• TFTP upgrade with the same firmware file failed

It seems that the U-boot configurations on both routers are different. Can anyone help me figure out how to access the "U-boot web" page on my older router?

1 Like

Hi Guys,

I also joined the "club" as I bought 2 of this router :slight_smile:

I received it with LuCI installed 21.02 (Powered by LuCI openwrt-21.02 branch (git-22.245.77575-63bfee6) / OpenWrt 21.02-SNAPSHOT unknown 23.1116_062920)

One strange thing I noticed after I opened the case that only 4 antennas are connected, the "A-WF2" is not soldered as it is visible eg on @darknblack 's photo.

I tried to update the firmware with "UART - U-boot web fail safe" method as it was working for @joshymg so I downloaded the factory image (openwrt-mediatek-filogic-zbtlink_zbt-z8103ax-squashfs-factory.bin) from the Firmware Selector but after the update it stuck in a bootloop state :frowning:

Based on the boot log it seems there is an issue with the UBI(?) volume:

[    0.965104] ubi0: default fastmap pool size: 25
[    0.969642] ubi0: default fastmap WL pool size: 12
[    0.974421] ubi0: attaching mtd4
[    1.156532] ubi0: scanning is finished
[    1.160309] ubi0 error: ubi_read_volume_table: the layout volume was not found
[    1.167614] ubi0 error: ubi_attach_mtd_dev: failed to attach mtd4, error -22
[    1.174703] UBI error: cannot attach mtd4
[    1.178816] clk: Disabling unused clocks
[    1.183496] /dev/root: Can't open blockdev
[    1.187617] VFS: Cannot open root device "" or unknown-block(0,0): error -6
[    1.194564] Please append a correct "root=" boot option; here are the available partitions:
[    1.202915] 1f00            1024 mtdblock0 
[    1.202920]  (driver?)
[    1.209442] 1f01             512 mtdblock1 
[    1.209447]  (driver?)
[    1.215969] 1f02            2048 mtdblock2 
[    1.215973]  (driver?)
[    1.222490] 1f03            2048 mtdblock3 
[    1.222494]  (driver?)
[    1.229015] 1f04           65536 mtdblock4 
[    1.229019]  (driver?)
[    1.235534] List of all bdev filesystems:
[    1.239539]  ext3
[    1.239541]  ext2
[    1.241455]  ext4
[    1.243368]  squashfs
[    1.245281]  f2fs
[    1.247547] 
[    1.250940] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    1.259186] SMP: stopping secondary CPUs
[    1.263098] Kernel Offset: disabled
[    1.266572] CPU features: 0x0,00000000,00000000,1000400b
[    1.271871] Memory Limit: none
[    1.276936] pstore: backend (ramoops) writing error (-28)
[    1.282324] Rebooting in 1 seconds..

Could someone suggest what should I try to fix this?

ps: I made backups of the mtdblocks (spi0.0, BL2, u-boot-env, Factory, FIP, ubi) via LuCI before the update if it helps :slight_smile:

Thanks in advance.

Hi Guys,

in the mean time I've contacted with the seller from Aliexpress and he sent me the original firmware via email.
I was able to restore it and got it working with OpenWrt v21 and had a chance to check what went wrong with the v23 update.

It turned out that they changed the mtd naming slightly and the UBI partition size as well.
So I went ahead and changed the "bl2" partion name to "BL2" and increased the UBI size in the dts file and built a snapshot firmware locally.
I updated the sysupgrade bin file via the "UART - U-boot web fail safe" method and it booted properly. :slight_smile:

I'm testing it at this moment but it seems to be working ok...

Did you get it to work?
I have two of the same devices and havn't been able to boot the official snapshot build, it just keeps rebooting. I've then tried to build my own with out luck so far. I got it to boot by using the dts that came with my devices but im not able to get any connection to the device. It just blinks likes theres activity when i plugin a network cable in the lan ports.

1 Like

Hi nyzxx,

yes, fortunately its working properly. :slight_smile:

How did you try to access your router? I mean what IP address did you use?

After the update the IP address is (or maybe as holivman wrote a few posts back). For me when I was done with the update I had to assign a static ip address to the computer from the same range (192.168.1.xxx) and set the routers IP as gateway.

If you did the same and still not able to connect to it then I would think the only solution would be to get the UART access and check the boot log if there is any error message.

Im not able to access it on after flash but will try later.
Can you maybe share the build you made so i can test that if 2.1 doesnt work?

Sure, please find below google drive link to the sysupgrade firmware I built and flashed to my device.
But please note I cannot guarantee that it will work for you as well, so please use it at your own risk.


2.1 did not work. And sadly your build just makes the device reboot exactly like the official build :frowning:
Guess i have to invest in some uart adapter.
Any specific i should look for when looking for an uart adapter or does any work?

Oh, I'm sorry to hear that it did not work on your device.
I'm using a CH341-uart USB stick and its working properly.

eg: aliexpress link

I hope with the boot log in our hands we will be able to figure out what is the difference between the devices.

What was the original LuCI/OpenWRT version on your device?