Yamon4 - Not Reading the Data

I have installed YAMon 4.0.7 on OpenWrt 22.03.2 following the instructions at https://usage-monitoring.com/v4Install+Validate.php

At first start of the reports page I got the list of contents of the directory instead of the web GUI (as described in this post. I was able to solve this thanks to the excellent advice by Steveb in that post.

However, I get no data in my reports. When starting the reports page, I get this:

Looking at the errors tab, I get the error "data file 'data4/2022/11/hourly_2022-11-13.js' not found.

Indeed, the directory data4/2022/11/ (which is a symlink to /opt/YAMon4/data/2022/11/) does NOT contain that file:

It resides instead in opt/YAMon4/yamon/:

It seems that either Yamon is writing to the wrong directory or else reading from the wrong one. Please help.

This is where the HELP link of Yamon leads: https://www.facebook.com/UsageMonitoring/

That location seems dead. The last post is from over 2 years ago. Anyway, I can see nothing there that would help with my problem.

You're welcome!

You have a problem with a specific package which isn't in the OpenWrt repo, so asking the package author is the natural thing to do.

I never got v4 working, but I'm getting the same with 3.4.7 after I updated from 21.02 to 22.03.
Running the startup script generated a bunch of IPTables errors.
I literally just signed up to the forum to look for help and I think the issue that IPTables isn't there anymore. "Firewall4 is used by default, superseding the iptables-based firewall3 implementation" - source:

Being a numpty, my questions are:
Is there an easy translate from FW3 to FW4, or will this be something the application author needs to fix to work with FW4? [fwiw I think the author has gone]
If we install IPTables back into 22.03, will it break anything?
Would it effectively put us back to FW3?
And....how do I do it? There's a truck load of iptables packages in the Luci software installer - do I need em all?

Thank you very much for your comments! I have also noticed all the iptables errors and my thoughts are identical to yours. I was also contemplating an installation of iptables but, just like yourself, am not sure what exactly to install from this long list of packages.

I did send an email asking for help to install@usage-monitoring.com, but got no response.

Reading through the forum here it would appear that there are people who got the v4 to work (not quite sure if on 22.03), so I'm still hopeful that some of those might help us.

Anyway, I'll continue digging and, if I find anything, will definitely publish it here.

I think I fixed your problem.

Install collectd-mod-iptables

That should make the iptables command work again.

Whilst messing around with that, I had another crack and yamon4 and still can't get it work. I think I know what is wrong: the /tmp/www disappears on reboot. just can't figure out what is meant to link where :frowning:

1 Like

Thanks a million! I have now done the following:

  1. Installed collectd-mod-iptables
  2. Installed Yamon 4.0.7 (having made sure that the previous installations have been meticulously deleted and all their remains eliminated)
  3. Executed the following commands:
rm /www/yamon
ln -s /tmp/www /www/yamon
  1. Went to https://[router IP]/yamon/ - still the same problems as described at the beginning of this post (all reports empty) and this initial message:


  1. Rebooted the router and HALLELUYAH! all works well!

In my case the directory /temp/www has remained after the reboot.

  1. For good measure I rebooted again and went to https://[router IP]/yamon/ and got the "Not found" error. After checking, I could see that the /tmp/www was still there but the symlink was not.

  2. Therefore I repeated the lines:

rm /www/yamon
ln -s /tmp/www /www/yamon

and Yamon worked again

  1. so now I have added the two lines to the /etc/rc.local (can do that also in Luci under System/Startup/Local Startup and all works great after many reboots.

Thanks again very much for pointing me to the right direction!!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.