No GUI For YAMon

Last week I installed YAMon on my router by following the posted instructions.
I'm as sure as I can be, at this point, that I did everything as prescribed but when I try and access the GUI I'm met with a numbered list of files, as per attached screenshot.

Archer AC1750 v2
OpenWRT 19.07.2
YAMon 4.0.7

I'm at the limits of my own ability to troubleshoot the matter and I'd love some help getting YAMon up and running. I will happily provide files, screenshots and any information required.

It appears that the Web server reads from /tmp/yamon instead of /tmp/www as it should be, and as the configuration file says.

An easy fix would be to copy shortcut/link file index.html from /tmp/www to /tmp/yamon.
Edit: that's a temporary work around, as it will work only until you restart, because /tmp will get cleared upon restarting.

@al_c FYI.

Another problem I found actually when trying to install over already installed YAMon 4 (I was trying to reinstall to see if it can let me fix the file location). I got:

/opt/install.sh: source: line 162: can't open 'y/setup.sh': No such file or directory

Edit. I run install.sh again and completed this time. (Didn't fix the index.html location though. But it doesn't work. I get JavaScript errors
image

Edit 2: Validation and the config file both show the correct router model.

An easy fix would be to copy shortcut/link file index.html from /tmp/www to /tmp/yamon

That did it! :partying_face:
Can you explain how figured that out? Does index.html use relative paths or something?

Thanks!

Until you restart, because /tmp will get cleared upon restarting.

In a Web server, when a home page doesn't exist, the server displays the content of the home folder (if the developer allowed that). So the trick was to find the folder that contains those 6 files.

That file is a shortcut to the actual index.html. It appears (in my WinSCP at least) to be using an absolute path, but wouldn't have mattered.

I'm getting this error but I can't restart until the family has gone to sleep tonight. Will report back.

I get the same error. Restarting doesn't solve it (and will actually take away the shortcut for index,html)

I don't know if it's about the same issue that cause the error with index.html or a different issue.

Sometimes you just can't see the forest for the tree! The work around/solution was was much simpler. without copying anything, instead of opening /192.168.1.1/yamon you should open /192.168.1.1/www.

@al_c
There is this discrepancy between what the documentation says and what the software actually does. And by the way, I tried editing both config.file and setPaths.sh to make the file get copied to /tmp/yamon instead of /tmp/www but it doesn't seem to have effect.

Having the home folder as /yamon instead of /www make more sense of course.

I had the same issue on latest Yamon 4.0.7.

For me the installer creates the wrong symlink and I get this :

# ls -la /www
drwxr-xr-x    4 root     root          4096 May  7 15:08 .
drwxr-xr-x   19 root     root          4096 May  7 14:50 ..
drwxr-xr-x    2 root     root          4096 Aug 16  2018 cgi-bin
-rw-r--r--    1 root     root           495 Aug 16  2018 index.html
drwxr-xr-x    4 root     root          4096 Aug 16  2018 luci-static
lrwxrwxrwx    1 root     root            10 May  7 15:08 yamon -> /tmp/yamon

Yet Yamon should direct to /tmp/www (not to /tmp/yamon)

The instructions to fix this in 4.0.6 on the install page are correct, but omit that they apply only if you have NO entry for Yamon. First you need to remove the incorrect link

rm /www/yamon

then you set the new symlink

ln -s /tmp/www /www/yamon

Now you can go to 192.168.1.1/Yamon

happy days...

2 Likes

It works after restart. Thank you.

This isn't working for me at all.
image

How about /yamon

I've reflashed the router with 19.07.3 and I'll try installing YAMON again. Will report back.

I just installed Yamon on my router and had the same issue. I installed it on /opt/app/Yamon4/.

First, /tmp/yamon/ is erased first time the router is rebooted, and its contents is lost. We can only get it back by reinstalling with setup.sh. I then copied it to /opt/app/Yamon4/yamon.persist/.

Every time the router reboots, it's lost and I need to get it back to its place:

rm -Rf /tmp/yamon/
ln -s /opt/app/YAMon4/yamon.persist/ /tmp/yamon

But that's not enough. As others reported, original /tmp/yamon is missing web folders. I solved that creating symlinks from their /opt/app/YAMon4/www/ place to /opt/app/YAMon4/yamon.persist/. They are the folders css, images and js. I take the chance to symlink yamon4.0.html to index.html, so that Yamon Web GUI loads directly.

There's still the data4 folder: symlink from /opt/app/YAMon4/data/ to /opt/app/YAMon4/yamon.persist/data4/

Yamon is a great tool, it's sad that it's not being maintained and these setup issues were never fixed.