Xiaomi Wifi Router 3G - 19.07.X / feedback and help

I found it on 4pda: https://4pda.ru/forum/index.php?showtopic=837667&st=6080#entry76121038

content of create_openwrt_for_breed.cmd

@echo off

if "%~1" neq "" (echo %~1) else (goto help)
del /q /f openwrt_for_breed*.bin >nul
del /q /f ~tempfile* >nul
del /q /f ~kernel* >nul
set size=0
copy /A %1 ~kernel0~
for %%I in (~kernel0~) do set/A size=4194304-%%~zI
fsutil file createnew ~tempfile %size%
copy /b ~kernel0~+~tempfile ~kernel0
del /q /f ~tempfile >nul
del /q /f ~kernel0~ >nul
for %%I in (%1) do set/A size=4194304-%%~zI
fsutil file createnew ~tempfile %size%
copy /b %1+~tempfile ~kernel1
del /q /f ~tempfile >nul
copy /b ~kernel0+~kernel1+%2 openwrt_for_breed.bin
del /q /f ~kernel* >nul
del /q /f ~tempfile* >nul
exit
:help
echo.
echo This will make OpenWrt binary file for using with Breed for Mi Router 3G.
echo Result file is Broken Kernel 4Mb + Kernel 4Mb + Rootfs0
echo.
echo Warning! You MUST add string in Breed for booting from 0x600000:
echo autoboot.command boot flash 0x600000
echo (see example at http://4pda.ru/forum/index.php?s=&showtopic=837667&view=findpost&p=71453185)
echo.
echo Usage: 
echo create_openwrt_for_breed.cmd {kernel1 file} {rootfs0 file}
echo.
echo Example: %0
echo create_openwrt_for_breed.cmd xxx-kernel1.bin xxx-rootfs0.bin
echo.

1 Like

You can take the breed-friendly image from this post: Support for Xiaomi Mi Wifi 4

Hello, have you been able to solve it? I had the same problems, there is a bug in an application file, the name of the process is wrong. You can solve it by editing the file minidlna.lua. Here it is explained https://github.com/openwrt/luci/commit/0d68d0ad7bd2ab036caba973daa85864f8ec81a3

1 Like

Thanks for your help, I have already solved it.

UPnP doesn't work for me in 19.07.2.... I have already added the upnp application, flagged the start up option but no deal... not sure what's wrong, whether it's in OpenWRT itself or the specific version for the Xiaomi 3G...

bug in openwrt, been for a long time afaik

Anyone tried upgrading to 19.07.3?

It works fine here.
Except that 5ghz sucks bigtime when using it as both AP and mesh backhaul.

Background: When using this device as a repeater, and also using the 5G band as both client and AP, you need to manually set fragmentation threshold on client to 2347 or the tx speed will drop down to almost zero.

The same happens when you use the device as both as mesh device with the backhaul on 5G (meaning AP+mesh), only the manually setting the fragmentation threshold doesn`t fix it. If anyone found a workaround, please tell.

EDIT: Seems to work if I removed the manual fragmentation threshold setting. (Guess I was too proactive)

1 Like

See also https://www.reddit.com/r/openwrt/comments/gs1fed/xiaomi_mi_wifi_r3g/

Hey, guys. Are there specific instructions about how to move from Padavan to OpenWRT. Also, can anyone recommend me builds with the bare minimum setup? I remember some people where making those available a couple of years ago.

Hello,

I have a Mi 3G router with openWRT on it. But since the 19 update, it have very slow internet connection.
I saw a bug in the bug report about this.

So i wanted to try X-WRT ( https://downloads.x-wrt.com/rom/ ) .

How can i switch to X-WRT ?

If i connect in ssh (in OpenWRT) and do these steps, does it works?

mtd write x-wrt-8.0-b202006050636-ramips-mt7621-xiaomi_mir3g-squashfs-kernel1.bin kernel1

mtd write x-wrt-8.0-b202006050636-ramips-mt7621-xiaomi_mir3g-squashfs-rootfs0.bin rootfs0

nvram set flag_try_sys1_failed=1

nvram commit

reboot

Or do i need to go back to stock firmware?

Thanks for help

If you install the Breed bootloader, then you can flash an openwrt image that been padded.

Thanks,
how do i install breed bootloader?

like this ?
opkg update
opkg install kmod-mtd-rw
insmod mtd-rw i_want_a_brick=1
mtd unlock /dev/mtd0
mtd -r write /root/breed-mt7621-xiaomi-r3g.bin Bootloader
reboot

@theMan

I'm also trying to move from Padavan to OpenWRT and was successful in creating the padded image file.

In Breed's Firmware Update page, am I picking Bootloader or Firmware or EEPROM to flash this image?

Thanks.

I have no experience with breed, but it's obvious that you should use Firmware.

Since this is supposedly a composite image, I was being conservative :slightly_smiling_face:

Thanks

is there any way I can keep stock rom while using openwrt just like I have padavan along with stock right now using breed? For some reason I am unable to update stock firmware(stable or dev), it just revert back to old one.

Hi there,
I did try to update xiaomi 3G (V1) from 18.06 to 19.07.03, I did so using luci and the sysupgrade file with the option set to keep settings. Now, I have no wireless at all - no 2,4Ghz nor 5 Ghz.
"device is not active"

Reboot etc. did not cure a thing.

Any idea how to fix this!?
Any help appreciated.

Thanks,
ONT

from what I remember a force sysupgrade will do just fine.