Xiaomi Wifi Router 3G - 19.07.X / feedback and help

I upgraded 2 routers first to rc2 and than to 19.07.0. No problems so far, on WiFi 5 Ghz throughput over 200Mbit.
I also upgraded my Xiaomi Router 3 (with SPI flash mod) - everything working stable.

Can you describe how you´ve done this or give me a link?

Look here

Basically you need to solder programmed spi flash. Change some pullups on main cpu.
Then start the router and flash openwrt.

1 Like

18.06.6 - NAT working correctly
19.07.0 - NAT is not working

Anyone tried 19.07.01? is 2.4ghz and 5ghz both stable?

I have been using 19.07.0 and then 19.07.1 since they were released.

     WAN       ________________       802.11s mesh    ___________________
----------------| MIR3G as main AP |--------------------------|  TL-WDR4300 (ath79) |
                   |________________|                                |___________________|

Note: I have replaced the wpad-basic with wpad-openssl to enable 802.11s mesh.

wlan0     ESSID: "ngauXXXX_mesh"
          Access Point: 50:64:2B:XX:XX:XX
          Mode: Mesh Point  Channel: 11 (2.462 GHz)
          Tx-Power: 17 dBm  Link Quality: 38/70
          Signal: -72 dBm  Noise: unknown
          Bit Rate: 78.0 MBit/s
          Encryption: WPA3 SAE (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 14C3:7603 14C3:7603 [MediaTek MT7603E]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

wlan0-1   ESSID: "ngauXXXX"
          Access Point: 52:64:2B:XX:XX:XX
          Mode: Master  Channel: 11 (2.462 GHz)
          Tx-Power: 17 dBm  Link Quality: 67/70
          Signal: -43 dBm  Noise: unknown
          Bit Rate: 55.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 14C3:7603 14C3:7603 [MediaTek MT7603E]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

wlan1     ESSID: "ngauXXXX"
          Access Point: 50:64:2B:XX:XX:XX
          Mode: Master  Channel: 161 (5.805 GHz)
          Tx-Power: 20 dBm  Link Quality: 57/70
          Signal: -53 dBm  Noise: unknown
          Bit Rate: 265.9 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 14C3:7662 14C3:7662 [MediaTek MT76x2E]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

Very stable so far on both 2.4 and 5, with a few minor problems:

  1. Xiaomi TV4 could not connect to either 2.4 or 5GHz. It was working on 18.06 but it is the only 1 out of about 20 devices I have at home, others don't have connection problem.

  2. Using WPA2/WPA3 as wifi security may cause problem with some devices but a reset of network setting take cares of it (including my iPhone X).

  3. The wifi driver doesn't not report noise level (Noise level: unknown).

Every time I sysupgrade past 18.06.4 I lose all wireless interfaces access, even when resetting configuration. I just flashed 19.07.1 and everything works besides none of the wireless interfaces initializing and the wireless tab in luci isn't present, roll back to 18.06.4 and it's fine. I'm using breed bootloader - could this be an issue? It's acting as if the wireless hardware isn't present at all.

edit: figured it out, did have to flash through breed and not sysupgrade

So I upgraded to 19.07.1. Both wifi frequencies seems to work fine and router is stable. BUT - ethernet now only syncs at 100mbps rather than 1gbps. Any idea what could that be?

Tried to replace the last hop cable but it didn't help.

Good evening friends, I recently installed an instant version, but you must install a stable version 19.07.x, to do this update is to download the sysupgrade of the stable version and right on Luci and flash? Or is it to be done in another way? You can help!

Hello, although I have been using openwrt for a while and I love it, I have never entered much. I have a Xiaomi 3g as an access point and I was seeing how to update it, but I am a bit lost. Is version 19.07.2 stable? Where can I get the specific bin for this router? Thank you.

Hi @SilverSt, I just updated myself from 18.06.5 to 19.07.2, got the bin download link from the following router specific info page - https://openwrt.org/toh/hwdata/xiaomi/xiaomi_miwifi_3g

Hi. I'm using 19.0.2 on mir3g and tp link 1043nd, but when i switch to 802.11s from 'Access Point' mode, all device missing wifi signal. computer and smartphone can't find wifi signal to connect? Is any special step. I've uninstall wpad-basic and install wpad-openssl on all device. thanks you.

Anyone running MiniDLNA? I've noticed since the update that the luci-app-minidlna service reports that The miniDLNA service is not running. even though it is, confirmed by navigating to where I can see the MiniDLNA status page. Of course everything still works so not a big deal just wondering if anyone else is experiencing it.

yesterday I tried to update my Xiaomi Router 3G
I downloaded the snapshot image using wget and upgraded that way:

sysupgrade openwrt-ramips-mt7621-xiaomi_mir3g-squashfs-sysupgrade.bin
Saving config files...
Commencing upgrade. Closing all shell sessions.

After that the router no longer boots.
Only Orange LED is lighting (not flashing)

I tried OpenWRT Failsafe - not working
I tried USB Stick with miwifi.bin - not working

I have not soldered pins to the board because I have not got the tools.
Any other chance to get it working again?
Why did that update brick the device? Usually I do the update with LUCI Webinterface

This happens: Optimized build for the D-Link DIR-860L
However there is this commit which should fix it but I have already bricked one router and thus cannot test a newer build with the mentioned commit included to test if it works.

Has anyone tried a build with the mentioned commit?

1 Like

Hi guys, I'm having an issue using 5ghz interface as a client and ap (wifi extender).
I detailed everything here, I tried a lot and don't find any fix, can anyone give me some hints? :wink:

To answer myself, current master snapshot (r13021) works!


To answer myself too, I figured my internet provider router was configured in 5G on a weird debug chanel (112). So, this is why it was not working - I guess - because meanwhile I got back to stock (not working) and then to padavan (where, while doing the config, I figured out that stupid issue).
But I bet it would work good on OpenWRT also, but I have now a good working conf and will stay on it :wink:

1 Like

Can you please help with switching from padavan to openwrt? I have dual boot using breed bootloader and I can switch between stock and padavan but the normal way of installing openwrt do not work. Is there any way I can install openwrt without removing breed bootloader or is there a way to use padavan to install openwrt?

I saw somewhere on the forum script that trims(do some magic :smiley: ) original firmware to fit breed-bootloader. If you have a problem find it, look on 4pda.ru Xiaomi router 3g topic.

1 Like