Xiaomi R4AC | System running in recovery (initramfs) mode


I have installed OpenWRT and have been able to install LuCI and log in to the gui.

However I am stuck with the message:

System running in recovery (initramfs) mode.

No changes to settings will be stored and are lost after rebooting. This mode should only be used to install a firmware upgrade

I have tried restarting, no luck.
I have also tried upgrading the firmware via System > Backup/Flash Firmware > Flash new firmware image

Using the firmware image from https://openwrt.org/inbox/toh/xiaomi/r4ac?s[]=r4ac under the "Installation" Factory sysupgrade image

However, when I do that the router seems to get stuck in a boot loop, Orange power light goes on, WAN light comes on then both go off over and over.

Have had to unbrick the router with pxesrv.

Any ideas on this? Thank you!


do you remember (or still have the file on your computer), which image file did you upload to the router and flashed?

I assume, you followed the installation steps here:

Did you confirm, you have the international version of the device?

Revision for global> DVB4230GL (see label attached to cardboard shipping box)
Revision for China> DVB4222CN (see label attached to cardboard shipping box) 


I have checked the box and confirmed it is the international version.
I have followed all the steps on that guide yes and still run into the issue.

Ok, great.

The wiki page is linking to snapshots in several places, but I think it better to start with a stable release.
Can you try with 23.05.3 and see if the same problem occurs?


Tried that one and same thing again. I had another look and I think I may have brought a paperweight.

I re-ran
3. Check the firmware layout with cat /proc/mtd and only proceed if mtd6: 00200000 00010000 “overlay”

And the result is mtd6: 00100000 00010000 “overlay”

Is there any way to change the firmware layout? (I'm assuming no)

This looks more like the chinese version.
The flash layout is basically the whole difference between them.

The chinese version firmware has a 1Mb overlay partition.
The global one has a 2Mb overlay.

If I understand it correctly recovering to a different OEM firmware would change the layout as well. So if you had a global version originally, but did a recovery to a chinese firmware, you have the chinese version now.

So you can try installing this instead:

It should fit the flash layout you have now.

1 Like

Amazing thank you!

All working now OpenWRT on there all okay.

I wonder how they got the international version of the firmware on the router in the first place!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.