Xiaomi MIR3 Router garbage Serial output

I bricked my router (xiaomi R3) when I tried the install Openwrt. but After that, I tried to recover using
USB-to-TTL. I connect with


and used baud rate 115200 / 9600 / and another one and used putty but when router boots up I'm getting some garbage output and after that some text output and then router goes to restart loop.

I'm not getting any option to boot from TFTP server.

I tried to alter the cable to check if cable is faulty or not but no luck.

Please check this video for a better understanding https://youtu.be/HGA9XHYQwZo

Note: I'm using pl2303 prolific usb to ttl

That looks like an unreliable connection (likely GND), also make sure that you adaptor is 3.3 volts based (pl2303 isn't necessarily and ttl usually refers to 5 volts), as this can cause similar symptoms..

I did soldering well and also use my hand to make it reliable. Please see my pl2303 below.

@slh any clue?

The LED on the data line can overload the output of the router. Adapters without LEDs are better, or just remove them.

Baud rate 57600 is sometimes used on MediaTek chips.

1 Like

tried with your mentioned baud rate but no output with this baud rate.

one thing I didn't why garbage show only first few sec after that it shows text and after reboot again garbage text.

That is usually because the bootloader and the kernel use different baud rates. The one that doesn't match your setting will be garbled and the one that does will be clear.

The text that appears before it reboots would likely tell why it reboots.

1 Like

Update Finally I have solved the problem by changing the USB to TTL module.
Now I bought CP2102 USB 2.0 to TTL UART Module.

But Now I have got a new problem. I'm not getting any chance to press "1" button. Please see the video

Did you reenable the serial console input, as described in
https://openwrt.org/toh/xiaomi/mir3 ?

How can I re enable it? I don't have any SSH access


@frollic https://openwrt.org/toh/xiaomi/mir3#serial

describe to run following command.

nvram set uart_en=1
nvram commit

but I don't have SSH access so how can I run those commands.

just keep on reading ....

Judging by the URLs you're supposed to post to the router, you should be able to reenable the serial console by using URLs only, instead of going the all the way via ssh, but I guess it's easier
to just follow the instructions :wink:

@frollic could you tell me which URL you are talking about? My router is brick and is in bootloop. Please check the youtube video.

Ah, my bad, guess I didnt' watch it till the end :confused:
In that case, no there's not much you can do, since the parameters I'm referring to weren't changed before you got stuck.

Since the present firmware won't boot you need to do a recovery which I think is based on putting stock firmware on a USB drive then plugging that drive into the router and holding down the reset button to make the bootloader flash it.

@mk24 any instruction on how to recover using USB?
which file (where to download) do I need to put in my USB?

Can't thank you enough for the baud rate. I wasted a few hours with my hlk-7628 module. I was checking solder joints, ground connections, etc. Then your comment helped me. Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.