Xiaomi mi wifi 3 support


#806

I tried to install new firmware by using sysupgrade -F through ssh.
It worked but wifi was not working.
Then I flashed back stock firmware, and tried doing the clean flash as in the instruction.
That makes the router went into bootloop, after loading kernel.

I restored it using TFTP and serial console.

Does anyone tried last build (from December 2018) downloaded from mega.nz?
Is it working on your routers?

Do I need to do anything special to avoid bootloop?

Now I flashed success some previous build from July 2018 which I had on router before.
It works OK, but sometimes 2.4GHz WiFi hangs.


#807

The wifi hangs probably because of this error (you can look it up on your system log):
ieee80211 phy1: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2

This is supposedly fixed in the latest mt76 driver, but it is not. I was also facing this problem, later my device bricks after installing bakemono's clean openwrt without having UART access (it bootloops), so I revived it by converting it to mi wifi mini and install pandorabox. So, I reckon PandoraBox will also fix that for you.

Relevant bug report: https://bugs.openwrt.org/index.php?do=details&task_id=896


#808

Yes thats the error what I have when there is a lot of 2.4G traffic.
I thought it was fixed in current HEAD.

I use 802.11r roaming between access points. Does it work in Pandora?

Could you give me a hint for converting to mini version?
Did you just soldered spi flash and changed the resistors?

How did you flashed the spi, and what binary have you used.

Thanks.


#809

802.11r is not working in Pandora as far as I know.

Yes, I bought a flash chip, flashed it with CH341A SPI flasher with the provided file from 4PDA, solder it on the board along with the resistor and jumper cable (also removed one resistor on the board), and that's it.


#810

Ok sounds simple.

I looked at 4pda but link to full dump is not working. Can you send me some link to instructions or at least full dump.

I wonder if it is working correctly on current openwrt for mini.

Many thanks.


#811

Your error is a long standing bug in the rt2x00 family of drivers, while there should have been recent (master, not 18.06.x) improvements in regard, it's not quite clear if the problems have really been fixed. mt76 is a new driver for newer Mediatek chipsets, these should not be affected by the bug you mention - but they don't apply to your device (xiaomi mir3), only the newer mt7621/ mt7628 based SOCs (xiaomi mir3g) and their wlan chipsets.


#812

At least one person is working on it https://github.com/sgruszka
His last statement:

Hi, I plan to mask "Dropping frame due to full tx queue" error as printing it can cause troubles by itself.
https://marc.info/?l=linux-wireless&m=154531898005908&w=2

Have also some pending patches and further improvements . Will provide to test in my repo as soon I test then by myself and assure they do not cause crashes.

All my work should finally lend in master.


#813

Hi, i have seen your compiled image on mega for Mi3 , can you please tell me does it work? , and are you using it on your device?
Thank you for support


#814

Tried image from mega and it works but you can't install packages (since it's based on master)


#815

I tried installing openwrt today. But after the reboot command, my router restarted and got stuck on the orange light. What do I do?


#816

If you've installed Pandora bootloader reset it with button and flash Pandora or Openwrt version from this thread


#817

Thanks for the quick response, but I can’t reset it... when I push the reset button the light just stays orange


#818

@bakemono

Any idea how to install DNSCrypt on Mi Router 3 with PandoraBox?
I switched from OpenWRT because of the low WiFi speeds.

I tried

opkg install --force-depends http://archive.openwrt.org/chaos_calmer/15.05.1/ramips/mt7620/packages/packages/dnscrypt-proxy_1.4.3-1_ramips_24kec.ipk

But it resulted in

Unknown package 'dnscrypt-proxy'. 
Collected errors: 
* pkg_hash_fetch_best_installation_candidate: Packages for dnscrypt-proxy found, but incompatible with the architectures configured 
* opkg_install_cmd: Cannot install package dnscrypt-proxy.

Thanks.


#819

i hate padorabox....mu wan keeps on disconnecting


#820

Hi. I would like to ask some help from you guys. So recently I got pandora box to work (I used the one from the mega link) then when I tried to go back to the stock firmware it got stuck with the orange light after flashing the stock bootloader also from the mega link. Now my router is stuck on the orange light. Reset button doesn't work. I can connect through the serial port though I can not select the "Load system code to SDRAM via TFTP" because it defaults to option 3 which is "boot system via Flash". even if I press 1 as fast as I can, it still boots with option 3. I hope someone can help me. I have also attached a screenshot as reference.


#821

AFAIK, if you can't boot your router like this, your only option is to convert it to mi wifi mini using this guide: https://4pda.ru/forum/index.php?showtopic=736801&st=19920#entry69325956

I've done it on mine, not too hard. But it needs some soldering skills.


#822

After converting to mini, the full OpenWRT can be flashed and it will work normal?, is there a some drawbacks after converting? Please share some details.
Thank you


#823

Yes you can flash OpenWrt as if you have the MiWiFi mini.

I'm currently using PandoraBox 19.01 on mine because the 2.4 GHz wifi is not stable for me on OpenWrt 18.06 (and turns out it is most likely fixed on SNAPSHOT, but I'm currently too lazy to change it), been running it non-stop since then (except a few blackout now and then).


#824

It is fixed on SNAPSHOT, as is verified by me using the chinese X-Wrt (not the old one, x-wrt.com).
The new X-Wrt is basically OpenWRT SNAPSHOT with a GUI, plus their own commits which they appear to be contributing to OpenWRT.

By the way, I recommend you to switch over from PandoraBox, since PandoraBox utilizes a different partition scheme than OpenWrt, so using X-Wrt will make transitioning to OpenWrt easier.


#825

@moriel5
Any tips how to move from Pandora directly to x-wrt ?