Xiaomi mi wifi 3 support


#786

Hello my xiaomi r3 router was flashed under PandoraBox 18.07 2018-07-26-git-e717545 / Master LuCI (git-18.191.64311-165cb77). Is it possible to put a vpn on it?
Is it possible to put English or French on it? my version is the last version thank you


#787

any system update for xiaomi mi router firmware im still on nitroxid firmware thoug


#788

so i flashed 2.11.20 firmware and enabled ssh but could not flash pandora box bootloader i got this:
"could not open mtd device:bootloader
could not open the device for writing"
and if i try to flash openwrt provided in the mega link i get this image with constant orange light:
ker

so whats im doing wrong?


#789

It looks like u r doing so many things wrong at the same time. What did u exactly do after unlock the ssh ? tell me step by step @crash


#790

why did u want to flash the pandora bootloader? did u read the Flash Instructions.txt ? If u want to flash Pandorabox openwrt then follow this https://openwrt.org/toh/xiaomi/mir3#how_to_flash_pandorabox_openwrt


#791

hey,
so what i did in order:
1.went to stock 2.11.10 fw
2.got ssh access
3.on ssh i did these commands:
nvram set flag_last_success=1
nvram set boot_wait=on
nvram set uart_en=1
nvram commit
reboot
4. i copied pandorabox bootloader from /extdisks/sda1 to /tmp ..
5.tried writing the bootloader with command "mtd write <bootloader-name.img> bootloader" but in this step i get the error:
"could not open mtd device:bootloader
could not open the device for writing"
5.i though maybe i should flash the bootloader from an openwrt build so i did this:(files from mega link)
mtd write openwrt-ramips-mt7620-xiaomi_miwifi-r3-squashfs-kernel1.bin kernel1
mtd write openwrt-ramips-mt7620-xiaomi_miwifi-r3-squashfs-rootfs0.bin rootfs0
reboot
but when i did step 5 i get constant orange light with the screenshot that i posted above from serial console ...

Do note : before all this i was running an open wrt build and i tried flashing bootloader from there but got the error:
"could not open mtd device:bootloader
could not open the device for writing"
so i though i might need to do that from stock fw but it doesn't work there too..(ie i tried to flash the bootloader from both stock and a openwrt build failed with the same error both times)


#792

ok, u still have serial access thats a good thing. Try to recover it to stock by tftp method https://openwrt.org/toh/xiaomi/mir3#recovering_from_softbrick then do the procedure again. This is looking interesting, the Bootloader partition should not be locked in 2.11.20, u shouldn't get the error in step 5. @crash


#793

i have serial access and recovered ...
right now im on 2.11.20 (downloaded from the link in the guide ) with ssh access and the same story ...
can i manually unlock that partition via serial ?


#794

ok, this is weird, also post the cat /proc/mtd output here . try to flash the normal openwrt from my link and instruction then flash the pb-boot @crash


#795

EDIT:
jesus christ bootloader was case sensetive i had to type Bootloader instead of bootloader
dumb mistake from my side


#796

hmm...it looks like openwrt flash is successful... go to 192.168.1.1 and setup it (enable ssh) @crash


#797

Hi,

How can I upgrade to new firmware build downloaded from
https://mega.nz/#F!WY0FiTIS!Cl_Dzm4yhzrQZFazYG3i8Q

I'm currently running OpenWrt 18.06-SNAPSHOT r7320+4-a8cac96aae / LuCI openwrt-18.06 branch (git-18.247.71242-9541751).

I can't flash sysupgrade through luci web interface - I'm getting error: The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Thanks


#798

photo_2019-01-02_21-35-28

Hi,

I have a Mi Router 3

I am getting BAD inside kernel1 while flashing Padavan. It never boots. I also tried to flash OpenWrt but that also never boots (stuck in orange LED). How can I repair the kernel1 partition?I s there any other alternate way of flashing the kernel in kernel0 partition.

I badly want to install Openwrt on my router.


#799

I believe I've (soft) bricked my router (waiting on a TTL module to try), because the Wiki had the incorrect steps for restoring to stock.
The wiki said:

  • in ssh:
cd /tmp
mtd write Bootloader.bin Bootloader
reboot
  • access ssh again
fw_setenv flag_try_sys2_failed 1
cd /tmp
mtd write kernel0.bin kernel0_rsvd
reboot

Which bricks the system.
However, the original instructions posted in here stated:

  • in ssh:
cd /tmp
mtd write Bootloader.bin Bootloader
mtd write kernel0.bin kernel0_rsvd
reboot
  • access ssh again
fw_setenv flag_try_sys2_failed 1
reboot

If someone with the appropriate authority could fix that on the wiki, I'd rest easier... Looking through the edit history, it was copied correctly before, but got mangled in some copy/paste edits later. Edit: I've corrected the wiki now.

Given that I've come from PandoraBox, flashed the provided openwrt firmware to roll back, and flashed the Bootloader.bin but not the kernel0.bin, I assume I need to try TTL?

Edit: Serial console worked, was able to flash stock via SFTP.


#800

I don't see official builds. In the wiki I see a dev build. I don't want pandora. Is the dev build working? Is anybody going to maintain it along?

I'm thinking to buy a Xiaomi Mi 3.


#801

Buy Xiaomi Mi 3G, not Mi 3. Mi 3G costs almost the same, supports gigabit ethernet, USB3, and is also supported by OpenWrt.


#802

This doesn't help him and a lot of others. There were the same situation like now before I bought this MI3 device. People recommended this because it was the most promising development ongoing. Now it suddenly stopped somehow and even when it was announced as officially supported it stucks still in a very low development level if you follow this treat.

It's really annoying slowly since it seems there is no real good choice for a low cost supported device. Everyone just recommends the >200€ Linksys AC3200 device which is maybe with good support atm, but nobody knows if it's still the same in 3 months.

I think slowly this has to be shut down to a good overview and some key supported devices or a better support than "buy a new device". Besides the traders nobody is happy with that.

Besides fundamental features it should now always wireguard already been implemented I'm every image. That's a minimum requirement in my eyes and the only reason why to switch from good working original images.


#803

WR1200JS is fine low price easy for install openwrt


#804

is there any sysupgrade with this one got plenty of error install php and using it


#805

is it safe if i had an openwrt convert to padora