Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion

Could be! Just disconnect your WAN cable and verify the log now says port 3 link is down to verify that port 3 is indeed your WAN connection.

br-lan: port 3(wlan1) entered blocking state
This line make me consider a Wi-Fi problem.

I have tested behaviour of all ports to exactly identify.
Port 1(in logs) - physically not exist, looking to switch VLAN configs, it's looks like it is CPU etho
Port 2(in logs) - port LAN1 physically (empty on my side)
Port 3(in logs) - port LAN2 physically (my pc is connected to this port)
Port 4(in logs) - port WAN

I've had the following issue using @araujorm 19.07.04.
I have the following set, but unsure if this could be related to the issue:
config globals 'globals'
option packet_steering '1'

[278047.753829] ------------[ cut here ]------------
[278047.758566] WARNING: CPU: 3 PID: 0 at net/sched/sch_generic.c:320 dev_watchdog+0x1ac/0x324
[278047.766918] NETDEV WATCHDOG: eth0 (mtk_soc_eth): transmit queue 0 timed out
[278047.773943] Modules linked in: pppoe ppp_async pppox ppp_generic nf_conntrack_ipv6 mt76x2e mt76x2_common mt76x02_lib mt7603e mt76 mac80211 iptable_nat ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_FLOWOFFLOAD xt_CT wireguard slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_conntrack_ipv4 nf_nat_ipv4 nf_nat nf_log_ipv4 nf_flow_table_hw nf_flow_table nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_mangle iptable_filter ip_tables crc_ccitt compat nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 ip6_udp_tunnel udp_tunnel leds_gpio gpio_button_hotplug
[278047.840607] CPU: 3 PID: 0 Comm: swapper/3 Not tainted 4.14.195 #0
[278047.846759] Stack : 00000000 87de0240 805a0000 8007271c 805c0000 80562bf4 00000000 00000000
[278047.855181]         8052e4b0 87c0fdc4 87c34ffc 8059c967 805292a0 00000001 87c0fd68 1cc28223
[278047.863603]         00000000 00000000 80700000 00005e20 00000000 00000134 00000008 00000000
[278047.872026]         00000000 805a0000 000cd39f 70617773 00000000 805c0000 00000000 8055cb04
[278047.880449]         80372100 00000140 00000003 87de0240 00000008 80299cf8 0000000c 8070000c
[278047.888869]         ...
[278047.891392] Call Trace:
[278047.893935] [<8000c7b0>] show_stack+0x58/0x100
[278047.898452] [<80469d54>] dump_stack+0xa4/0xe0
[278047.902883] [<8002f608>] __warn+0xe0/0x138
[278047.907053] [<8002f690>] warn_slowpath_fmt+0x30/0x3c
[278047.912088] [<80372100>] dev_watchdog+0x1ac/0x324
[278047.916882] [<80089468>] call_timer_fn.isra.25+0x24/0x84
[278047.922256] [<80089724>] run_timer_softirq+0x1bc/0x248
[278047.927466] [<80487cf8>] __do_softirq+0x128/0x2ec
[278047.932242] [<80033fb4>] irq_exit+0xac/0xc8
[278047.936513] [<8024c970>] plat_irq_dispatch+0xfc/0x138
[278047.941628] [<80007588>] except_vec_vi_end+0xb8/0xc4
[278047.946658] [<80008f50>] r4k_wait_irqoff+0x1c/0x24
[278047.951580] ---[ end trace 0c708dc15f3494fc ]---
[278047.956278] mtk_soc_eth 1e100000.ethernet eth0: transmit timed out
[278047.962518] mtk_soc_eth 1e100000.ethernet eth0: dma_cfg:80000065
[278047.968600] mtk_soc_eth 1e100000.ethernet eth0: tx_ring=0, base=06dc0000, max=0, ctx=1472, dtx=1472, fdx=1471, next=1472
[278047.979526] mtk_soc_eth 1e100000.ethernet eth0: rx_ring=0, base=06150000, max=0, calc=1660, drx=1661
[278047.994389] mtk_soc_eth 1e100000.ethernet: 0x100 = 0x6060000c, 0x10c = 0x80818
[278048.007298] mtk_soc_eth 1e100000.ethernet: PPE started

Hi @Brett.

Are you using the latest, the one that I published in a zip file? That one has a fix for similar problems.

I thought I was but cannot be sure.
The version reported is:
Powered by LuCI openwrt-19.07 branch (git-20.247.75781-0d0ab01) / OpenWrt 19.07.4 r11208-ce6496d796 which matches the version.buildinfo in the zip.

What is the version.buildinfo for the previous as can't see it with the release?

I checked here in my archive... the version.buildinfo is the same, so that doesn't really tell us for sure. Can you do a sysupgrade from the sysimage on the ZIP file related to the latest "generic" build, just to be safe?

If that doesn't solve it, then I'm at a loss...

1 Like

Thanks for checking, will try

Zip firmware applied...

I tried using the OpenWRTInvasion method and flashed my 4A Gigabit with https://github.com/Byte-bite/OpenWRT-19.07.3-Stable-MI4A-Gigabit/releases.
This bricked the device and I tried using Zorro's and Hoddy's debricking tools.
Connected the router directly to my PC, changed the IP, started up the router with the reset button pressed.
The tool showed that test.bin was being read and the router's power light changed from blinking orange to blinking purple.
Tried this several times, even leaving it overnight, but it is still blinking purple and does not start up (can't access or in the browser).
Does anyone have any ideas what could be wrong?

1 Like

After that, have you changed back to dhcp and power cycle your unit? Never faced any problems with that procedure.
You should install @araujorm latest build as it is very stable and running fine.

Switched back to DHCP, but just restarted the modem. How do you power cycle it?

Remove power alimentation and put back after 15-20 seconds.
Unbricking cycle finishes when power light changed to blue and blinking (aprox 10 minutes).
That is the moment when is needed power cycling after put back pc to dhcp.

That's the thing - the light never changes to blue. It just keeps blinking purple.

Hey guys. I have recently purchased this router and I have successfully installed OpenWrt on it. The process was incredibly easy. Thanks for all your hard work and support.

But now I wonder that is there anyway to build a firmware which is exactly the same config with stable releases? Please help me about this. Honestly I don't want to use snapshot or beta-alpha stage firmwares. Why don't we get any stable releases for this device? It's working so far so good with OpenWrt.

Thanks in advance.

Because at this moment, official OpenWRTdevelopment for this device is on the snapshot stage, there isn't a stable version released until now. But @araujorm version (if this is the version you have installed) is really stable, it is based on 19.07.4 stable, don't worry.

1 Like

But now I wonder that is there anyway to build a firmware which is exactly the same config with stable releases?

Oh yes, I have already read that page. However, the latest config.buildinfo file does not include mir4a as a target device. Is this not a problem? You mean that it is still possible?

git clone https://git.openwrt.org/openwrt/openwrt.git
cd openwrt
git checkout v19.07.4
./scripts/feed update -a
./scripts/feed install -a
wget https://downloads.openwrt.org/releases/19.07.4/targets/ramips/mt7621/config.buildinfo -O .config
make defconfig

Can I compile it like this for mir4a? Iā€™m sorry I'm confused.

Hey guys, can someone please provide the international firmware 2.18.215 or 3.0.5 with "all" in the filename for the R4AC (100m)?

Is there anyone who knows if in the last snapshots the problem with pppoe disconects has been fixed ?