Xiaomi Mi Router 4A Gigabit Edition missing the Wireless

hi , im new in here , I recently bought mi 4a gigabit edition cn version , it is already installed the Bootloader breed Web, the Network Wireless is missing after flashed the 21.02.0 version (download link), I have been also tried this version v19.07.8 and results are same, any one can help . Thanks a lot.

You just picked the wrong image (it matches your device and works, but the file for testing purpose).
...initramfs...images do not persist the settings, as soon as you reboot, settings are resetted - that is meant for developers for testing to have less writes on the flash chip.
you need the other listed download. Best is, use: https://firmware-selector.openwrt.org to pick the right file

You need to download sysupgrade for breed.

Should I pick this image? so flash with sysupgrade is fine?

have you studied https://openwrt.org/inbox/toh/xiaomi/xiaomi_mi_router_4a_gigabit_edition ?

flashing an initramfs image will let you test openwrt, but the image won't survive a reboot, since it's only stored in the devices' RAM.

You need to press sysupgrade.

sysupgrade won't cut it. it works once openwrt's already installed.

No through breed you can only install sysupgrade file.

He says that he have breed installed in router.

Thanks for your replay, I tried sysupgrade file through breed, however seem not work to booting up, it auto reboot around 10 minutes still can't get in to the system...

İnteresting. How you flash it?

İ know whats your problem. You need write mac addresses.

İn breed mac address of router gots corrupted.

So I need to backup the eeprom first, then flash the systemupgrage image, also select the eeprom?

First flash kernel file then from openwrt do sysupgrade.

so after flash the kernel file , then no need fix the mac address first?
I have tried flash the kernel, then do the sysupgread from Luci, but seem not work to booting up, it auto reboot around 10 minutes still can't get in to the system...

After flashing kernel go to interfaces and tell me if there have mac addresses. And 2 of 3 will be same mac addresses.

İf you still want run openwrt you need dump. İ have found one from russian forum. After installing dump you can install official stable version and do sysupgrade. You can get firmware dump from this link: https://4pda.to/forum/index.php?showtopic=988197&st=0#entry95012258

İf you need translation you can tell me.

And you need backup eeprom.

Hi, thank you for your help, I have been flashed one of the image base on openwrt, seem the mac addresses are normal, and I tried flash the official stable version sysupgrade(openwrt-21.02.0-ramips-mt7621-xiaomi_mi-router-4a-gigabit-squashfs-sysupgrade.bin) , but it can't be upload.