Xiaomi AX3600 INT firmware

You know the OEM firmware and its rather limited feature set.

QSDK[0] based builds use (almost) the same (semi-proprietary) 4.4.60 based kernel/ wireless drivers as the OEM firmware, but are otherwise more generic and less refined (not at all-) by the vendor. It looks more like OpenWrt, with (an old variant of-) luci as webinterface, providing some more access to the device and some more/ other features - but as you can't easily rebuild it from source and given that there is no full repository of downloadable binary packages, you quickly hit a wall if you'd like to add features not present in the ready built images provided by the respective individuals.

[0] QSDK is the semi-proprietary SDK Qualcomm provides to their corporate customers and licensees, the generic code the vendors then use to build their own firmware from. Vendors then adapt this example code for their devices, adding configuration and drivers as needed, just as well as customizing it to their liking (which usually entails ripping out the luci variant provided by the QSDK, dropping in their own webinterface, according to their plans and corporate identity and often adding their idea of upgrade/ recovery means).


Thanks for the thorough explanation, I appreciate it.
As far as performance goes it should be basically identical or even better compared to the stock version then right?
If that's the case in theory it would be a better firmware than the stock one as you would get rid of all the little issues like broken IPv6 firewall or the fact that if you have a vlan specified in the wan interface it gets removed at each reboot.
Obviously having a real OpenWRT build would be the ideal solution, but if for now the choice is between the borked Xiaomi firmware and the QSDK build, is there any reason for which a user shouldn't use the latter?

1 Like

Some little help, I managed to execute all steps from this page, but the code generated does not work for "root". Any idea?

Managed to fix it... sorry, bad command execution...
Fully rooted...

Did you manage to fix it? I have the same problem but it is once per day.

Is there a way to enable dual stack on our AX3600?
When I try it via ui it doesn't work on my clients, when both are activated the router gets working IPV4 and IPV6 but my clients can only connect via IPV6 to the internet.

I have SSH access and can modify the network config, but I have no Idea wat to add ...?

Solved it!

I had to turn off the ds-wan_6_4 device.

Just put a "ifconfig ds-wan_6_4 down" in your rc.local and it will work ...

1 Like

Someone knows how to get back the stock partition layout after flashing the qsdk version?

Take a look at the bottom of the page, TFTP Recovery

Thank you. I did this & immediately notice signal increased (more bars showing)
But the speed of connection did not improve.
Still 100-200mbs using my Xiaomi MI 9 SE phone.

Anybody knows have I can permanently adjust the timezone in our router? I have SSH access but after setting it manually in the /etc/config/system system time it will always be set back to the defaults after rebooting the router ...

Hello, please help!
How can i change MCS?
We need all 4 x streams with MCS 0-7. Is this possible?

root@XiaoQiang:~# iw phy0 info
Wiphy phy0
        max # scan SSIDs: 10
        max scan IEs length: 255 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * managed
                 * AP
                 * AP/VLAN
                 * WDS
                 * monitor
        Band 2:
                Capabilities: 0x19e7
                        RX LDPC
                        Dynamic SM Power Save
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 7935 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: No restriction (0x00)
                HT TX/RX MCS rate indexes supported: 0-31
                VHT Capabilities (0x738bf9fa):
                        Max MPDU length: 11454
                        Supported Channel Width: 160 MHz, 80+80 MHz
                        RX LDPC
                        short GI (80 MHz)
                        short GI (160/80+80 MHz)
                        TX STBC
                        SU Beamformer
                        SU Beamformee
                        MU Beamformer
                        RX antenna pattern consistency
                        TX antenna pattern consistency
                VHT RX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: MCS 0-9
                        4 streams: MCS 0-9
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT RX highest supported: 0 Mbps
                VHT TX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: MCS 0-9
                        4 streams: MCS 0-9
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT TX highest supported: 0 Mbps
                        * 5180 MHz [36] (33.0 dBm)
                        * 5200 MHz [40] (33.0 dBm)
                        * 5220 MHz [44] (33.0 dBm)
                        * 5240 MHz [48] (33.0 dBm)
                        * 5260 MHz [52] (33.0 dBm)
                        * 5280 MHz [56] (33.0 dBm)
                        * 5300 MHz [60] (33.0 dBm)
                        * 5320 MHz [64] (33.0 dBm)
                        * 5500 MHz [100] (30.0 dBm)
                        * 5520 MHz [104] (30.0 dBm)
                        * 5540 MHz [108] (30.0 dBm)
                        * 5560 MHz [112] (30.0 dBm)
                        * 5580 MHz [116] (30.0 dBm)
                        * 5600 MHz [120] (30.0 dBm)
                        * 5620 MHz [124] (30.0 dBm)
                        * 5640 MHz [128] (30.0 dBm)
                        * 5660 MHz [132] (30.0 dBm)
                        * 5680 MHz [136] (30.0 dBm)
                        * 5700 MHz [140] (30.0 dBm)
        valid interface combinations:
                 * #{ AP } <= 17, #{ managed } <= 30, #{ monitor } <= 1,
                   total <= 17, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz }

Hi I bought a global version AX3600 with 3.0.22 firmware. I just installed chinese firmware 1.1.15 latest one on my global version router. My signal coverage is increased very significantly and now I have decided to keep the chinese firmware. But a little problem I am facing. now I can only access my router through web interface and on my miwifi app it got paired in germany region of the app but showing "Router is offline". please guide how can I solve this problem?

Did you do the reset? That is very recommended.
After that uninstall the MiWIFI app, and install this version:

Select China as the region.

Tried. didn't work. after shifting to chinese firmware they are recognizing the device from germany and asking me to switch my region. I think the region is still EU after chinese firmware. how can I change that?

I'm trying to have high range with this router and still have international firmware.

I'm trying to achieve this, I managed to downgrade to 1.0.17 and obtain SSH.
Then I tried xqrepack method you linked, after running:
ubireader_extract_images -w miwifi_r3600_all_6510e_3.0.22_INT.bin
I get error:
ModuleNotFoundError: No module named 'lzo'
I also get errors when trying to install python-lzo package. Could anyone help with this?

Hi folks,

For some reason, my AX3600 doesn't seem to be able to distribute the IPv6 address on its own LAN network. It gets attributed an IPv6 through the WAN port from the providers router, but the AX3600 doesn't distribute to its DHCP clients.

If I change the IPv6 mode to NAT6, it distributes, however that's not the way I want it to work (as NAT6 is slower).

Is that a known issue or behaviour? What do I need to do?

If I set the AX3600 to connect through PPPoE, Native IPv6 works, but it has some issues with my provider, being unable to receive my whole contracted speed.


I have been using my AX3600 with firmware 3.0.22 with root access.
The covarage and speeds has been great so far.
But I have a few weird issues, some apps which does not work well when connected to the router.

For instance my Samsung phone has a built in function which allows you to sync your photos to OneDrive automatically. This works great with 4G, but when connected to my AX3600 wifi I get an error saying that syncing is not supported when connected to a mobile hotspot? This is weird as it is a fibre connection to my AX3600 which I connect to via wifi.
How come it confuses this as a mobile hotspot?

Another thing is using the Mi Home app, which I have multiple devices in my home connected to a Mi Hub. When using this app with 4G on my phone I get decent speed to view the devices, always a little bit slow as they are connected to Mainland China. But when connected to Wifi it almost doesn't work. It can take minutes for it to connect to a device in the app, if it doesn't time out.

Maybe both these issues are connected? Why does my phone think it is connected to a mobile hotspot?

Any ideas?

Maybe the app works with upnp enabled, you can try to enable upnp enabled in the router configuration. Some apps do like upnp for some reason though I always try to run my setup without upnp enabled.

That's because your router doesn't receive a prefix from the provider's router. The easiest way to achieve that is to put the ISP's router in bridge

Maybe because it's a Xiaomi mac address so for Samsung it's a phone?