Xiaomi AX3600 INT firmware

Thanks for instructions, but I'm not sure if bdata is problem here. Because bdata is same for me on China and on INT firmware:

root@XiaoQiang:~# bdata show

So I have CountryCode=EU in both firmwares in bdata, it's just on China 30dBm tx power is max, and on INT it's 16dBm, really don't know why.

Once the ssh is updated and obtained, the recommendation is to put a line in /etc/rc.local before the "exit 0"

(sleep 60; iwconfig wl0 txpower 30; iwconfig wl1 txpower 30) &

1 Like

My bdata is set to "DE", although I've heard that this is not a valid code.

Truth is, I seem to have plenty of 5GHz power around the house. I'm with 866MBPS on my phone about anywhere in my home, only dropping to around 700ish when I'm relatively far away like on my laundry room -- but still connected to 5GHz network.

It's not a necessarily large apartment, sitting at 82m² (882 sq-ft) with the router sitting right in the middle of it, but it is plentifully covered by the 5GHz network.

Now, said that,if I remember well, there are "two officially recognized" bdata country codes: EU and CN. CN provides the most power. Setting your bdata to CN and having a global firmware with the country set to DE (english Mi Wifi app) or CN (chinese Mi Wifi app) will give you the best power.


Care to share the step you added in the script to comment out these lines from the file?
I don't know how.


Nevermind, but would still love to know how you added in the script. I ended up adding a pause in the middle of the script, so I went to the /tmp/ folder and manually edited the file lol

Also, the IoT network doesn't seem to be isolated from the actual network (even with option ap_isolate '1'). Is there a way to isolate it?

Does someone have an account on this site to retrieve the mesh plugin? I thank you, it has become imossible to create an account.


Yes, you are probably right about having CN in bdata. But now with China firmware I have enough power (still within limits of ETSI - https://w.wol.ph/2015/08/28/maximum-wifi-transmission-power-country/) to have 5GHz available through my house (2 floors), It's even picked up in basement and connects on 200 MBPS which is still ok :slight_smile:
I'm using google translate when I need to configure something on router, but interface is easy to remember where is what so It's not a issue as most things are already set up.
I'll probably wait until official OpenWRT is available for our device (tried QSDK but it also have lower signal strength) and stay on China firmware until then.


Working on my new AX3600 with 3.0.22 global firmware.

Like other people, I have some forwarded port who works (443/5000/5001) but a lot don't.

Have you find any workaround ?

If I put back my AC2100, works fine.


you can do with WINSCP this script go to /etc then open rc.local
and before exit write

For example:
uci set*network.wan.ifname='eth1.6'
uci commit
/etc/init.d/network reload
exit 0

now everytime you reboot the router it will change eth1 to eth1.6

Hello everyone,
I ask your help for the following question, I recently bought two AX3600 global versions with the firm. 3.0.22 with the objective of connecting them in mesh, I have tried in many ways and I can't, when I try via app or web to add a mesh mode router and I can't find the second router ... any suggestions?


I messed up when I was downgrading the firmware and I checked "clear all custom configuration" and as a result, the /etc/config/wireless file is missing and the LED on the Antenna no longer work. So wifi doesn't work. I am not sure what other configuration files are missing. A factory reset doesn't not help to restore the wireless file.

Can someone share your firmware with /etc/config/wireless and other files in tact so I can restore my router back to the "default" state. TIA

If you have ssh redone the procedure. Files will be returned to original. Here

Have you tried to update the firmware from the UI again? The firmware file will contain the "default" files if I'm not wrong.

Hi, thanks everyone for your help. I have removed the crash partition and it solved the issue. I factory reset the router and everything is back to normal. Remember to remove write access bdata partition if not you get will your wifi bricked!

1 Like

Hi guys,
I'm a bit confused about the information cuz there are many threads about ax3600.
I recently bought AX3600 and i guess mine is the international version, im on version 3.0.22.
If I just flash the firmware to the newest chinese version, does the signal strengh solves the issue? I don't mind having the page in chinese.

If it doesn't solve the issue I guess I have to do the SSH permission, can I downgrade straight to the 1.1.17 firmware? Some threads says the 1.0.17 version, does it makes difference?

I was in the same situation as you, you have to downgrade to version 1.0.17 (download the file and flash it from the web interface) and use this guide to get ssh access.

Once you have access by ssh, using the xqrepack method that is here, patch the 3.0.22 image which is the latest international and install it.

Finally to increase the power of the antennas you can use the commands:

iwconfig wl0 txpower 30
iwconfig wl1 txpower 30

With these two commands it will increase the power but it will be restored on each reboot so to make it permanent we use the rc.local script located in /etc that is executed on each start. We add these 3 lines to rc.local (obviously before "exit 0"):

sleep 60
iwconfig wl0 txpower 30
iwconfig wl1 txpower 30

As a clarifying note, increasing the power to 30db or 1000mw is not allowed in many countries, in my case I have increased it to 23db or 200mw and it is enough for my house.


Anyone know if packages can be installed on the official version of the firmware? I have installed the xqrepack version that has the /opt directory activated but I can't install anything because it says there is no space in /overlay. My intention is to install wireguard, maybe by uninstalling openvpn there will be space? Or is it simply that nothing can be installed?

fyi currently at 80€ on amazon.de with coupon

I bought it at 56 euros on aliexpress. The international version


Hello to everyone, I keep reading about chinese images based on the Qualcomm tree, do they have any problem or advantage compared to the stock firmware patched with irq5's script?

You know the OEM firmware and its rather limited feature set.

QSDK[0] based builds use (almost) the same (semi-proprietary) 4.4.60 based kernel/ wireless drivers as the OEM firmware, but are otherwise more generic and less refined (not at all-) by the vendor. It looks more like OpenWrt, with (an old variant of-) luci as webinterface, providing some more access to the device and some more/ other features - but as you can't easily rebuild it from source and given that there is no full repository of downloadable binary packages, you quickly hit a wall if you'd like to add features not present in the ready built images provided by the respective individuals.

[0] QSDK is the semi-proprietary SDK Qualcomm provides to their corporate customers and licensees, the generic code the vendors then use to build their own firmware from. Vendors then adapt this example code for their devices, adding configuration and drivers as needed, just as well as customizing it to their liking (which usually entails ripping out the luci variant provided by the QSDK, dropping in their own webinterface, according to their plans and corporate identity and often adding their idea of upgrade/ recovery means).