Xiaomi AX3600 INT firmware

tried running my script with ra67 as a parameter and there is no available firmware for ax5 for international versions.
this is how it behaved before Xiaomi released an update for global ax3600.
I am not aware about updates of global ax5 but for the ax3600 a year almost passed since the update. it might work in the future if they will release a new global ax5 version, just change the "hardware" field to ra67 and check every once in a while.

btw - this is not relevant to the thread so please PM me if there any more questions.

on your samsung android device, you can manually set the wifi (the SSID of your xiaomi router) to be manually considered as NOT a metered connection
it's in wifi advanced

Thanks for this great topic !
I've just received a AX3600 INT and I have a AX1800 CN too.
After installing my new AX3600 and testing it, I see that the signal is lower and slower than the AX1800 !

In order to connect with MESH these 2 routers, what is the best way ?

Thanks !

I have both running with CN Firmwares and they work in mesh setup.

1 Like

Hello everyone.

I flashed 1.1.19 and while signal improved, it's nothing amazing. Do I have to do the SSH settings to gain the full 30db of signal, or just the Chinese firmware is enabling it?

When trying to connect to the router via miwifi app, it says I should switch to Germany server in the app. This hints that the router even though has Chinese firmware, the region is set to Germany, thus maybe limiting the db output?

What's the easiest way of changing country code to CN?


What's the easiest way of changing country code to CN?

Just restore factory defaults, and it'll switch to CN.

I flashed 1.1.19 and while signal improved, it's nothing amazing. Do I have to do the SSH settings to gain the full 30db of signal, or just the Chinese firmware is enabling it?

I haven't looked at 1.1.19, but as of 1.0.67, the region made no difference in terms of signal strength on Chinese firmwares. The 'max' was always 30 db

I did reset and it stays in EU.

I am checking the country code by doing "/api/xqsystem/country_code".
The command "set_country_code?country=CN" doesn't work on 1.0.17 either, as it returns error 1606.

From what I've read here, there is a limit to 23db when in EU country code.

How to set country code via SSH?

The value in nvram should be set to CN, it's value in bdata that persists (unless patched). I've looked at /lib/wifi/qcawificfg80211.sh, the script that sets actual signal power, and in 1.0.67 (and I assume in other CN firmwares), it does not depend on the region: max is always 30db

1 Like

Hi everyone ! I've got 2 AX3600 in mesh mode in 3.0.22 Firmware.

i've got an Adguard DNS server on a RPI who shows me that one of the router (the slave node) is flooding request to "xiaoqiang" wich is identified by Adguard as to be block by "Perflyst and Dandelion Sprout's Smart-TV Block".

Does someone know the service behind that flooding, that represent 50% of the DNS traffic in order to stop it ?

AFAIK you have to get both routers onto the same localization, means both on INT or CN.
Since ax1800 has no int firmware, you are forced to use the CN firmware.

Or does somebody have an INT firmware for ax1800 ra67?

1 Like

Hi Guys,

I recently purchased a Chinese version of xiaomi ax3600, and i need a way to change the vlan id to 2 as per my ISP requirement. i have tried to manually flash the router rom to either an international version (miwifi_r3600_all_6510e_3.0.22_INT.bin) or a old Chinese version (miwifi_r3600_firmware_5da25_1.0.17) to enable ssh but have been unsuccessful as it is unable to validate the file.

i would appreciate if anyone can lead me in the right direction thank you

The easiet way i found to gain persistent SSH is to follow this guide :


He created python script that helps

1 Like

even easier: OpenWrt support for Xiaomi AX9000 - #179 by bruda


I just purchased the Ax3600 to replace my Huawei Ax3. I have 2 ssid used in our home and some of our smart home cctv cameras use the ssid I configured on the guest ssid however the devices will not use the network. When I setup the Ax3 with my 2 ssid all our devices worked as if nothing changed. I can program the devices to use the main SSID but it won't work on the guest.i am pretty sure the guest has no device limit and is transmitting 2.4hgz but I can't setup some of wifi Smart devices to it. Any ideas?

Also from what I have read in the thread I should not have flashed the firmware to global as it was China originally.

Hi, did you solve the port forwarding problem? Please tell me how to solve this, thank you

I'm not facing any port forwarding problem.. can you describe your trouble ?

When I put my AX3600 as router (ISP modem dial PPPOE -> AX3600 broadcast wifi) I can forward port normally. But when I put my AX3600 as modem (ISP modem in bridge mode -> AX3600 dial PPPOE), I can't forward port any more

My ISP modem is in Bridge Mode but still managing PPPOE and the AX3600 in router mode.
The port forwarding is OK in that configuration.

My ISP doesn't authorize PPPOE delegation so I can't reproduce your case sorry

1 Like

this is my same scenario, with the ax3600 dialing pppoe and can't forward.

I tried with another router and it works normally. The problems seems occur due to stupid stock firmware. Hope to have stable openwrt firmware for ax3600 :frowning:

1 Like