XHR Timeout error message

Message - XHR Timeout on certain functions. Maybe this is posted in a nother thread but I'm posting this again anyway. Simply because it was so annoying I dont want others to not be able to fix it quickly.

User stated: I fixed it disabling the uHTTPd Connection Reuse.

You can find it in Luci under > Services > uHTTPd > Advanced Settings > Connection reuse = 0

or through SSH > nano /etc/config/uhttpd > option http_keepalive '0'

Maybe consider setting default to 0 in other images? Unless theres a good reason to keep it at 20

1 Like

Thank you @nk72772
This has been driving me nuts for months now.
Only seems to happen frequently with Chrome browser (both Mac and Windows). But not Firefox or Safari.
Anyhow, after making the setting change... now Chrome works too.
Thanks again.

1 Like

Glad I could help. Also, do not fear searching in Google or wherever else. Do not suffer unnecessarily.

Indeed, it was a Google search that lead me to your post here on this forum :wink:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.