Wrt1900acs v2 - Loosing internet connection randomly

I got a new WRT1900ACS v2 about a month ago. In general all works fine but I still have a recurring problem for that I'm unable to fix. I'm not even close to know what is happening. It is happening with both 19.07.2 and 19.07.3.

I have a simple setup. The 1900acs is connected to the modem provided by my ISP. This modem is configured in bridge mode. Before I got the 1900acs this modem was also the router and wifi access point. I disabled wifi on the modem.

Here's a summary of what is happening:

  • I start to work in the morning using a mac book pro. I use a wired connection (wifi turned off)
  • The only other device is a raspberry pi4 that act as the DNS server (pihole)
  • I will be, for example, in a conference call using WebEx
  • At some point people no longer hear me. I can hear them and I can still see screen sharing
  • I cannot access any website
  • I can ping the router just fine and the Pi4. The LAN works.
  • I cannot ping or
  • I cannot ping ISP DNS servers.
  • On the router I can ping the WAN IP (82.x.x.x).
  • The router cannot ping or traceroute to any IP on the internet
  • Rebooting the router "fix" the issue.

I have an other PC, but I don't remember if I ever had the problem while using it.

It is not a problem with my ISP. I already check with them: there is no outage and they don't see any problem on my DSL line.

Any ideas or suggestions to help me troubleshoot this ?

What is the output of uci export network ?

Please use the "Preformatted text </>" button for logs, scripts, configs and general console output.

Do you see anything in the logs when this happens? logread; dmesg

Output of uci export network

package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask ''
	option ipaddr ''
	option ip6assign '64'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix '64'
	list ip6prefix '2a71:1e3a:1353:48c3::/64'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

config route6
	option interface 'wan6'
	option target '2000::/3'
	option gateway 'fe80::3627:92ff:fe59:d4f7'

The route route6 is there to allow IPv6 traffic routing.

Unfortunately I forgot to check logread and dmesg before I rebooted this morning :frowning: Anyway I got everything from logread for today: https://pastebin.com/raw/WnHBDiwf

There isn't anything relevant in the logs.
Since you have DHCP as wan protocol, see if there is any connection to the internet hanging and the leasetime from your provider.

Next time it happens I will get information from dmesg. If it follows the same 'pattern' it should take a week before it happens again.

For the WAN interface I used the default settings (DHCP). In bridge mode the modem gives me that static IP assigned for my connection. Maybe I could try to configure the WAN interface manually ?

see if there is any connection to the internet hanging

What should I check ? Run a netstat on the router and check connection status (established, syn_sent, etc) ?

Do a ifstatus wan and check how much time is left for the lease to expire.

Not a good idea, maybe your ISP will not allow you if a DHCP lease is not in place.

There should be a firewall rule in place Allow-DHCP-Renew allowing udp/68 from wan. I hope you didn't disable that.

ifstatus wan shows lease time 604800. 1 week, that's a weird coincidence.

Should I check if my ISP would allow me to specify the IP instead of using DHCP ?

I didn't touch any firewall rules but I still verified that Allow-DHCP-Renew is indeed enabled.

At the half of the lease time (in your case 3,5 days) the dhcp client will send a dhcp request again to the server in order to renew the lease. Therefore if you don't see the lease updated (main status page of Luci, IPv4 upstream), it means that something is wrong with the communication of the router with the ISP dhcp server.

However since you mentioned that you are on a DSL, I have never seen DHCP protocol used over DSL, mostly some kind of PPP, like PPPoE. Is your ISP modem indeed in bridge mode, or is it terminating the connection?
Can you post here the output of ifstatus wan?

The ISP modem has 2 modes: router and bridge. Before I got the 1900acs it was set in router mode. There is no setup to do to connect that modem. I plug the modem and that's it. I think it relies on the MAC address of the modem for the automatic configuration. In the past I was able to use a TP-Link as the modem (TD-W9970). In this case the whole setup was manual: modulation type, VPI, VCI, encapsulation, ATM QoS Type, IP address, gateway and DNS. On the ISP dashboard it shows as a VDSL2 connection.

To use the wrt1900acs I only had to switch the ISP modem mode to bridge.

ifstatus wan:

	"up": true,
	"pending": false,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"uptime": 13122,
	"l3_device": "eth1.2",
	"proto": "dhcp",
	"device": "eth1.2",
	"updated": [
	"metric": 0,
	"dns_metric": 0,
	"delegation": true,
	"ipv4-address": [
			"address": "82.xx.xx.xxx",
			"mask": 24
	"ipv6-address": [
	"ipv6-prefix": [
	"ipv6-prefix-assignment": [
	"route": [
			"target": "",
			"mask": 0,
			"nexthop": "82.xxx.xxx.xxx",
			"source": "82.xx.xx.xxx/32"
	"dns-server": [
	"dns-search": [
	"neighbors": [
	"inactive": {
		"ipv4-address": [
		"ipv6-address": [
		"route": [
		"dns-server": [
		"dns-search": [
		"neighbors": [
	"data": {
		"leasetime": 604800

The IP values match the values I had to used for manual configuration.

Alrighty then. Keep monitoring the lease remaining time to see if it drops way below the half lease time.

The bridge mode of the ISP modem may be the problem.

Using a device in bridge mode is sometimes tricky.

I have a LTE router, which I use in bridge mode. It is connected with the WAN port of my openwrt router, the WAN interface gets its IP via DHCP with a lease time of 7200 sec = 2 hours. After one hour the openwrt router sends his first renew.

Sometimes the LTE router looses its connection and tries to reconnect. In that case the ISP assigns a new IP to the LTE router, but the LTE router does not inform the openwrt router about the IP change. Therefore the openwrt router operates with an invalid WAN IP (result: no internet access). The openwrt router knows about the new WAN IP after his next DHCP renew.

Of course: If you reboot, your linksys router gets the new WAN IP.

If my guess is correct, you have two options to solve your problem:

  1. operate your ISP modem in router mode (in that case your problem doesn't exist, but you'll have double NAT)

  2. operate your ISP modem in bridge mode and check on a regular basis (e.g. every minute), whether your linksys router has internet access or not. If not, just call ifup wan. This will immediately renew your WAN IP.

i have a similar issue:

I also got a wrt1900acs v2. I am running 19.07.3.

I have quite the same setup. The 1900acs is connected to the modem provided by my ISP (Unitymedia / Vodafone). This modem (AVM Fritzbox 6490) is configured in bridge mode. But i have a fix ipv4 (/30), so that the wrt1900acs is not configured to use wan dhcp but the fix /30.

Same here, i experience this issue about 2-3 times a week about 5-10 Minutes - how often do you? But i never rebooted the device.

I will check the online status via the following cronjob on the wrt1900acs:

So will investigate further on ...


BTW: I never experienced this behaviour before 19.07.2 :frowning:

Can you also monitor that dhcp client is renewing the lease from the ISP at around half of the leasetime?

I didn't keep track exactly but I can tell for sure that it happens at least once a week. Maybe I could wait, but I'm usually working and I need to get back online as soon as possible. This is the only reason why I reboot. In normal operation I expect uptime to reach months like the ISP device can do.

When I posted the router was up for about 2 days. I had few reboots due to other problems with Wifi and I tried other firmware (dd-wrt, linksys) but came back to OpenWrt.

I wrote a small script to ping few destinations and collect logs. Hopefully I'll be able to find some information that will help solve this issue. I'll post back when I have more infos to share.

Sorry, but as i mentioned - my wan is not getting any dhcp lease. it is configured to the fix ip gateway of my own /30-network. the isp router has fix ipv4 regarding the inside and outside interface ...

I'm curious...did either user with this issue turn off the DHCP firewall rule on WAN?


In my case I use all default rules. I had a look again and rule Allow-DHCP-Renew is enabled. I don't have any custom rules configured.

For the moment I'm waiting for the problem to happen again. I'll keep an eye on the DHCP lease expiration for the WAN interface.

1 Like

I must have overlooked that part. Can you ping the gateway of the ISP from your router when the outage occurs? Is there arp entry?

1 Like

While the outtage, i can ping the outside ip of the isp router, but no hop behind ...