WPS Button Activation is required

Hello. I need help please. I have a ZBTLink WE 1326 computer with a mt7621 processor. I want to activate WPS through the rear button and I can't do it.

Wpad and Hostapd-utils are already installed.

The equipment is reset by pressing and releasing the rear button once.

How can I configure the button so that it associates and works with WPS?


WPS i never found much info

Some say it's not secure
Yet it is used by more than 100 million internet boxes, routers and repeaters

1 Like

The doc says it has only one button that is a RESET button. There is no WPS button. Furthermore you can't use the reset button for WPS purpose.

At one point, the entire population of the planet believed that the Earth was flat, it didn't make it right.

After a little googling, I believe you can repurpose reset button to initiate the WPS mode for a specific WiFi. How good are you with SSH, editing files on the router and shell scripting?


Hello, thanks for the answer. I also think you can reprogram the reset button. I'm getting started on the subject, but I think I can edit files with the help of Google, of course. Thanks.


I'd try:

  1. Install required packages:
opkg update
opkg remove wpad-mini
opkg install wpad hostapd-utils
  1. Add option wps_pushbutton '1' to the wifi interface you want to enable WPS button for.

  2. Edit the /etc/rc.button/reset to contain:

case "$ACTION" in
logger -t 'button.reset' 'Enabling WPS'
hostapd_cli wps_pbc
return 0

Then run logread -f on your router and press momentarily and release the reset button.

Hello. Thank you very much for the instructions. These were carried out and we are currently like this.

  1. Uninstalled WPAD-basic-wolfssl. There was no WPAD-MINI.

  2. WPAD and Hostapd-utils installed

  3. Additionally, kmod-button-hotplug was installed

  4. When trying to connect to the WIFI network, we are suggested to press the WPS button. We press it but the equipment does not send the password to the laptop.

  5. The content of the reset file was deleted in /etc/rc.button/reset and the indicated was placed:


  1. The equipment no longer performs the reset when pressing the button and it does not go to factory settings if it is pressed for 8 seconds.

  2. By placing in the console the instruction: logread -f
    and release the button. It is noted
    the indication of button press, WPS activation and button release.


I hope you have understood me. Concluding the laptop does not receive the password that the WIFI equipment must send and thus proceed to the connection.

Thank you very much for the help, I think it is missing just a little.

Great job following (and modifying when needed) instructions!

Did you modify the wireless config as outlined in step 2?

Hello. Thanks for answering. Well in step 2 just install the WPAD and Hostapd-utils packages.

Additionally, the WPA2-PSK security protocol was configured and the use of WPS was marked.

What configuration are you referring to?

I show you the configuration. Thank you very much for the help.

Just for reference, it is not secure, as noted by the very article you linked :wink: -- 3rd paragraph reads:

A major security flaw was revealed in December 2011 that affects wireless routers with the WPS PIN feature, which most recent models have enabled by default. The flaw allows a remote attacker to recover the WPS PIN in a few hours with a brute-force attack and, with the WPS PIN, the network's WPA/WPA2 pre-shared key (PSK).[2] Users have been urged to turn off the WPS PIN feature,[3] although this may not be possible on some router models.[4]

That is why OpenWrt (and most other) router OS's no longer include (default) support for it. Obviously there is still a need in some situations where a wifi client device can only use WPS for configuration. This is really the only reason to use this now-deprecated technology. Fortunately, it looks like the OP may have a path to a solution.

1 Like

After replacing wpad, it is necessary to fully reboot for the new version to start running.

Try activating WPS manually from the console by running the command:
hostapd_cli wps_pbc
If this throws an error message, determine the problem. If it works and starts a WPS handshake, then something is wrong with the button script.

WPS-PBC is only secure if your neighbors aren't waiting for you to press the button.

1 Like

That package is no longer included by default.

Hello, thanks for answering, the hostapd_cli wps_pbc command was placed on the console, according to your recommendation, the results are displayed on the screen.


The password is not received from the equipment as proof of initiation of the WPS exchange process. The laptop stays waiting like this.


I don't know what happens. It will be because my operating system is Linux-Zorin. It is that I have tried with Huawei AP and the WPS has worked well against my laptop. Thanks for the help.

Not sure how important this step is, given that the CLI command ran without error, but:

You may want to post your /etc/config/wireless file omitting passwords.

1 Like

Hello, thanks for answering. Is it asking me to publish the configuration of the wireless interface? I put it below, thank you.

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option isolate '1'
	option ssid 'ETECSA_PRUEBA'
	option wps_pushbutton '1'
	option encryption 'psk2'
	option key 'testwps123'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option isolate '1'
	option ssid 'ETECSA_PRUEBA'
	option encryption 'psk2'
	option wps_pushbutton '1'
	option key 'testwps123'
	option disabled '1'

@vizoso the instructions I've seen recommend picking just one WiFi interface to have option wps_pushbutton '1'.

To test if it's working properly, I'd recommend you delete the option wps_pushbutton '1' from the config wifi-iface 'default_radio1' and also changing the SSID for that interface to something like ETECSA_PRUEBA5g. Then try to use the WPS console command while trying to connect to ETECSA_PRUEBA.

Also, don't forget to restart wifi after making changes in the config file and before trying.

Hello, thanks for answering. Well, wps was deactivated on the 5.8 GHz interface and the ESSID of that interface was changed.

The wifi and the equipment in general were restarted. The same situation remains.

Thank you.

I do not understand the remark on the fact that WPS would not be very secure because after all why not use it at our own risk

I don't think there's much ambiguity here...

The protocol is not secure. And it has been deprecated as a result.

of course. You do use it at your own risk. And that's fine if you are comfortable with that risk. But I think it makes sense to ensure that the risks are documented and known to those who choose to use this technology -- each user can make an informed decision. I personally would advise against it and I'd never use it on my own networks. However, I recognize that there are some devices out there that have WPS but no other means of being setup... so in those cases, obviously enabling WPS becomes a necessity.

1 Like

so in those cases, obviously enabling WPS becomes a necessity.

like what i have at home only with WPS button:

Decoder TV Box by Orange
Repeater by Orange

for that alone it should be studied with some importance