WPJ344 install?

Have you been able to install OpenWRT on a WPJ344 ?

I've had no luck.

I've connected a serial port and booted "MimoAP" and used the admin / password login, but that doesn't have rights use sysupgrade.

The root password is not published, but I reset the root password by booting into failsafe, doing "mount_root" and running "passwd root".

Then I rebooted and mounted a USB stick with "mount -t fat /dev/sda1 /tmp/m"

Then tried "sysupgrade /tmp/m/openwrt-18.06.1-ar71xx-generic-wpj344-squashfs-sysupgrade.bin", but got "Bad firmware format! Invalid image. Use the correct image for this platform Image check 'platform_check_image' failed."

I could try the force option on sysupgrade : "-F" ... but I'm not sure that will work.

Maybe running "mtd write openwrt-18.06.1-ar71xx-generic-wpj344-squashfs-sysupgrade.bin firmware" ?? I've never done this before. I have to umount various stuff first ? Or copy firmware to /rom, then boot into failsafe and copy firmware from /rom to /tmp and do "mtd write ..." ?

I tried tftp (both client and server) from uboot, but it says, "eth0 link down" , "Retry count exceeded" (on both wired interfaces).

I could use a hardware solution, like flashboot or JTAG, but I've never done that before and I'm hoping for something simpler.


FYI, I got this to work :

I modified /lib/upgrade/platform.sh to remove "wpj344" from the "case" statement in platform_do_upgrade ... so that it uses default_do_upgrade (not platform_do_upgrade_cpximg).

... then flash with "sysupgrade -F file"

Now the Wi-Fi works, but the wired ports still don't work ("swconfig list" shows nothing ...)

Duplicate: Compex WPJ344 : Enet switch config?