Compex WPJ344 : Enet switch config?

FYI, I installed OpenWrt 18.06.1 on a Compex WPJ344 ( it was a bit tricky : WPJ344 install? ) ...

However, the wired enet ports don't work. "swconfig list" shows nothing.

Is there some trick to get this working ?


From the product details, they appear to be 2 Ethernet PHYs. There is no switch.

Do they work as standard Ethernet ports?

There is a switch (AR8334) :


  • Switch support for the AR8334 was *added.

The switch on this board is currently NOT support in openwrt! In case you have a datasheet or a Linux driver for the QCA8334 switch / AR8334 switch, please send your information to

To make the switch partially work:

The device is supported in OpenWrt since 12.09 Attitude Adjustment. (If you accept that downloading all the patched sources from Compex qualifies.)

Yeah, saw that ... but it still doesn't work : "swconfig list" returns nothing.

I do get :

[ 0.718535] libphy: Fixed MDIO Bus: probed
[ 0.753984] libphy: ag71xx_mdio: probed
[ 1.383972] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:00 [uid=00000000, driver=Generic PHY]
[ 1.393978] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:RGMII

... but no switch

One thing that might be a clue : From U-boot , I tried TFTP (both client and server) , but it said, "eth0 link down" , "Retry count exceeded" (on both wired interfaces).

Maybe it could be a problem with the board (but I bought the board new from Compex) ?

Another thing : if I plug a laptop into the WPJ344, then I get a link light on the laptop (and corresponding kernel messages) ... so that implies that the switch is wired to the RJ45 connectors correctly.

what does

ls -l sys/class/net/


is your TFTP configuration file correct ? (sorry I dont know what the right config would be)