Worse 2.4GHz and best 5GHz wireless performance after flashing LEDE

I recently entered into this world of endless possibilities and amazed by the things we can do. Thanks to all the developers for making it possible.

I own a TP Link Archer C50 V1 which has MT7620A chip
I used to get 75Mbps up and down in my stock firmware on both bands. However, 5Ghz band wasn't giving consistent speeds on the stock firmware in the adjacent room.

After switching to LEDE, 5GHz band was transformed into a beast giving excellent consistent max 75Mbps speeds all over the house but 2.4Ghz is capping at 30-40Mbps which is almost the half which i used to get on stock firmware. I modified few settings back and forth i.e. different channels, 40Mhz, Transmit power, WMM mode ON. Nothing changed the capped speed. I tested on various devices, All were capping the 2.4GHz speed to 43Mbps max. Some of the same devices which also have a 5GHz band gave a consistent 75Mbps as advertised by ISP.

Can somebody kindly help ?? I'm open to any kind of testing.

Here's my device LEDE page and firmware

Here's the OpenWRT wiki for my device
https://openwrt.org/toh/tp-link/archer-c50

Your 2.4ghz channel is probably working at 20mhz due to interference from neighbouring APs in this crowded spectrum. It isn't compliant with the WiFi specs, but you can add option noscan '1' to your 2.4ghz radio in your /etc/config/wireless and rebooting to reload the changes. That should nearly double your 2.4ghz speed. It will force the AP to use 40mhz if you select 40mhz, regardless of any interference.

A couple other things to consider would be to set 11n 11g as the default mode and, assuming you don't have any ancient devices, disable legacy mode.

        option require_mode g
        option legacy_rates 0

(11g over restricting to 11n since there still some of those out there for many people)

*Bad news mate :frowning: Thanks for the suggestion
After adding that line, It slows down the speeds to 5-6Mbps.
There's absolutely minimal interference at my place. The only router which is using channel 11 other than me is 500m away. There are barely 2 APs around my router(A single one which belongs to my neighbor running at 40mhz and the other one is running at 20mhz) but you are absolutely right- When i remove the proposed line from the config, my router falls down to 20mhz but speed increases to 30-40Mbps with less range.

Here's the deal -
When we force it to use 40mhz, the speed falls down to 5-6Mbps with high ping and lot of jitter.
If we let the router to decide- It picks up 20mhz with less range and increases speed to 30Mbps with ping as low as 2ms and no jitter.
Internal USB transfers are also affected and produce equal max speeds as i stated above.
If it was interference, I shouldn't have got the high speeds just 2 days ago on my stock firmware, right ?

Legacy devices don't exist in my network as of now :stuck_out_tongue:
Unfortunately, That doesn't improve anything. I forced it into 11g and 11n on both 40mhz and 20mhz but nothing improves and produces the exact results as i stated in my above reply.

Please try without an USB device connected. USB ports can cause a lot of interference on 2.4ghz.

Negative ! I tried various settings removing USB but it still stays the same.
I think, I have to request my neighbor to tone down his wifi network to 20mhz which is occupying all the channels from 4 to 11. Could a single 40mhz network cause congestion ??

  1. You might force channel 1 to be used. Because of neighbour blocking 4-11.
  2. Would have been interesting whether stock firmware uses the open WiFi driver (like openwrt usually does) or the closed one from Mediatek. May be, you can reflash stock fw, and check channel used, and wifidriver. The one from mediatek shows up as "ra:" in ifconfig.
    Or somebody else, having same device can elaborate.

I tried going back to stock firmware but it wan't letting me. However, I requested my neighbor to tone down his network into 20mhz band which resulted in consistent 30Mbps speeds. I guess, I have to live with half speeds on 2.4GHz band. At least 5GHz is giving the best output on which all my main devices are running.

Depending where you live, how "noisy" the 2,4 ghz Bands are and how good the Mediatek driver is (at least it run stable for you): seem pretty solide to me.