WNR834Bv2 installation method?

Good day,

Previously I asked for help on how to flash openwrt on a router that already runs dd-wrt but it was not recommended by one of the users due to hardware limitations. WNR834B v2, help with transition from dd-wrt to openwrt

Being myself, I like to explore stuff during my free time and therefore I would like to ask the same question again but with different goal. I would like to set up QoS to prevent latency jumps caused by family members. Our current router is Nighthawk x4s running on stock firmware and the QoS just does not work. I imagine my plan as to place the wnr834bv2 in bridge mode and use r7800 as access point. The wnr834bv2 is on latest 2018-10-10 dd-wrt build, but the QoS is really limited and more modern options are simply not there. My question is would flashing openwrt provide better bandwith management options compared to limited ones in dd-wrt? If so, what would be the instructions to flash the .chk file.? I imagine this is dumb, but I cannot risk to brick the R7800 and would like to try out all the options before buying another router

Thank you


With a 264 MHz MIPS processor and a single, 100 Mbps Ethernet port on the SoC, I wouldn't expect more than 20-50 Mbps with SQM. With 16 MB of RAM, I would expect it to be unstable due to RAM exhaustion. From the page history, it doesn't look like it has been worked on since 2011. I didn't see any install instructions in the git commits. They date back to 2010.

You might try looking at other Netgear-branded, Broadcom-based units of the same era to guess at an install method. The .chk suffix suggests that it might be in an OEM-compatible format.

We are getting 15 down/7 up via wireless internet service provider, there are no other options in the current location.

I will try to find the installation method per your suggestion

OpenWrt support for the Netgear Nighthawk X4s/ r7800 is very mature, there is no reason not to use it (with OpenWrt and SQM).

I'am afraid to brick the device as it was not a cheap investment. It also no longer has warranty, therefore I'am being very careful

I realize that, but the r7800 is a rather popular and well supported device for OpenWrt, which is relatively hard to brick thanks to a robust tftp push-button recovery mechanism. You can flash OpenWrt using that procedure (mandatory, don't try to flash OpenWrt via the webinterface) and revert back to the OEM firmware the same way, if you happen not to like OpenWrt on it.

18.06.2 will run fine on it, but there are (optionally) two community builds more targetted at this particular device:

Disclaimer: I'm using the very similar ZyXEL NBG6817 myself, which is working very well.

1 Like

I'll have that in mind. At the moment I'am trying to flash the wnr834bv2 back to original .chk netgear firmware via gui -> firmware update but after reset it still runs dd-wrt.

Small update on what I managed to find out from yesterday:

  1. I got the router back to stock netgear firmware by putting it in recovery mode and flashing .chk via tftp client.
  2. Flashing 18.06.2 via OEM Gui results in pop out saying incorrect file
  3. Flashing snapshot build via OEM Gui bricks the router and it enters recovery mode which I later fixed by tftp client
  4. Flashing 18.06.2 via tftp client results in same recovery mode as the light keep flashing in green and wi-fi blue led does not appear. Again fixed by tftp client by flashing stock firmware.

I believe the good thing is that I was able to fix the router from bad flashing two times already and learned how to use tftp client. The bad thing is Im out of ideas how to load openwrt to this router.

Any suggestions?

Hook up serial and see what is going on when you flash snapshot / 18.06.2

I'am not familiar with the term hook up serial, from a quick search it is serial console and requires messing with the router's insides?

That's correct.

1 Like

Alright, I will examine the information first, thanks

OpenWrt won’t turn on WiFi on a fresh install, so the WiFi light probably won’t come on. Have you tried connecting to the router with a cable and logging in? (Though the status light usually goes solid on once OpenWrt is running properly.)

18.06.2.chk is not accepted via oem flash, while snapshot.chk is accepted, that is weird for me. As for your question right after flashing the firmware the router's power pulsates in green non-stop. Factory reseting results in same green flashing light and does not let me log in.


Connection cut out while being in the netgears gui, now the power light is solid amber and no amount of factory reseting or 30/30/30 help. Impossible to assign static ip and does not respond to pinging. Seems like it is dead for good. It was fun playing and thank you for support while trying to flash the firmware.

Why is it impossible to assign a static IP?

To be clear, if you are recovering, the step of assigning a static IP is done on the client.

Of course it isn't. You were already told this:


No....the SERIAL CONSOLE!!! You were already told this too:

In the future, I highly advise you follow the advice and instructions of people assisting you, especially when working with embedded devices like routers.

I'am afraid to brick r7800 and not the old one. I was toying with the WNR834Bv2 that had no other use, my only goal was to try and run the openwrt for it's bandwith management. After sudden disconnection from the Netgear GUI, the NIC no longer connects to the router, says no network detected while when it worked, it displayed some kind of name. I did not purposedly break the router, I experimented flashing firmware via OEM Gui and tftp client, tftp cmd. None of my attempts succeeded and everytime the router would automatically go into recovery mode (green flashing power indicator). After last unsuccesful attempt I recovered the router to it's stock firmware and did not do anything else. A little bit later while I looked thro the netgear gui, I was notified that the connection has been lost and the router had the static amber power light. It does not work anymore I believe

OK, thanks for the clarity.

The WNR834 is never going to run 18.06 due to its 16 MB of RAM.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.