Wireguard performs a lot worse than OpenVPN

I have a VPN between two sites located in two different countries in Europe. The routing is complex as I have a number of subnets for Home, IoT, office, guests etc. One of the subnets has the router in the other country as default route.
I found setting up the default route through the VPN limited to only one of the subnets challenging with OpenVPN (I cannot make it work as I like, it is either all the subnets get the default route through the VPN or nothing), but with Wireguard everything works just fine.


Unexpectedly, the bandwidth with Wireguard is appalling. With OpenVPN I get a throughput that is close to 90% of the available maximum broadband bandwidth. With Wireguard it stops at less than 30%. Even setting up a very simple point to point Wireguard VPN without any routing whatsoever iperf3 gives me exactly the same results.

The routers I use are Asus TUF AX4200 (both points), but I tried also with Netgear R7800 and Linksys MR8300 (same results), so the issue is unlikely due to the hardware.

I read that wireguard was supposed to be faster. Has anyone done a similar comparison?

I am not posting my wireguard configuration because there is not much that can be tweaked. Beside host, port, private and public keys and IPs allowed I leave everything as the default in luci.


well, it is surprise that WG is slower than OVPN :frowning:

usig WG everyday, more than pleased with speed & latency ...

only reason i could think for your problem is MTU

1 Like

It was in fact the MTU! At some point I changed it to 1492 which is the same as LAN, I realized only much later that the performance had dropped significantly, therefore I could not make the connection to the MTU change as the cause. Now it is back to the default of 1420 and I get 90% of the available bandwidth.


i am glad that you found it
please consider to mark topic as [Solved] and proper answer as solution