Wireguard OpenWrt server, NO LAN, YES accesso to internet

Hello, I am new in this forum, I would like to ask you for help with a problem on my router with OpenWRT, I have a vodafone modem from my provider with disabled firewall and all features, I have activated UPnP and DMZ to pass all traffic through the modem up to my OpenWRT router, I configured a wireguard server on the router to be able to remotely access the lan with the automatic script at this link: https://openwrt.org/docs/guide-user/services/vpn/wireguard/automated. I can access the internet via vpn and in fact I have the public ip of my router but I do not have access to the lan, in particular to a windows computer on which I would have the files, could you help me?

You need to allow on the windows firewall the access from remote hosts. By default it allows only from local hosts.


Good morning, thank you very much, as soon as I get home I try this method, as soon as I have news I write, thanks again for your patience.

Unfortunately it didn't work, the network was already set to private. I also tried to temporarily disable the firewall but it always gave the same error that I leave below, would you have any other advice for me? if needed I could post the configuration files too, thanks and good night.


I don't understand what this error is. However if you are able to access non windows hosts in the lan and the problem exists only on windows hosts, then the issue is on windows firewall.

1 Like

sorry, I mean it wrong, I only have windows pc in the lan and they give the same problem, I also tried to disable the firewall to see if it was that but it didn't work, in theory if it was the firewall and I disable it it had to go right?

Yes, that's right.
Still you can run a wireshark on the windows server and verify that you see the incoming packets. That can verify if the packets make it to the server or not.

1 Like

thank you very much, tomorrow I will check, one last thing, if I have the wireguard server installed on the router I don't have to set any static route right?

No, it is not necessary. All routes are there and OpenWrt should be the default gateway for every device.

1 Like

I tried to ping a printer in my lan remotely and it replies, so i guess i have access to lan, could you please tell me what should i do to enable remote host sharing on windows 10? in my lan i have 2 windows 10 and this printer, neither of the two windows computers responds to the ping, in fact, at this point I think it's really a firewall problem, or windows settings problem. Thanks for your patience and sorry.

I noticed an interesting thing, if I connect to my home network via my mobile phone and activate the vpn on the pc it allows me to ping the printer and I can access the router remotely, while if I connect directly to my home network and try I can't ping the printer or access the router.

in fact if I try to connect to the windows 10 network path of my pc it changed error message with this

and it could be given by the firewall of the pc

Troubleshooting windows is out of scope of this forum. You can try to disable the firewall as documented by microsoft. In any case you can pinpoint the issue by running wireshark on the windows host and verify that you can see the incoming packets. But if you can ping the printer my understanding is that your issue is with the windows firewall.

1 Like

good evening, I solved the windows firewall problem and now I can connect to the LAN remotely to the PC, I only have one problem left, I can connect to the LAN from a PC only if I use the phone as a router even when I am connected to the wifi at home, I have to share the wifi connection via mobile phone and I can remotely connect to both the router and the PCs, while if I don't I can only connect to the internet without having access to the LAN, do you have any ideas?

I am not sure that I understand what is the problem. If you are using an online translator, it is messing up what you are trying to say.