WiFi occasionally without Internet connectivity

I just updated to OpenWrt 21.02.0 from an older version and tried to replicate my network and wifi settings as they were before the upgrade. But something seems to be wrong. Sometimes my devices say they're connected to the wifi, but there is no internet connectivity. A few moments later it's suddenly working again. I can't seem to figure out what is wrong, but maybe it's related to me having a family internal network and a guest network. Can somebody please inspect my configuration and see if I made some mistake?

There should be two wifi networks. MyWifi is supposed to be linked to the internal ethernet ports. Also there should be an extra IP address for the router on this network (firewalls used to forward requests to another host for this IP). GuestWifi should be on a separate VLAN. OpenWrt should act as DHCP server for both networks, using separate IP networks.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdcb:ff9a:5566::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '10.10.11.1'

config device
	option name 'wan'
	option macaddr '11:22:33:44:55:9d'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config interface 'guest'
	option proto 'static'
	option device 'wlan1-1'
	option ipaddr '10.10.10.1'
	option netmask '255.255.255.0'

config interface 'internal'
	option proto 'static'
	option device '@lan'
	option ipaddr '10.10.11.3'
	option netmask '255.255.255.0'
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option cell_density '0'
	option country 'SE'
	option htmode 'VHT20'
	option channel '128'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option macaddr '11:22:33:44:55:9f'
	option ssid 'MyWifi'
	option key '123456'
	option ieee80211w '1'
	option encryption 'sae-mixed'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option cell_density '0'
	option country 'SE'
	option legacy_rates '1'
	option htmode 'HT40'
	option channel '4'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option macaddr '11:22:33:44:55:9e'
	option ssid 'MyWifi'
	option key '123456'
	option ieee80211w '1'
	option encryption 'psk2'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'GuestWifi'
	option key '654321'
	option ieee80211w '1'
	option network 'guest'
	option encryption 'psk2'

Maybe also my dhcp config is needed?

root@OpenWrt:/tmp# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option start '10'
	option limit '60'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'guest'
	option interface 'guest'
	option leasetime '12h'
	option start '101'
	option limit '49'
	list ra_flags 'none'

config domain
	option name 'internal.mynet.me'
	option ip '10.10.11.3'

What router are you using?

Linksys WRT 1900 ACS

Have you tried these settings OpenWrt 21.02.0 third release candidate - #37 by User34 ?
I had very same issues you mention on 21.02.0-rc4 on my 1900ACS, but they disappeared on 21.02.0 with the above settings.

There is also a thread on this issue Users needed to test Wi-Fi stability on Linksys WRT3200ACM & WRT32X on OpenWrt 21.02.0-rc4.
Focus is on 3200ACM/32X, but this is the issue I had. Some interesting leads there you might want to explore even with a 1900ACS.

On shelby might be this issue

1 Like

Fully agree. This is the issue I had, though I never got to that thread before. That explains why the settings above 'solve' it.

Thanks to both of you! I will try that out.

1 Like

I'm having the same problem. Tried a bunch of suggestions, but no luck. Back to 19.07.8 until the issues are fixed.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.