OpenWrt 21.02.0 third release candidate

every few seconds, I get in debug console :

[72055.723846] mwifiex_pcie 0000:01:00.0: CMD_RESP: cmd 0xb0 error, result=0x1                                                                                                  
[72055.731323] mwifiex_pcie 0000:01:00.0: Failed to set AP configuration                                                                                                        
[72055.738027] mwifiex_pcie 0000:01:00.0: Failed to start AP                                                                                                                    
[72061.749946] mwifiex_pcie 0000:01:00.0: CMD_RESP: cmd 0xb0 error, result=0x1                                                                                                  
[72061.757394] mwifiex_pcie 0000:01:00.0: Failed to set AP configuration                                                                                                        
[72061.764123] mwifiex_pcie 0000:01:00.0: Failed to start AP                                                                                                                    

I used this :
http://linuxwireless.sipsolutions.net/en/users/Drivers/mwifiex/
to get the firmware...
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/mrvl/pcieusb8997_combo_v4.bin
and add it to /lib/firmware/mrvl
and reboot, it look to load correcty :

[    8.622071] mwifiex_pcie 0000:01:00.0: info: FW download over, size 634228 bytes                                                                                             
[    9.463213] mwifiex_pcie 0000:01:00.0: WLAN FW is active                                                                                                                     
[    9.532655] mwifiex_pcie 0000:01:00.0: info: MWIFIEX VERSION: mwifiex 1.0 (16.68.1.p195)                                                                                     
[    9.541211] mwifiex_pcie 0000:01:00.0: driver_version = mwifiex 1.0 (16.68.1.p195)

But AP do not work at all :

BusyBox v1.33.1 (2021-06-13 22:02:19 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 21.02.0-rc3, r16172-2aba3e9784
 -----------------------------------------------------
root@ultra:~# wifi status
{
	"radio0": {
		"up": true,
		"pending": false,
		"autostart": true,
		"disabled": false,
		"retry_setup_failed": false,
		"config": {
			"path": "soc/d0070000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0",
			"hwmode": "11g",
			"channel": "auto",
			"cell_density": 0,
			"log_level": 1,
			"htmode": "HT20"
		},
		"interfaces": [
			{
				"section": "default_radio0",
				"ifname": "wlan0",
				"config": {
					"mode": "ap",
					"ssid": "ULTRA",
					"encryption": "psk-mixed",
					"key": "<***OBFUSCATED***>",
					"network": [
						"lan"
					],
					"mode": "ap"
				},
				"vlans": [
					
				],
				"stations": [
					
				]
			}
		]
	}
}
root@ultra:~# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/d0070000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option hwmode '11g'
	option channel 'auto'
	option cell_density '0'
	option log_level '1'
	option htmode 'HT20'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'ULTRA'
	option encryption 'psk-mixed'
	option key '<***OBFUSCATED***>'

some more few details :

root@ultra:~# lspci
00:00.0 PCI bridge: Marvell Technology Group Ltd. 88F3700 [Armada 3700 Family] ARM SoC
01:00.0 Ethernet controller: Marvell Technology Group Ltd. Device 2b42 (rev 11)
root@ultra:~# lsmod | grep wifi
cfg80211              303104  1 mwifiex
compat                 12288  3 mwifiex_pcie,mwifiex,cfg80211
mwifiex               253952  1 mwifiex_pcie
mwifiex_pcie           36864  0
root@ultra:~# cat /etc/config/network 

config interface 'loopback'
   option device 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fdc5:0f7f:d0b5::/48'

config device
   option name 'br-lan'
   option type 'bridge'
   list ports 'lan0'
   list ports 'lan1'
   list ports 'lan2'
   list ports 'lan3'

config interface 'lan'
   option device 'br-lan'
   option proto 'static'
   option ipaddr '192.168.1.1'
   option netmask '255.255.255.0'
   option ip6assign '60'

config interface 'wan'
   option device 'wan'
   option proto 'dhcp'

config interface 'wan6'
   option device 'wan'
   option proto 'dhcpv6'

config device
   option name 'wlan0'
   option promisc '1'
   option acceptlocal '1'
root@ultra:~# iw dev
phy#0
	Interface wlan0
		ifindex 12
		wdev 0x1
		addr f0:ad:4e:10:17:05
		type AP
		channel 6 (2437 MHz), width: 20 MHz, center1: 2437 MHz
		txpower 0.00 dBm
root@ultra:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1508 qdisc mq state UP qlen 1024
    link/ether f0:ad:4e:10:c1:9e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f2ad:4eff:fe10:c19e/64 scope link 
       valid_lft forever preferred_lft forever
3: lan0@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether f0:ad:4e:10:c1:9e brd ff:ff:ff:ff:ff:ff
4: lan1@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether f0:ad:4e:10:c1:9e brd ff:ff:ff:ff:ff:ff
5: lan2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether f0:ad:4e:10:c1:9e brd ff:ff:ff:ff:ff:ff
6: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether f0:ad:4e:10:c1:9e brd ff:ff:ff:ff:ff:ff
7: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether f0:ad:4e:10:c1:9e brd ff:ff:ff:ff:ff:ff
    inet 10.4.2.224/24 brd 10.4.2.255 scope global wan
       valid_lft forever preferred_lft forever
    inet6 2a01:e0a:8ab:34b0:f2ad:4eff:fe10:c19e/64 scope global dynamic noprefixroute 
       valid_lft 86204sec preferred_lft 86204sec
    inet6 fe80::f2ad:4eff:fe10:c19e/64 scope link 
       valid_lft forever preferred_lft forever
9: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether f0:ad:4e:10:c1:9e brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fdc5:f7f:d0b5::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::f2ad:4eff:fe10:c19e/64 scope link 
       valid_lft forever preferred_lft forever
12: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP100> mtu 1500 qdisc mq master br-lan state DOWN qlen 1000
    link/ether f0:ad:4e:10:17:05 brd ff:ff:ff:ff:ff:ff
root@ultra:~# iw dev wlan0 get power_save
Power save: on

tried this, because of bug reports found on the Internet :

root@ultra:~# iw dev wlan0 set power_save off
root@ultra:~# iw dev wlan0 get power_save
Power save: off

But no changes and still get same errors !

wifi up                                                                                                                                                                         
root@ultra:/# [73687.555780] mwifiex_pcie 0000:01:00.0: CMD_RESP: cmd 0x20 error, result=0x1                                                                                    
[73687.584664] mwifiex_pcie 0000:01:00.0: CMD_RESP: cmd 0xd1 error, result=0x1                                                                                                  
[73687.848831] br-lan: port 5(wlan2) entered blocking state                                                                                                                     
[73687.854325] br-lan: port 5(wlan2) entered disabled state                                                                                                                     
[73687.860293] device wlan2 entered promiscuous mode                                                                                                                            
[73687.865398] br-lan: port 5(wlan2) entered blocking state                                                                                                                     
[73687.870958] br-lan: port 5(wlan2) entered forwarding state                                                                                                                   
[73688.559114] br-lan: port 5(wlan2) entered disabled state                                                                                                                     
                                                                                                                                                                                
root@ultra:/# [73694.274948] mwifiex_pcie 0000:01:00.0: CMD_RESP: cmd 0xb0 error, result=0x1                                                                                    
[73694.282184] mwifiex_pcie 0000:01:00.0: Failed to set AP configuration                                                                                                        
[73694.288850] mwifiex_pcie 0000:01:00.0: Failed to start AP                                                                                                                    
[73700.277802] mwifiex_pcie 0000:01:00.0: CMD_RESP: cmd 0xb0 error, result=0x1                                                                                                  
[73700.285139] mwifiex_pcie 0000:01:00.0: Failed to set AP configuration                                                                                                        
[73700.291922] mwifiex_pcie 0000:01:00.0: Failed to start AP                                                                                                                    
[73706.306665] mwifiex_pcie 0000:01:00.0: CMD_RESP: cmd 0xb0 error, result=0x1                                                                                                  
[73706.314010] mwifiex_pcie 0000:01:00.0: Failed to set AP configuration                                                                                                        
[73706.320818] mwifiex_pcie 0000:01:00.0: Failed to start AP                                                                                                                    

Upgraded TP-Link Archer C2600 to RC3 and it seems to be working well.

The biggest issue is that uhttpd crashed at startup. It may be worth adding this issue and workaround to the release notes. The certificate (.CRT) file was not recognised as valid as it had all the plain text details/settings of the public key before and after the actual public key. Once the plain text was edited out, uhttpd worked again.

The certificate is a self-generated/self-signed one generated outside OpenWRT and worked under 19.07

Another try with removing mwifiex and adding mwlwifi (driver and firmware)... now crash

kmod-mwlwifi
mwlwifi-firmware-88w8897

[    7.381382] Loading modules backported from Linux version v5.10.42-0-g65859eca4dff                                                                                           
[    7.389366] Backport generated by backports.git v5.10.42-1-0-gbee5c545                                                                                                       
[    7.426132] <<Marvell Mac80211 Wireless PCIE Network Driver version 10.3.8.0-20181210>>                                                                                      
[    7.434452] pci 0000:00:00.0: enabling device (0000 -> 0002)                                                                                                                 
[    8.899679] mwlwifi 0000:01:00.0: Direct firmware load for mwlwifi/WlanCalData_ext.conf failed with error -2                                                                 
[    8.910014] mwlwifi 0000:01:00.0: Falling back to sysfs fallback for: mwlwifi/WlanCalData_ext.conf                                                                           
[    8.935764] mwlwifi 0000:01:00.0: Direct firmware load for mwlwifi/txpwrlmt_cfg.conf failed with error -2                                                                    
[    8.945680] mwlwifi 0000:01:00.0: Falling back to sysfs fallback for: mwlwifi/txpwrlmt_cfg.conf                                                                              
[    8.964209] Unable to handle kernel access to user memory outside uaccess routines at virtual address 0000000000000010                                                       
[    8.975308] Mem abort info:                                                                                                                                                  
[    8.978191]   ESR = 0x96000005                                                                                                                                               
[    8.981340]   EC = 0x25: DABT (current EL), IL = 32 bits                                                                                                                     
[    8.986825]   SET = 0, FnV = 0                                                                                                                                               
[    8.989971]   EA = 0, S1PTW = 0                                                                                                                                              
[    8.993211] Data abort info:                                                                                                                                                 
[    8.996177]   ISV = 0, ISS = 0x00000005                                                                                                                                      
[    9.000128]   CM = 0, WnR = 0                                                                                                                                                
[    9.003193] user pgtable: 4k pages, 39-bit VAs, pgdp=000000003d44a000                                                                                                        
[    9.009833] [0000000000000010] pgd=000000003d9c2003, pud=000000003d9c2003, pmd=0000000000000000                                                                              
[    9.018819] Internal error: Oops: 96000005 [#1] SMP                                                                                                                          
[    9.023847] Modules linked in: mwlwifi(+) mac80211 cfg80211 compat i2c_pxa nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_rejec
t_ipv6 ip6_udp_tunnel udp_tunnel nls_utf8 sha512_generic sha256_generic libsha256 seqiv jitterentropy_rng drbg md5 md4 kpp hmac ghash_generic gf128mul gcm ecb ctr cmac ccm arc4
 gpio_button_hotplug                                                                                                                                                            
[    9.057440] CPU: 1 PID: 1085 Comm: kmodloader Not tainted 5.4.124 #0                                                                                                         
[    9.063991] Hardware name: Globalscale Marvell ESPRESSOBin Ultra Board (DT)                                                                                                  
[    9.071173] pstate: 40400005 (nZcv daif +PAN -UAO)                                                                                                                           
[    9.076117] pc : 0xffffffc008928834 [mwlwifi@00000000175cddd8+0x2b000]                                                                                                       
[    9.082850] lr : 0xffffffc00890acd0 [mwlwifi@00000000175cddd8+0x2b000]                                                                                                       
[    9.089579] sp : ffffffc010f138e0                                                                                                                                            
[    9.092993] x29: ffffffc010f138e0 x28: 0000000000000009                                                                                                                      
[    9.098470] x27: ffffffc008934000 x26: ffffff80043ac800                                                                                                                      
[    9.103948] x25: ffffff80043ac8a0 x24: ffffffc00892c4f0                                                                                                                      
[    9.109426] x23: ffffffc00892d7d8 x22: ffffffc00892d7f8                                                                                                                      
[    9.114903] x21: ffffffc00892d7c0 x20: ffffff803d600ec0                                                                                                                      
[    9.120382] x19: 0000000000000000 x18: 000000000000000e                                                                                                                      
[    9.125859] x17: 0000000000000001 x16: ffffffc008928804                                                                                                                      
[    9.131336] x15: ffffffc008934000 x14: ffffff803d6025c0                                                                                                                      
[    9.136813] x13: 0000000000000000 x12: ffffffc0109a2000                                                                                                                      
[    9.142291] x11: ffffffc010946000 x10: ffffffc0109a2058                                                                                                                      
[    9.147769] x9 : ffffff803fde4410 x8 : ffffffff00d54408                                                                                                                      
[    9.153247] x7 : ffffffc02f4b5000 x6 : ffffffc01098f4c0                                                                                                                      
[    9.158725] x5 : ffffffff00d543c8 x4 : ffffff803d600ec0                                                                                                                      
[    9.164203] x3 : ffffffc00892d000 x2 : ffffff80043ac800                                                                                                                      
[    9.169680] x1 : ffffffc00892d070 x0 : ffffff803d6025c0                                                                                                                      
[    9.175157] Call trace:                                                                                                                                                      
[    9.177680]  0xffffffc008928834 [mwlwifi@00000000175cddd8+0x2b000]                                                                                                           
[    9.184054]  0xffffffc00890acd0 [mwlwifi@00000000175cddd8+0x2b000]                                                                                                           
[    9.190427]  0xffffffc00891625c [mwlwifi@00000000175cddd8+0x2b000]                                                                                                           
[    9.196798]  0xffffffc01040bae8                                                                                                                                              
[    9.200033]  0xffffffc010467fa0                                                                                                                                              
[    9.203268]  0xffffffc010468334                                                                                                                                              
[    9.206503]  0xffffffc0104685ac                                                                                                                                              
[    9.209737]  0xffffffc01046860c                                                                                                                                              
[    9.212972]  0xffffffc010466110                                                                                                                                              
[    9.216207]  0xffffffc0104679a8                                                                                                                                              
[    9.219442]  0xffffffc0104673d0                                                                                                                                              
[    9.222676]  0xffffffc010468c58                                                                                                                                              
[    9.225911]  0xffffffc01040b0e0                                                                                                                                              
[    9.229148]  0xffffffc008936028 [mwlwifi@00000000175cddd8+0x2b000]                                                                                                           
[    9.235520]  0xffffffc0100839c4                                                                                                                                              
[    9.238754]  0xffffffc010126190                                                                                                                                              
[    9.241989]  0xffffffc010127b6c                                                                                                                                              
[    9.245224]  0xffffffc010127ff4                                                                                                                                              
[    9.248459]  0xffffffc0101281d8                                                                                                                                              
[    9.251693]  0xffffffc010094fac                                                                                                                                              
[    9.254928]  0xffffffc010083748                                                                                                                                              
[    9.258172] Code: f9414a73 b0000023 f9400004 9101c061 (f9400a62)                                                                                                             
[    9.264456] ---[ end trace 510352514047102f ]---                                                                                                                             
[    9.269216] Kernel panic - not syncing: Fatal exception                                                                                                                      
[    9.274605] SMP: stopping secondary CPUs                                                                                                                                     
[    9.278650] Kernel Offset: disabled                                                                                                                                          
[    9.282246] CPU features: 0x0002,00002008                                                                                                                                    
[    9.286376] Memory Limit: none                                                                                                                                               
[    9.289524] Rebooting in 5 seconds..        

First of all big thanks for this awesome work!

For this upcoming release would it be possible to fix smartphone tethering? The symptom - at least on the iPhone/iOS 14.6 - is that upon connecting I don't get the "Trust" dialog on the phone and hence no new eth device is registered in OpenWRT.

Recent snapshot builds all work fine but none of the 21.02.0-rc* so far.

Router is a Netgear R7800.

1 Like

@CHKDSK88 Any idea why 21.02.0-rc3 doesn't allow lan access on Check Point L-50?

Reporting WRT1900ACSv2 successfully running 21.02.0-rc3. Upgraded from 21.02.0-rc2 keeping old configuration. Reinstalled the following packages. Up-time Day 1: everything appears to be working.

opkg update && opkg install irqbalance luci-app-advanced-reboot luci-app-sqm luci-app-samba4 block-mount kmod-usb-storage kmod-usb-storage-uas kmod-usb-ohci kmod-usb-ohci-pci luci-app-hd-idle kmod-usb3 kmod-fs-ext4 nano openvpn-openssl luci-app-openvpn luci-app-watchcat luci-app-statistics

Below are my WRT1900ACSv2 configurations for improved WiFi performance, kept from rc2:

  • Installed irqbalance. Change 'enabled' from '0' to '1' in '/etc/config/irqbalance'. Essential.
  • Enabled SQM. Significant improvement.
  • Disabled 802.11w (previously known to provide issues on mwlwifi). May not be necessary.
  • Patched firmware-88w8864 mwlwifi specific high latencies by disabling tx_amsdu. Essential. Add in luci > startup > local startup (nano /etc/rc.local) the following commands:
echo "0" >> /sys/kernel/debug/ieee80211/phy0/mwlwifi/tx_amsdu
echo "0" >> /sys/kernel/debug/ieee80211/phy1/mwlwifi/tx_amsdu
3 Likes

Just tested on rc3, ipheth driver (and thus iPhone usb tethering) doesn't work for me either. Kernel 5.4.124. Same behaviour as on rc2. It worked on a recent openwrt snapshot though (same kernel as rc3).

Anyone on TP-Link Archer C7 have experience with this version, or the earlier 21.02.0 candidates, notice whether it influences the 2.4ghz wifi disconnect / go deaf problem? It's a problem that has been plaguing these models for quite a few versions now.

Sorry that I haven't offered myself as a guinea pig yet, with the family AP... :roll_eyes:

Thanks for the awesome works from developer..
Using this rc3 build since snapshots and stable on my Linksys EA8100 v1,
no wireless connection issues so far... 5Ghz speed more than 350Mbps tested on my GL503vd
but the WAN DHCP Client configuration and DNS server must be configured manually, otherwise it will get no internet connection..

Nope, I haven't seen these issues on my Archer C7 v2. I use it as an access point only. And while it could be that I just haven't noticed it since I have another access point with the same SSIDs on different channels, I have looked at the logs rather often during my testing of the 21.02.0 release candidates (since rc1) and haven't found anything unusual in this regard.

Is Rasberry Pi 4b wireless controller supported well enough yet? So far it seems better to keep an actual wireless router for an access point when using the Pi 4b, I'm running RC3

1 Like

I had the same issue, The problem is the br-lan looses the wlan* interfaces on the migration ans as a consequence wifi clients are isolated.. Add the wlan* interface to the bridge and you will gain lan access.

Thanks to hauke and the rest of the OpenWrt developers.

No issues encountered, such as random reboots.
Nothing noticed in the system log during the 6 days of uptime test.
Archer C2600 rev. 1.1 with irqbalance installed, enabled and running as standard WiFi router.

Moving on to test D-Link (DIR-878, 882, 2640) routers now.

2 Likes

@RaylynnKnight

Could You check if current snapshot work fine?

The Pi4 has incredible potential for OpenWrt given it's strong CPUs, with tons storage (64GB 10-speed microSDs are dirt cheap) and RAM (8GB max now?), but it's wifi isn't good enough to serve as an AP other than maybe for 1 user next to it. Think about it there isn't an antenna array. You're always going to need a seperate AP and gigabit switch for that device.

1 Like

The only thing I'd ask for from the LuCI devs is for a light/dark theme option with the same color scheme just like what's in Preferences > Interface on this forum. It would be nice to have a dark theme. Hell, even the top bar with the OpenWrt icon isn't in LuCI which is a little awkward at this point. Unless you install material theme, but then the color scheme and iconography doesn't match this forum either.

Yes, what did you expect from a HDTV multimedia hub?

By the way, 8GB ram is only meaningful if you run a 64-bit version of O/S. Not even Pi Foundation has managed to make that work on their own device.
If no 64-bit you only get 4,7GB ram.

Yes I know, and I've had the Pi4 2GB since release and it's plenty of ram for this. I just play with it though, mostly run RetroPie with it for a fun emulator box, but doing another microSD with OpenWrt 21.02 to tinker with once it's released. Performance should be exellent even though the WRT32X will probably remain my router.

Timmo.. had you been seeing a problem on non 21 FW, or have you not noticed on 19/18 FW versions?

You might very well be not noticing, since typically theres little to no log evidence, especially as an AP.

@phinn with the chrome extension "Dark Reader" all of the themes have great color scheme

for something that can be handled on the client side fairly easily now, probably there would not be a lot of focus for "dark mode" in luci themes