Wifi client connected to wireless ap+sta dont register hostnames

So I've successfully configured the latest stable (19.07.3) on two Tplink Archer A7 devices.
One of the routers is the main router and the 2nd is a Wifi Client which rebroadcasts the 5G wifi signal. It doesn't re-broadcast the 2.4G, it is simply running on different channels on both devices. The Wifi client has disabled DHCP/IPv6 Firewall, upnp etc... all this runs on the main router. The 2nd device has a static lease to ensure it doesn't get a random IP address (makes managing it easier if it has a static IP).
Everything works as expected.
Previously I had Chaos Calmer configured similarly (on two WD MYNet N750 routers), yet any Wifi client connected to the secondary AP/STA device showed the hostname when viewing the connected devices on the STA device's overview through LuCI.
With the 19.07.3 on my TPlink devices, the 2nd device no longer shows hostnames, it only shows MAC Addresses, making it difficult to determine which device is currently connected to it.
Is something broken? Or did I configure something incorrectly.

Check if you have added the main router as nameserver on the dumbAP.


So a note about my setup.
I override the WAN DNS servers, LAN DNS Servers and the DHCP Server options on the lan to and
my /etc/resolv.conf.auto file on the main device also contains the same values.
What setting would I need to check on the 2nd device? Better yet, what would I need to set it to?

Reset DNS-related DHCP options and use Dnsmasq as a primary DNS for all LAN clients, or configure mDNS/LLMNR on the clients.

Can you tell me if the three things I mentioned, which ones I need to undo?
The main reason for overriding the DNS is to ensure that every device uses same DNS servers. I even set up a force dns firewall rules.
Maybe I went a bit overboard and did too much.
All the settings were changed on the main router so please advise what I should be changing. Perhaps the relevant config files and entries would help.

The dumbAP needs to use the main router as nameserver. Otherwise pointing it to the GoogleDNS or CloudflareDNS will result in failure to resolve the internal addresses of the hosts.

On the dumbAP use only one DNS, the one of the main router.
Or don't send by dhcp option 6 the cloudflareDNS.

1 Like

Ok I guess I am going to write out all the overrides I performed so that someone can tell me which ones to keep and which ones to undo/change... Been doing too much tinkering and not sure what term refers to which (from the above responses).

root@Chiggy:~# ls -ltr /etc/resolv.conf
lrwxrwxrwx    1 root     root            21 May 25 01:18 /etc/resolv.conf -> /tmp/resolv.conf.auto
root@Chiggy:~# ls -ltr /tmp/resolv.conf*
-rw-r--r--    1 root     root           108 Jul 12 17:31 /tmp/resolv.conf.auto
-rw-r--r--    1 root     root            32 Jul 12 17:34 /tmp/resolv.conf

root@Chiggy:~# cat /tmp/resolv.conf
search lan

root@Chiggy:~# cat /etc/resolv.conf
# Interface lan
# Interface wan

I suppose several changes ended up in the same file as a result of me repointing /etc/resolv.conf to resolv.conf.auto instead of the non-auto file. Is it really as simple as re-pointing the /etc/resolv.conf to /tmp/resolv.conf ?

The LuCI UI is showing me as having WAN DNS as and



All this is on the main router. The dumbAP doesn't override these settings. I might have to point its /etc/resolv.conf with the right sets of information (that's what it seems like will fix the issue), but can't be sure. So which ones need to be undone and what needs to change ?

EDIT: also made a change to the firewall on the main router to be able to force the DNS using this method: https://openwrt.org/docs/guide-user/firewall/fw3_configurations/forced_dns_redirection

Is this the AP or the main router?
I'll presume it is the AP:
Are you using the wan interface? If not, delete it. If yes, remove the cloudflare DNS servers and add the main router only.
In lan interface remove the custom DNS servers, and add the main router if wan is not used.
In DHCP settings of lan interface remove the option 6 with the cloudflare DNS. AP should not be running DHCP/DNS anyway.

1 Like

This was on the main router.
DumbAP doesn't override these settings.
On the dumbAP, I have already removed wan and wan6.
Firewall and DHCP server are disabled on the dumbAP as well.

Then remove the custom DNS from lan interface. These servers are reachable from wan only, so they should be only in wan interface.
Also remove option 6 with the cloudflare DNS from lan dhcp settings.
Restart the network and dnsmasq, then renew dhcp at the clients to acquire the new settings.

1 Like

Ok, removed the Cloudflare DNS servers from LAN interface and the option 6 from DHCP settings.
Wouldn't it then ask my router to perform the DNS lookups instead of Cloudflare?
I did all this to ensure that I force all clients to use Cloudflare instead of my router's cached DNS entries because sometimes it is out of date and requires a restart.

By itself it wouldn't.

Sure, but cloudflare doesn't know the internal names of your devices.

1 Like

You can disable Dnsmasq cache:

uci set dhcp.@dnsmasq[0].cachesize="0"
uci commit dhcp
/etc/init.d/dnsmasq restart
1 Like

Well yes not by itself. I meant that any client connecting via WiFi through the dumbAP will then see the DNS server as (which will essentially imply asking the router to do a DNS lookup instead of going to cloudflare...
Isn't there a way to separate the two things below:

  1. Any clients connecting should refer to cloudflare for any DNS lookups (and not the routers) BUT
  2. Routers (both the main router and dubmAP) should search the LAN for a hostname for locally connected devices

What purpose would this serve? I'm not that savvy with dnsmasq.
Also, is there any reason why when I attempt to change the cachesize to 0 via LuCI, all the below also gets removed...

uci del dhcp.cfg01411c.boguspriv
uci del dhcp.cfg01411c.filterwin2k
uci del dhcp.cfg01411c.nonegcache
uci del dhcp.cfg01411c.nonwildcard

You can do what you ask. Send by default cloudflare as DNS server, with option 6 in lan dhcp. For the dumbAP it would be easier to set the DNS static, otherwise you can send specific dhcp options to the dhcp client. The router doesn't need any special setting.

Ok so not sure why it was suggested that I remove it in the first place.... ::sigh::
I removed it and it still hasn't fixed the problem i started with...

Here is what things look like connected to the DumbAP:

And this is when the connection is established with the MAIN ROUTER (problem still not solved even after above changes):

Is this an actual bug?

Edit: As i indicated before, Firewall, DHCP has been disabled on the dumbAP, but not dnsmasq (it autostarts), and WAN and WAN6 have also been removed

current start software enabled/disabled on the dumbAP

Because you did not specify from the beginning what do you have and what do you want.

Which DNS server is the dumbAP using?

The LAN interface of the dumbAP is configured as a static IP of and it does not have an entry for Custom DNS servers. So the assumption is that this should come from upstream.
However, this is what I observed for /etc/resolv.conf (is symlinked to /tmp/resolv.conf):

search lan

There are no entries for DHCP options (6 options), no overrides of LAN DNS servers, etc.