WIFI channel 149 for France / Europe?

It's weird when i program the channels for my country France i have the possibility of putting channel 149 & up which is not authorized...

frequency plan

https://www.malekal.com/les-canaux-wifi-et-la-bande-de-frequence-2-4-ghz-5-ghz/

That may be old information. 149-161, 165 are available as SRD (short range devices) limited to 200mW. Channels 167-173 are available as SRD at 25mW.

2 Likes

See https://git.kernel.org/pub/scm/linux/kernel/git/sforshee/wireless-regdb.git/tree/db.txt#n634 for the background, specifically:

# FR as part of EU/CEPT accepted decisions 2005/513/EC (5GHz RLAN, EN 301 893)
# and 2006/771/EC (amended by 2008/432/EC, Short-Range Devices, EN 300 440)
#  EU decision 2005/513/EC: https://eur-lex.europa.eu/legal-content/EN/TXT/?uri=CELEX:02005D0513-20070213
#  EU decision 2006/771/EC: https://eur-lex.europa.eu/legal-content/EN/TXT/?uri=CELEX:02008D0432-20080611
#  EU decision 2021/1067/EC: https://eur-lex.europa.eu/legal-content/EN/TXT/PDF/?uri=CELEX:32021D1067&from=EN
# Harmonized CEPT countries (July 2019): https://www.ecodocdb.dk/download/25c41779-cd6e/Rec7003e.pdf
# FR: https://www.anfr.fr/fileadmin/mediatheque/documents/tnrbf/TNRBF_2021-12-14.pdf
country FR: DFS-ETSI
        (2400 - 2483.5 @ 40), (100 mW)
        (5150 - 5250 @ 80), (200 mW), NO-OUTDOOR, AUTO-BW, wmmrule=ETSI
        (5250 - 5350 @ 80), (100 mW), NO-OUTDOOR, DFS, AUTO-BW, wmmrule=ETSI
        (5470 - 5725 @ 160), (500 mW), DFS, wmmrule=ETSI
        # short range devices (ETSI EN 300 440-1)
        (5725 - 5875 @ 80), (25 mW)
        # WiFi 6E low power indoor
        (5945 - 6425 @ 160), (23), NO-OUTDOOR, wmmrule=ETSI
        # 60 GHz band channels 1-6 (ETSI EN 302 567 v2.2.1)
        (57000 - 71000 @ 2160), (40)
1 Like

From the same wikipedia page

" Les canaux de 144 à 165 sont utilisables en Europe pour des dispositifs Wi-Fi de 25 mW maximum, ce qui inclut les smartphones en mode [partage de connexion](https://fr.wikipedia.org/wiki/Partage_de_connexion). Il s'agit de la norme portant sur les SRD de moins de 25 milliwatts de puissance d'émission[13](https://fr.wikipedia.org/wiki/Liste_des_canaux_Wi-Fi#cite_note-:3-13)."

So these channels are allowed, but with reduced power transmit.

1 Like

nevertheless it is annoying because the wifi programmed in auto automatically switches to channel 149 so in very limited power

Try to restart wifi.
It also means that you are living in an area with radars signals. So lower channels and not available due to DFS. Yes it's annoying, you can't set freely your channel. I'm in the same case.
Have you tested channel 36 BTW ?

It is certain that if I block in channel 36 it works
I looked with several box providers and there is none that has this frequency range. there must be a reason for that
What interests me is to delete the range above channel 149 because it works badly because of the very low power on these channels

Looking for other countries it seems to me that for Japan it seems to correspond while having my same parameters for the other channels en 5 Ghz

At home i am very disturbed by the wifi of the neighborhood
These are individual houses whose owners have transformed into student studios and there are many boxes
My house is not Faraday cage at all

Ah if only I could pass network cables!!!

1 Like

You could put your "channel" to "auto" and the "channels" to a very specific, hand crafted list of wifi channels.

See: https://openwrt.org/docs/guide-user/network/wifi/basic#common_options

That will not cause your router to constantly look for new channels to hop to, but it will at least make channel auto-detection only consider this specific list.

If I'm not mistaken, the range from 5470MHz to 5725MHz should mp to channels 96 to 144. That's what the FR regulatory domain allows with enabled DFS at 500mW.

But as far as I know, detecting radar on a DFS channel requires this channel to be freed for at least a couple of minutes. So if radar is detected, that channel is marked as unusable for the foreseeable future and another channel gets used. That might repeat a couple of times, until either your router finds a channel that is not in conflict with radar, or until there is no channel left (that wasn't marked as unusable before).

So there are three possible scenarios here:

  • Your router might just try another DFS channel and keeps hopping all the time. That's when "cooldown" for conflicting channels hits earlier than radar conflicts happen.
  • Your router might finally settle on one of the channels, if your area has at least one DFS channel not in use for radar.
  • Your router might turn off 5GHz entirely. That's when all DFS channels are used for radar and there is no DFS channel free at all.

But of course using 80MHz channels will make DFS triggers 4 times more likely than 20MHz channels because a 80MHz channel is completely unusable as soon as one of its 20MHz slices is unusable. So you might be better off using 40MHz channels, or maybe even 20MHz channels.

1 Like

golialive , many thanks

i have never see this parameters:

channels list no (regulatory domain specific) Use specific channels, when channel is in ‚Äúauto‚ÄĚ mode. This option allows hostapd to select one of the provided channels when a channel should be automatically selected. Channels can be provided as range using hyphen ('-') or individual channels can be specified by space (' ') separated values.

for me as my Livebox 6

opption country 'FR'
option channel 'auto'
option channels '36 -64 100-144'

this parameters are not visible with luci , you must therefore manually edit the wireless file

it works because now the 5Ghz WIFI has gone to 132 instead of 149 before

Yes, that's what I was trying to say. Glad I could help.

Speaking of tricks, isn't there a solution to use WIFI in STA / LAN with French boxes because it doesn't work ?
It only works with OpenWrt on each side in WDS

For now it only works with OpenWrt + MTK drivers

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.