Which Image for RPI4 B

Evening All,

I have an RPI4 B running an older OpenWRT snapshot version f(OpenWrt SNAPSHOT r11955-b97247c2e9).

I'm trying to get Wireguard setup and running, but finding that I need to upgrade the firmware that already contains one of the wireguard packages (cannot find the kmod package to install manually), which is fine, but I'm having issues getting an image to boot. I keep getting 'direct firmware load for blah blah.bin failed with error -2'

Initially, I get the image copied to the sd card and actually booted up and let me log into LuCI and set a root password. But, I screwed up the VLAN eth0.1 and VLAN eth0.2 configurations and couldn't get reconnected. So, I re-flashed the SD with the image (after wiping the card a few times) and now won't finish booting.

The SD care is Sandisk Ultra 32gb (overkill I'm sure.)

is the factory image from https://openwrt.org/toh/raspberry_pi_foundation/raspberry_pi the appropriate image or should I be using a different image? Can I use the same config/network settings as I was using from the snapshot image or do I need something different?

These are my current configs on the still working snapshot image:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc5:f6ad:a06e::/48'

config interface 'lan'
        option type 'bridge'
        option ipaddr '192.168.10.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option proto 'static'
        option ifname 'eth0.1'
        list dns '192.168.10.57'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth0.2'

Thanks for any guidance/help.
B.

You're probably dealing with this:

When you get the message “Cannot satisfy the following dependencies for…” it is most likely because you installed a snapshot version of OpenWrt.
Read here for possible solutions.

You don't necessarily need to have a pre-built image, but there's no harm in that method either.

You should install 23.05.5 which just literally came out today. You can download it directly from the firmware slector and you can use either the standard release image or you can customize and add the packages you want.

Adding luci-proto-wiregurd kmod-wiregaurd wireguard tools is all that is required. Optionally, you may want to add qrencode as well.

Given the age of your current snapshot and configuration, you need to start from scratch -- do not keep settings when you do the upgrade.

EDIT: here's the direct link to the firmware selector with the Pi4B:
https://firmware-selector.openwrt.org/?version=23.05.5&target=bcm27xx%2Fbcm2711&id=rpi-4

Current stable for RPI4 B can be found Here:

What little you posted of your config should be ok as is.

Follow the wiki link you posted.

I disagree...

The above has two major things that are invalid in current configurations:

  1. the bridge is defined within the interface. This must now be done outside the interface definition as a device and then the device used within the stanzas.
  2. the ifname syntax has been replaced by device

These two things alone will probably cause a bunch of issues. At least what is in the config here seems really simple to replicate, so I would argue that a fresh install is safest.

And of course you are correct. I was playing with an old EOL/NLS box earlier today that used the old ifname syntax.

Thanks! I figured since it's been nearly 5 years (i set it and forgot it), much has changed. I'll spend some time in the wiki and looking at other rpi firm posts and get myself up to date.

With a clean upgrade, there isn't too much to worry about -- it's pretty much the same if you're using LuCI, and fairly obvious about the new syntax if you're using the CLI/config files. But sure, makes sense to read stuff to ensure your comfortable.

Any thoughts on squashfs vs. ext4 install choices? Does one make adding packages and upgrading more tedious or personal preference?

Also, since I'm not using an extra usb-lan adapter and splitting the lan to be both Rx/Tx, I believe I ended up creating a 2nd Interface (eth0.2, no clue what command was used ) and let a managed switch act as the relay between my home network and the router. Since I only have 300mb service, the 1gb lan port on the PI as served the household well...

UNLESS I would be MUCH better of using a 2nd port on the managed switch and changing VLAN settings to use two ports instead of the single port setup I'm currently using.

Thanks

they're both fine and easy to work with.

ext4 is a better choice if you want to expand your partition to allow more than ~100MiB of space for packages and data. Generally speaking, this isn't really necessary unless you're running things like AGH or similar. It is usually not recommended to make your router into a NAS or other general purpose storage device, though, so you may or may not actually need the extra space on your card.

squashfs has the advantage of being able to reset to defaults without rewriting the card. This is because it has a ROM partition and another for R/W. Your configs and post-flash package installs will go in the R/W partiation. If you ever need to reset or grab a given default file, squashfs does make that really easy. And, if you happen to be using a very small card (say 128MB or smaller), you can save space because squashfs uses a compressed ROM partition.

I'm using a 32GB sd and will likely want to expand the partition to the fullest.

I'm also assuming I'll need to be connected to my switch to create new vlan 'devices', assuming I'm keeping my current setup (single lan port on the pi) and not adding a USB adapter (although, might be a good idea to upgrade to a second port)...maybe later.

Thanks for letting me bounce ideas/questions. The PiRouter is back up and running with the new image. Still rocking a split lan port on the RPi4, perhaps I'll upgrade to a usb lan adapter. Another day.

B.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile: