Where’s the option to upload .ovpn file under services>openvpn

I am trying to setup a vpn connection on the router, I’m trying to follow the NordVPN guide: https://support.nordvpn.com/Connectivity/Router/1364683552/OpenWRT-LuCI-setup-with-NordVPN.htm

I am at step 4:

My setup however looks different;

I’m using; LuCI openwrt-18.06 branch (git-19.020.41695-6f6641d)](https://github.com/openwrt/luci) / OpenWrt 18.06.2 r7676-cddd7b4c77

Also the options don’t do anything when I try to “Add”

Any help much appreciated, thanks

fwiw, the Nordvpn instructions mentions using the snapshot version of luci-app-openvpn package.

If you are unable to upload the OpenVPN configuration file , do the following procedure to download the snapshot version of the luci-app-openvpn plugin:

1 Like

Oh thanks :sweat_smile:

I’ve changed the architecture name to mips_24kc


but I am getting this error now;

fwiw, I'm no expert, but one other thought I had is whether 'snapshot' packages can be safely used with older 'stable' releases such as 18.06.x? My understanding it is normally a bad practise to 'update' existing packages. No harm in trying I suppose.

At first glance, NordVPN's own web guide also may not have properly implemented 'kill switch' btw.

Update: Have you tried OpenWrt 19.07 snapshot, these appear to include the 'OVPN configuration file upload' option in luci-app-openvpn package.

Use my "old-fashioned" cli guide instead.

I was able to sort it out now I have the option to upload but I am now getting this error when I upload:

404 Not Found

Sorry, the object you requested was not found.

Unable to dispatch: /cgi-bin/luci/admin/vpn/openvpn/upload

Usually you can't mix LuCI packages from a new branch (like 19.07 or master) to firmware of an old branch like 18.06. The packages may reflect other changes in the LuCI main components or in the underlying OpenWrt.

Changing the opkg download feed definitions is usually a bad idea.

2 Likes

The openvpn option under services is now missing , when I go to install it again it displays it is up to date in root.

fwiw, if you are still using 18.06.x, you may want to consider using my v1.1 guide written for windows users if you are struggling with setting up openvpn client.
https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=279
you may need to reset your openwrt (luci->system->backup/flashfirmware-> Perform Reset) to ensure instructions are completed successfully.

The instructions were written with HH5A router, but the mainly generic instructions do work too for the other low end routers I own.

(I recently updated the guide to v1.2 for Openwrt 19.07)

Good luck.

Is openwrt 19.07 even available for the BT hhb5? On the openwrt website current release is 18.06.4

OpenWrt 19.07 snapshots, updated weekly since July 2019:
https://downloads.openwrt.org/releases/19.07-SNAPSHOT/

Ok thanks,

I’m going to flash the sysupgrade.bin file. I don’t have to worry about anything else like losing me configuration?

Would I need the kernel.bin file?

As far as I can tell, you haven't mentioned in this thread what router you are using.

I presume it is a BT Home Hub 5A, in which case the squashfs-sysupgrade file you found is indeed the correct one to use. No other files required.

If you are not using a HH5A, don't install it of course :wink:

Refer to section 4.3 of the 'OpenWrt/LEDE installation guide for HH5A' for general advice about upgrading LEDE or OpenWrt on HH5A

Thanks, have you used the raspberry pi as a vpn gateway? The speeds using openvpn on the BT hub is really substandard :sweat:

I don't own a raspberry pi. You'll have to use google to find more info about setting up pi as a gateway.

Google is your friend
https://www.instructables.com/id/Raspberry-Pi-VPN-Gateway/
openvpn gateway seems to work with single ethernet port

Hi, how could you fix this? I started using OpenWRT very recently and I don't understand much.

What router and what version of OpenWrt is installed?

Only 19.07 snapshots and daily development snapshots will offer the new .ovpn file upload feature. It is not available to 17.01 or 18.06.

I am using OpenWrt 18.06. I tried to use OpenWrt 19.07, but my Wireless USB (TP-link wn7200nd) didn't work. What could I do? I want to use my Raspberry Pi as Router VPN with an external USB Wifi

Sorry, I can't help with Raspberry Pi. Someone else may be able to help.

You may have to start a new thread, or search this forum to help you configure your Pi as an openwrt 'router'. For example:
https://forum.openwrt.org/t/18-06-on-raspberry-pi-3-b/18670

fwiw, once you have your Pi configured and functioning as a wifi router, you could try my v1.1 guide for openwrt 18.06 openvpn client setup.
https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=279

Google is your friend
https://www.instructables.com/id/Raspberry-Pi-VPN-Gateway/
Openvpn gateway seems to work with just single ethernet port.

pi 4b opevpn speeds
https://www.raspberrypi.org/forums/viewtopic.php?t=244736