Wget returned 4

i came across this error even though i am able to browse the internet with any problem and also able to play game but this error still showing

edit 1 : i have reset my router several times just today

1 Like

also check date/time on router. It may have failed an NTP update and SSL will not work with incorrect date/time.

did everything over there

everything is correct in that tab

Your local dnsmasq nameserver is not running. Also don't add custom nameservers to the lan section, put them in WAN (and add option peerdns 0 if you don't want to use the ISP advertised nameservers).

3 Likes

same

Check your gw IP too.

We weren't able to pin point the problem to solve so I took all the effort in installing oem and did all openwrt installing now there is no problem now. I believe there is a solution but what i did isn't the solution it was Last Resort so try your level best finding solution before doing the same

Lastly Thnx everyone who tried to help

Hi,

same problem for me. I've already check several posts about "wget returned 4" and had try unsuccesfully some solution which worked for some users.

This happened suddently on 21.02 version. I have reset my router several times. Then I tryed to flash RC version. Same problem, and no LUCI. I've disabled wan6 (even if i've a routable ipv6 from my isp + ipv4), changed DNS on LAN and many others stuff.

Any idea ?

wget error 4 is a general inability to reach the URL's site on the Internet. This can be as was the OP's case a DNS problem, or a complete lack of connection to the Internet.

On the router CLI or the test page try pinging a site by numeric address such as 8.8.8.8, then try again by name such as openwrt.org. If pinging by address works but by name does not, it's a DNS problem.

You might exchange the crappy openwrt-wget by real wget (NOT the busybox-wget). Which might provide more explicit error messages, better suited to trace down the issue.

nah man i have did the same

i am able to ping 8.8.8.8

how exactly can i download that

If you can't reach internet with the router, DL it to your computer, transfer it to the router, than install it manually via ssh.

I reinstalled OpenWrt and everything back to normal. Still don't know what happened.

ok try this * * * * * ping -c2 google.co.in

          • ping -c2 google.co.in (*)those are stars

command in Luci > System > Scheduled Tasks

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.