WAX206 erroring out when setting 5GHz wireless network

Hello everyone,
I'm really new to OpenWrt and to be honest i'm stuck with 2.4 GHz for now as I'm not able to enable the 5 GHz wireless network.
The SSID stays "not associated" and I am not able in any way to create the network.

I'm using the latest snapshot: r23129-a3469a90c4

I have two questions:

  1. How to build an older snapshot? I think there could be an issue in the current snapshot so I would like to take one old for testing purposes
  2. How to reinstall the stock firmware? When I try to update it through the UI I get always the check on the force checkbox but unfortunately I'm not able to restore the stock firmware.

wifi configs:

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'SomeRandomName+'
	option encryption 'psk2'
	option key 'a_password_really_strong'
	option network 'lan'
	option wpa_disable_eapol_key_retries '1'

below radio1 configs

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'some_path'
	option channel '132'
	option band '5g'
	option htmode 'HE160'
	option cell_density '0'

Below some logs:

root@OpenWrt:~# logread -f
Sun May 28 23:35:27 2023 daemon.notice hostapd: Configuration file: /var/run/hostapd-wl1.conf (phy wl1-ap0) --> new PHY
Sun May 28 23:35:27 2023 kern.info kernel: [ 2790.282899] br-lan: port 6(wl1-ap0) entered blocking state
Sun May 28 23:35:27 2023 kern.info kernel: [ 2790.288402] br-lan: port 6(wl1-ap0) entered disabled state
Sun May 28 23:35:27 2023 kern.info kernel: [ 2790.294160] device wl1-ap0 entered promiscuous mode
Sun May 28 23:35:27 2023 kern.info kernel: [ 2790.299207] br-lan: port 6(wl1-ap0) entered blocking state
Sun May 28 23:35:27 2023 kern.info kernel: [ 2790.304693] br-lan: port 6(wl1-ap0) entered forwarding state
Sun May 28 23:35:27 2023 daemon.notice hostapd: Frequency 5660 (primary) not allowed for AP mode, flags: 0x197b NO-IR RADAR
Sun May 28 23:35:27 2023 daemon.err hostapd: Primary frequency not allowed
Sun May 28 23:35:27 2023 daemon.warn hostapd: wl1-ap0: IEEE 802.11 Configured channel (132) or frequency (5660) (secondary_channel=1) not found from the channel list of the current mode (2) IEEE 802.11a
Sun May 28 23:35:27 2023 daemon.warn hostapd: wl1-ap0: IEEE 802.11 Hardware does not support configured channel
Sun May 28 23:35:27 2023 daemon.err hostapd: Could not select hw_mode and channel. (-3)
Sun May 28 23:35:27 2023 kern.info kernel: [ 2790.310827] br-lan: port 6(wl1-ap0) entered disabled state
Sun May 28 23:35:27 2023 kern.info kernel: [ 2790.318985] device wl1-ap0 left promiscuous mode
Sun May 28 23:35:27 2023 daemon.notice hostapd: wl1-ap0: interface state UNINITIALIZED->DISABLED
Sun May 28 23:35:27 2023 daemon.notice hostapd: wl1-ap0: AP-DISABLED
Sun May 28 23:35:27 2023 daemon.err hostapd: wl1-ap0: Unable to setup interface.
Sun May 28 23:35:27 2023 daemon.notice hostapd: nl80211: deinit ifname=wl1-ap0 disabled_11b_rates=0
Sun May 28 23:35:27 2023 kern.info kernel: [ 2790.323711] br-lan: port 6(wl1-ap0) entered disabled state
Sun May 28 23:35:28 2023 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Sun May 28 23:35:28 2023 daemon.notice hostapd: wl1-ap0: CTRL-EVENT-TERMINATING
Sun May 28 23:35:28 2023 daemon.err hostapd: hostapd_free_hapd_data: Interface wl1-ap0 wasn't started
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090): Command failed: ubus call hostapd config_add {"iface":"wl1-ap0", "config":"/var/run/hostapd-wl1.conf"} (Invalid argument)
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090): Usage: ubus [<options>] <command> [arguments...]
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090): Options:
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):  -s <socket>:		Set the unix domain socket to connect to
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):  -t <timeout>:		Set the timeout (in seconds) for a command to complete
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):  -S:			Use simplified output (for scripts)
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):  -v:			More verbose output
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):  -m <type>:		(for monitor): include a specific message type
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090): 			(can be used more than once)
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):  -M <r|t>		(for monitor): only capture received or transmitted traffic
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090): Commands:
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):  - list [<path>]			List objects
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):  - call <path> <method> [<message>]	Call an object method
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):  - subscribe <path> [<path>...]	Subscribe to object(s) notifications
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):  - listen [<path>...]			Listen for events
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):  - send <type> [<message>]		Send an event
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):  - wait_for <object> [<object>...]	Wait for multiple objects to appear on ubus
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):  - monitor				Monitor ubus traffic
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090):
Sun May 28 23:35:28 2023 daemon.notice netifd: radio1 (12090): Device setup failed: HOSTAPD_START_FAILED
Sun May 28 23:35:28 2023 daemon.notice netifd: Wireless device 'radio1' set retry=0
Sun May 28 23:35:28 2023 daemon.crit netifd: Wireless device 'radio1' setup failed, retry=0
Sun May 28 23:35:28 2023 daemon.notice netifd: Wireless device 'radio1' is now down
Sun May 28 23:35:29 2023 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sun May 28 23:35:29 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 4 names
Sun May 28 23:35:29 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 names
Sun May 28 23:35:29 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sun May 28 23:35:30 2023 daemon.warn odhcpd[1771]: No default route present, overriding ra_lifetime!

Does that mean that I cannot enable the channel 132 or?

Your issue is likely the HE160, try using HE80. Here's my config for reference; additionally, you can ignore my channel option since I had to mess around with country code on/off to get that to work (auto should be good enough).

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'some_path'
        option band '5g'
        option htmode 'HE80'
        option cell_density '1'
        option channel '153'
        option rts '2347'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'ap'
        option ssid 'zeNetwork'
        option encryption 'sae-mixed'
        option isolate '1'
        option key 'zepassword'
        option network 'lan'

Hard reset it, or use nmrpflash.

2 Likes

I noticed that you have not set the Country for the wireless, this maybe flagging these errors.

2 Likes

The only way I've gotten the 5Ghz to work is by leaving country code off and setting HE80 channel to auto. Every time I set mine to US it will not associate. It does unlock the other frequencies making them visible in LUCI, but the radio will not start until I remove the country code; even setting 00 for world makes it fail.

Setting to World would make it fail as an AP.

I does, but unfortunately for me, so does US.

Have you tried another channel (e.g. Channel 36) to test?

I just did and that seemed to allow me to use country code US :slight_smile: thanks man! Would you mind if I messaged you directly to pick your brain on wifi upload speed issues?

1 Like

I'd prefer responding to a new public thread, so others can benefit from it. Nonetheless, my Private Message Inbox is open.

You're welcome.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Something I've learned @maonat, as I'm setting up my wax206 this weekend for the first time, is that DFS will delay the availability of the interface for a minute or two as it performs its scan. You can view what frequencies will require the scan by running the command below, I'll just list a few (scroll to find the appropriate section). Your channel, 132, seems to require that scan. I choose in my config not to wait so went with channel 48, I've attached my config below.

iw list

 Frequencies:
                        * 5180 MHz [36] (23.0 dBm)
                        * 5200 MHz [40] (23.0 dBm)
                        * 5220 MHz [44] (23.0 dBm)
                        * 5240 MHz [48] (23.0 dBm)
                        * 5260 MHz [52] (24.0 dBm) (radar detection)
                        * 5280 MHz [56] (24.0 dBm) (radar detection)
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'redacted'
        option channel '9'
        option band '2g'
        option htmode 'HT40'
        option cell_density '1'
        option country 'US'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'redacted'
        option band '5g'
        option htmode 'HE160'
        option cell_density '1'
        option channel '48'
        option rts '2347'
        option country 'US'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'redacted'
        option encryption 'sae-mixed'
        option isolate '1'
        option key 'redacted'
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'redacted'
        option encryption 'sae-mixed'
        option isolate '1'
        option key 'redacted'
        option network 'lan'

Good luck.

2 Likes

Thanks everyone for the responses and suggestions, I will try all suggestions as soon as possible and will get back to you with feedbacks!