WAVLINK WL-WN533A8 - Missing one 5GHz radio on device

Hi Guys,

I have installed OpenWrt SNAPSHOT on my WAVLINK AC3000 (model: WL-WN533A8) following these instructions:
https://github.com/bubbadestroy/Jetstream_AC3000

So far everything is going well, but unfortunately I have problems with the radio module. The device usually has 3 different frequency bands (SSIDs) and supports 1x 2.4GHz and 2x 5GHz at the same time:

  • SSID1 (2.4GHz): WAVLINK-N
  • SSID2 (5GHz): WAVLINK-AC
  • SSID3 (5GHz): WAVLINK-AC-1733M

LuCI only shows 2 radio modules under /network/wireless (radio0, radio1). radio0 should support the 2.4GHz band and radio1 the 5GHz band. So far so good.

Now I would like to set up an SSID for radio0 and radio1 each. I named them like this:

  • radio0: OpenWrt_TEST_N
  • radio1: OpenWrt_TEST_AC

If I want to set up another, second SSID for radio1 (OpenWrt_TEST_AC1733), the 5GHz radio module no longer starts and hangs up. After restarting the router, I no longer have access to the shell and LuCI, and a connection is no longer possible to configure the router. I have to reset it.

I adjusted the radio channels in the same way as with the OEM firmware. With radio0 it worked without any problems, but not with radio1. If it worked, both SSIDs (OpenWrt_TEST_AC / OpenWrt_TEST_AC1733) were broadcasting on the same channel. The channels are and should be different from the factory.

Did I do something wrong? Why do I only see 2 radio modules? Is the driver for this router possibly incompatible because I worked according to the instructions for the WS-WN536A8? But according to these instructions, the same hardware should be installed.

OpenWrt SNAPSHOT r14900-acb336235c

It's not yet an officially supported model, so you're using a third-party build and you should seek support from them. This forum is for builds obtained from downloads.openwrt.org or built yourself from the source code.

It looks like there should be three radios. With most drivers, two SSIDs on the same radio is readily possible but of course it doesn't gain any bandwidth. It is useful to connect different networks such as trusted users and guests.

I asked a similar question back here:

And I sort of have figured it out. The trick was to disable the frequency limit on one of the radios, since one of them is responsible for both the 2.4 and 5 GHz band. I started with the most similar supported thing I found: wavlink wl-wn531a6, and changed:

diff --git a/target/linux/ramips/dts/mt7621_wavlink_wl-wn531a6.dts b/target/linux/ramips/dts/mt7621_wavlink_wl-wn531a6.dts
index 04f656d0f6..8d22ca677e 100644
--- a/target/linux/ramips/dts/mt7621_wavlink_wl-wn531a6.dts
+++ b/target/linux/ramips/dts/mt7621_wavlink_wl-wn531a6.dts
@@ -25,12 +25,6 @@
                        linux,code = <KEY_RESTART>;
                };
 
-               touch { /* RH6015C touch sensor -> GPIO 14 */
-                       label = "Touch Button";
-                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
-                       linux,code = <BTN_0>;
-               };
-
                turbo {
                        label = "Turbo Button";
                        gpios = <&gpio 25 GPIO_ACTIVE_LOW>;
@@ -124,7 +118,7 @@
                compatible = "mediatek,mt76";
                reg = <0x0000 0 0 0 0>;
                mediatek,mtd-eeprom = <&factory 0x0>;
-               ieee80211-freq-limit = <2400000 2500000>;
+               #ieee80211-freq-limit = <2400000 2500000>;
        };
 };

I had a following issue with the power of the radios, which got limited at 7 dBm, but then hacked the code to enable larger powers. Let me know if you find the same thing. Probably what's really missing is some eeprom info, but I haven't figured that out yet.

How to apply this patch? Please help me!

By using the patch command

But as you can see, it deletes 6 lines, and modifies one. No rocket science, from a manual edit point of view.

Thank you for your reply. :slight_smile:

But, yesterday I looked a little bit around and had not found the dts-files. Are they hidden on the filesystem?

Can you maybe tell me the correct syntax of that patch command? I will try it again after work.

Thanks a lot! :wink:

they're in the source, but I think it's possible to extract them from an already build image, if I remember correctly. There was a thread or two about it recently ...

patch < infile.patch

Both steps are not working for me. I still did not found the dts-files.

Applying the patch returns just an error "no such file" (or something else.)

Any ideas or how to's?

Make sure the paths are correct?

Or remove them all together, and make sure you patch in the correct dir.

Where is correct directory? Maybe thats my problem...

You tell me, it's your drive/device....

I tried to patch the mt7621_wavlink_wl-wn531a6.dts file again right now. But there are upcoming errors while patching:

timo@timo-ubuntu-i440FX-PIIX-1996:~/Downloads$ patch mt7621_wavlink_wl-wn531a6.dts 001-mt7621_wavlink_wl-wn531a6_radio3.patch
patching file mt7621_wavlink_wl-wn531a6.dts
Hunk #1 FAILED at 25.
Hunk #2 FAILED at 124.
2 out of 2 hunks FAILED -- saving rejects to file mt7621_wavlink_wl-wn531a6.dts.rej

Any ideas? What am I doing wrong?
Maybe it is easier to edit the dts-file manually? If so, which lines have to be changed exactly?

The lines marked by - in the patch file are removed, + are added.

This thing drove me crazy with it's crap stock firmware, was so glad to get openwrt on it in any semi-working condition. That said, I don't know if this will help but I dumped a gist here:

https://gist.github.com/bubbadestroy/ab47c478999e573d11fb74c4cfd2f655

Mostly all of the info I could source at the time a while back; from other folks efforts to reverse and dump these wavlink / winstars / jetstream / Ematic AC3000 triband routers.

Maybe something found here about radio 2:

http://en.techinfodepot.shoutwiki.com/wiki/Winstars_WS-WN536A8

could resolve the 5GHZ radio2 patching issue. I personally never attempted.. There are only 2 physical removable mpcie modules in this device (daughter cards?), one for 2.5ghz and other for 5ghz.

Other thoughts would be reversing this original firmware file might yield some light(tpd)
on the issue.

https://www.mediafire.com/file/80a80u2155vt0ta/WN533A8-WAVLINK-20181109/file

Possibly dig source, and it's logs within and see how they solve patching the modules in. Thinking they originally used openwrt as a base imagebuild anyhow to make their shitty * Lighttpd webserver web server ontop of anyhow..

Could always check out binwalk or ... some of the firmware tools from this virtual machine that easily loads firmadyne on a buntu machine in virtualbox.. here.
https://github.com/adi0x90/attifyos

At this point however, just getting it dirty flashed with almost everything else out of box working in openwrt was way way better than stock firmwares shortcommings. GJ Walmart :slight_smile:

Thought you might want to read this also..

Seems to affects EMATIC JETSTREAM WINSTARS WAVLINK devices. Just another reason to get these devices flashed with actual openwrt and far away from the stock firmware it ships with.