WAN speed issue on Netgear WNDR 3700v2

The Netgear WNDR 3700v2 is an old device, but can still be used for basic purpose. It is built on a Atheros AR7161 socket, which claims to have a dual 1000Mbits ethernet (one for LAN switch, one for WAN eth).

I have performed some speed tests using OpenWRT 19.07.7 and latest 21.01 snapshot, and noticed that the WAN eth is limited to 100 Mbits only. It is linked to another 1Gbits router and/or switch so link speed should be at 1000Mbits.
Using ethtool, I was able to verify that the speed was indeed set to 100Mbits. I tried to tweak to 1000 with several possibilities (half/full duplex, autoneg on/off) but none of them work. It only works when setting back to 100
ethtool -s eth1 speed 100 duplex full autoneg off

ethtool info for eth1 says that 1000 is supported.
Does anyone know about a WAN speed limitation on this device ?
Technical docs on a netgear forum claim that it has been tested with a bandwith of 345Mbits, so it must be set to 1000Mbits speed.
Thank you.

Did you try another cable? Did you check your OpenWrt log for any messages concerning the link negotiation?

While 100 MBit/s sharp would indeed indicate a problem (most likely cable related), you have to be aware that this SOC maxes out around 150-200 MBit/s (maybe up to 300 MBit/s under ideal circumstances and plain ethernet) - you won't get anywhere close to 1 GBit/s WAN-LAN throughput.

1 Like

With software flow offloading and CPU OC'ed to 800MHz, you can get 1.1Gbps bidirectional throughput.

I have tried several cables (5e/6) which works well with other devices.
link negotiation shows 100 Mbits
[ 61.874797] eth1: link up (100Mbps/Full duplex)
I have also tried several ports on the upward switch just in case. Every other devices work fine at 1Gbits except this WAN port.

I'm aware of the technical limitations of such old device. I don't expect a 1Gbits bandwith, but a 200Mbits as you suggest. Nevertheless, to get this, link speed needs to be at 1Gbits. That is what I'm looking for.

I have noticed that whatever upward device is linked (switch, another router), or cables (cat 5e/6) is used, the link partner advertised link mode is always 100 on WAN. All my devices works at 1Gbits.

I'm going to try an older OpenWRT version, and even a ath71xx to see if there is some kind of regression.

1 Like

I'm looking for a 1Gbits link, not bandwith. I'm aware it's impossible with such device.

I have performed several tests with 19.07.0 both ath79 and ath71xx. Result are the same.
If I force (ethtool) a 1000Mbit/s speed, link partner advertised link mode is also shown at 1000Mbit/s, but I get no connectivity. Setting back to 100Mbit/s restores connectivity.

I have linked directly the router to the optical WAN, link is at 100Mbit/s while it is of course at 1000Mbit/s with my main router (using same cable). I have even returned to stock firmware :woozy_face: and the link is also at 100Mbit/s. It's clearly not a cable related issue.

All devices on the network link each others to 1000Mbit/s, cables are cat 5e/6, everything works just fine with full bandwith, except for the 3700v2 on WAN. My guess is that there is an hardware limitation to 100Mbit/s.
I say it again, I just want the link set to 1000Mbit/s as it is claimed possible by the soc documentation. I'm aware that such old device won't be able to obtain more than 200Mbit/s as bandwith through WAN/LAN.

Thank you all anyway.

There shouldn't be.

Looking at my bootlog archive, WNDR3800 (=3700v2 with double RAM) properly showed the eth1 1000 full-duplex link still with kernel 4.9 in 2017:

[   27.590800] eth0: link up (1000Mbps/Full duplex)
[   30.912084] eth1: link up (1000Mbps/Full duplex)

With kernel 4.14 that eth1 1000 line disappeared from the log in 2018.

(my 3800 and 3700v2 are not online at the moment, so I can't test it right now)

I agree.
Whatever device is linked, cable used, and OS (stock, OpenWRT) the link is always at 100MBit/s on WAN. All other devices are linked at1000Mbit/s each others.
I also understand why I don't see an entry in log.

Inspect and clean the Wan socket.

It may be damaged or the pins may be dirty.

That is the very first thing I do in such case :slight_smile:

1 Like

I had the same issues with my WNDR4300 and not able to get it to link at 1000Mbit. After switching to Gargoyle 1.12, I had no issues whatsoever and have hit 600+ Mbits on the 4300 over the lan, I nevver really tested the wan speed as I'm on a 70mbit connection currently. But hopefully that solves your issue also. I guess there is a bug somewhere in OpenWRT and those Netgear boards preventing it from changing from 100.

Oops, just to clarify I know that your issue was with the WAN port. Even though I didnt test the speeds above 100mbit on the WAN port, I was able to get it to link at 1000mbit with Gargoyle 1.12. Just thought I'd clarify.

Thanks for info. I have revert back to stock firmware and was not able to link to 1000Mbit/s either. Every cables, devices of the network works fine at 1000. I have clean the wan connector... so I can't see any logical reason.

Hm ... I know where to find another such device. I'll recover it when I can and make some speed tests. I have have again the same issue than it's related to openwrt, if not it's related to the device.

I have tried: stock firmware, gargoyle 1.12, openwrt 19.07, openwrt 21.02 ... and still have 100 Mbit/s on WAN. I have tried several wires and possibilities. I had a poor WAN bandwith when I was using this device, and never worried about the WAN link speed.
This device is doomed. I'll have access to another 3700v2 and will try all these possibilities again.

I have the same device and the WAN is connected at 1000Tx

~# ethtool eth1
Settings for eth1:
Supported ports: [ TP MII ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Half 1000baseT/Full 
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes:  10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Half 1000baseT/Full 
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                     100baseT/Half 100baseT/Full 
                                     1000baseT/Half 1000baseT/Full 
Link partner advertised pause frame use: Symmetric Receive-only
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
Speed: 1000Mb/s
Duplex: Full
Port: MII
Transceiver: external
Auto-negotiation: on
Current message level: 0x000000ff (255)
       drv probe link timer ifdown ifup rx_err tx_err
Link detected: yes

Thank you.
I know where I can find another (than mine) and I'll check when I can. I would like to know if the issue if hardware related or if it's only mine. The connector is clean, no pin issue.

Yea, seems like the port is faulty, very strange, with everything you've tried, I can't think of any other thing that would cause it. Sorry it didn't work out with Gargoyle fixing the speed issue :frowning: