WAN DHCP Client not working

Hi,

I have a Qualcomm AP152 reference board, with Openwrt installed, I am unable to get DHCP Client IP address on the WAN interface. I have tried a set static IP address, I can assign IP address, but I am unable to have traffic pass through.

The WAN is on eth0.2, the ISP default gateway is on 192.168.1.1.

Please find the details of the network configuration below:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.254.1'
option netmask '255.255.255.0'

config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 2 3 4 5'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t 1'

root@OpenWrt:~#

root@OpenWrt:~# cat /etc/config/firewall

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option disabled '0'

config zone
option name 'lan'
option network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'wan'
option network 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config include 'miniupnpd'
option type 'script'
option path '/usr/share/miniupnpd/firewall.include'
option family 'IPv4'
option reload '1'

root@OpenWrt:~#

root@OpenWrt:~# cat /etc/config/dhcp
config dnsmasq
option domainneeded 1
option boguspriv 1
option filterwin2k 0 # enable for dial on demand
option localise_queries 1
option rebind_protection 1 # disable if upstream must serve RFC1918 addresses
option rebind_localhost 1 # enable for RBL checking and similar services
#list rebind_domain example.lan # whitelist RFC1918 responses for domains
option local '/lan/'
option domain 'lan'
option expandhosts 1
option nonegcache 0
option authoritative 1
option readethers 1
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
#list server '/mycompany.local/1.2.3.4'
#option nonwildcard 1
#list interface br-lan
#list notinterface lo
#list bogusnxdomain '64.94.110.11'

config dhcp lan
option interface lan
option start 100
option limit 150
option leasetime 12h

config dhcp wan
option interface wan
option ignore 1
root@OpenWrt:~#

root@OpenWrt:~# swconfig list; swconfig dev switch0 show
swconfig dev [port |vlan ] (help|set |get |load |show)
Global attributes:
enable_vlan: 1
max_frame_size: 1528
dump_arl: MAC: e0:cc:7a:68:f0:03 PORTMAP: 0x08
MAC: d4:25:8b:99:7c:f3 PORTMAP: 0x08
MAC: a4:4c:c8:6c:cd:9c PORTMAP: 0x04
MAC: 00:17:7c:9e:48:aa PORTMAP: 0x01

igmp_snooping: ???

Port 0:
mib: Port 0 MIB counters
RxBroad : 70
RxPause : 0
RxMulti : 24
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 22
Rx128Byte : 2278
Rx256Byte : 225
Rx512Byte : 46
Rx1024Byte : 87
Rx1518Byte : 69
RxMaxByte : 153
RxTooLong : 0
RxGoodByte : 669780
RxBadByte : 0
RxOverFlow : 0
Filtered : 14
TxBroad : 55
TxPause : 0
TxMulti : 265
TxUnderRun : 0
Tx64Byte : 1
Tx128Byte : 2865
Tx256Byte : 223
Tx512Byte : 25
Tx1024Byte : 251
Tx1518Byte : 6
TxMaxByte : 4
TxOverSize : 0
TxByte : 445654
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 0
link: port:0 link:up speed:1000baseT full-duplex txflow rxflow 

Port 1:
mib: Port 1 MIB counters
RxBroad : 0
RxPause : 0
RxMulti : 0
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 0
Rx128Byte : 0
Rx256Byte : 0
Rx512Byte : 0
Rx1024Byte : 0
Rx1518Byte : 0
RxMaxByte : 0
RxTooLong : 0
RxGoodByte : 0
RxBadByte : 0
RxOverFlow : 0
Filtered : 0
TxBroad : 0
TxPause : 0
TxMulti : 0
TxUnderRun : 0
Tx64Byte : 0
Tx128Byte : 0
Tx256Byte : 0
Tx512Byte : 0
Tx1024Byte : 0
Tx1518Byte : 0
TxMaxByte : 0
TxOverSize : 0
TxByte : 0
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 2
link: port:1 link:down

Port 2:
mib: Port 2 MIB counters
RxBroad : 39
RxPause : 0
RxMulti : 180
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 52
Rx128Byte : 2822
Rx256Byte : 134
Rx512Byte : 16
Rx1024Byte : 250
Rx1518Byte : 10
RxMaxByte : 0
RxTooLong : 0
RxGoodByte : 415268
RxBadByte : 0
RxOverFlow : 0
Filtered : 39
TxBroad : 89
TxPause : 0
TxMulti : 90
TxUnderRun : 0
Tx64Byte : 56
Tx128Byte : 2292
Tx256Byte : 313
Tx512Byte : 35
Tx1024Byte : 92
Tx1518Byte : 222
TxMaxByte : 0
TxOverSize : 0
TxByte : 679576
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 1
link: port:2 link:up speed:1000baseT full-duplex auto

Port 3:
mib: Port 3 MIB counters
RxBroad : 22
RxPause : 0
RxMulti : 118
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 48
Rx128Byte : 30
Rx256Byte : 105
Rx512Byte : 0
Rx1024Byte : 14
Rx1518Byte : 0
RxMaxByte : 0
RxTooLong : 0
RxGoodByte : 33738
RxBadByte : 0
RxOverFlow : 0
Filtered : 1
TxBroad : 50
TxPause : 0
TxMulti : 97
TxUnderRun : 0
Tx64Byte : 19
Tx128Byte : 51
Tx256Byte : 81
Tx512Byte : 15
Tx1024Byte : 15
Tx1518Byte : 0
TxMaxByte : 0
TxOverSize : 0
TxByte : 38035
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 1
link: port:3 link:up speed:1000baseT full-duplex auto

Port 4:
mib: Port 4 MIB counters
RxBroad : 0
RxPause : 0
RxMulti : 0
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 0
Rx128Byte : 0
Rx256Byte : 0
Rx512Byte : 0
Rx1024Byte : 0
Rx1518Byte : 0
RxMaxByte : 0
RxTooLong : 0
RxGoodByte : 0
RxBadByte : 0
RxOverFlow : 0
Filtered : 0
TxBroad : 0
TxPause : 0
TxMulti : 0
TxUnderRun : 0
Tx64Byte : 0
Tx128Byte : 0
Tx256Byte : 0
Tx512Byte : 0
Tx1024Byte : 0
Tx1518Byte : 0
TxMaxByte : 0
TxOverSize : 0
TxByte : 0
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 1
link: port:4 link:down

Port 5:
mib: Port 5 MIB counters
RxBroad : 0
RxPause : 0
RxMulti : 0
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 0
Rx128Byte : 0
Rx256Byte : 0
Rx512Byte : 0
Rx1024Byte : 0
Rx1518Byte : 0
RxMaxByte : 0
RxTooLong : 0
RxGoodByte : 0
RxBadByte : 0
RxOverFlow : 0
Filtered : 0
TxBroad : 0
TxPause : 0
TxMulti : 0
TxUnderRun : 0
Tx64Byte : 0
Tx128Byte : 0
Tx256Byte : 0
Tx512Byte : 0
Tx1024Byte : 0
Tx1518Byte : 0
TxMaxByte : 0
TxOverSize : 0
TxByte : 0
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 1
link: port:5 link:down

Port 6:
mib: Port 6 MIB counters
RxBroad : 0
RxPause : 0
RxMulti : 0
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 0
Rx128Byte : 0
Rx256Byte : 0
Rx512Byte : 0
Rx1024Byte : 0
Rx1518Byte : 0
RxMaxByte : 0
RxTooLong : 0
RxGoodByte : 0
RxBadByte : 0
RxOverFlow : 0
Filtered : 0
TxBroad : 0
TxPause : 0
TxMulti : 0
TxUnderRun : 0
Tx64Byte : 0
Tx128Byte : 0
Tx256Byte : 0
Tx512Byte : 0
Tx1024Byte : 0
Tx1518Byte : 0
TxMaxByte : 0
TxOverSize : 0
TxByte : 0
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 0
link: port:6 link:up speed:1000baseT full-duplex 

VLAN 1:
vid: 1
ports: 0t 2 3 4 5
VLAN 2:
vid: 2
ports: 0t 1
root@OpenWrt:~#

Are you using a cable modem? If so, you may need to reboot the modem (possibly a few times) to reset the MAC address binding so that it will work with your new device.

Hi,

I am using a Huawei ONU

Are you certain that your isp uses dhcp and not pppoe?

I have connected to the LAN port of the ONU, which is a DHCP server.
If I connect the ONU port to any other device with WAN being DHCP Cient, it works.

The setup is as follows:

AP152 Device - WAN INterface - eth0.2 --------------> LAN port of ONU Device ---------------> ISP

Looks like the port is down. Check your cables. Check the physical port. Make sure it can establish a link (connect it to your old router - just to see if the link functions). If not, you can reassign one of the other ports.

1 Like

The device has two ports - LAN - eth0.1 and WAN eth0.2. The port 2 on the switch is mapped to LAN and Port 3 is mapped to WAN. I have modified the configuration on the switch, wherein the Port 3 is assigned to WAN, and the port 6 is tagged for the same. But I still have not been able to get the DHCP client working. Please find the swicth details below:

root@OpenWrt:~# swconfig list; swconfig dev switch0 show
swconfig dev [port |vlan ] (help|set |get |load |show)
Global attributes:
enable_vlan: 1
max_frame_size: 1528
dump_arl: MAC: a4:4c:c8:6c:cd:9c PORTMAP: 0x04
MAC: 22:41:f2:c6:25:19 PORTMAP: 0x01
MAC: e0:cc:7a:68:f0:03 PORTMAP: 0x08
MAC: a4:4c:c8:6c:cd:9c PORTMAP: 0x04
MAC: 00:17:7c:9e:48:aa PORTMAP: 0x01
MAC: e0:cc:7a:68:f0:03 PORTMAP: 0x08

igmp_snooping: ???

Port 0:
mib: Port 0 MIB counters
RxBroad : 141
RxPause : 0
RxMulti : 40
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 46
Rx128Byte : 1050
Rx256Byte : 108
Rx512Byte : 106
Rx1024Byte : 29
Rx1518Byte : 33
RxMaxByte : 88
RxTooLong : 0
RxGoodByte : 363120
RxBadByte : 0
RxOverFlow : 0
Filtered : 99
TxBroad : 23
TxPause : 0
TxMulti : 25
TxUnderRun : 0
Tx64Byte : 21
Tx128Byte : 1235
Tx256Byte : 19
Tx512Byte : 2
Tx1024Byte : 120
Tx1518Byte : 2
TxMaxByte : 1
TxOverSize : 0
TxByte : 180670
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 0
link: port:0 link:up speed:1000baseT full-duplex txflow rxflow 

Port 1:
mib: Port 1 MIB counters
RxBroad : 0
RxPause : 0
RxMulti : 0
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 0
Rx128Byte : 0
Rx256Byte : 0
Rx512Byte : 0
Rx1024Byte : 0
Rx1518Byte : 0
RxMaxByte : 0
RxTooLong : 0
RxGoodByte : 0
RxBadByte : 0
RxOverFlow : 0
Filtered : 0
TxBroad : 0
TxPause : 0
TxMulti : 0
TxUnderRun : 0
Tx64Byte : 0
Tx128Byte : 0
Tx256Byte : 0
Tx512Byte : 0
Tx1024Byte : 0
Tx1518Byte : 0
TxMaxByte : 0
TxOverSize : 0
TxByte : 0
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 0
link: port:1 link:down

Port 2:
mib: Port 2 MIB counters
RxBroad : 29
RxPause : 0
RxMulti : 26
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 36
Rx128Byte : 1231
Rx256Byte : 19
Rx512Byte : 2
Rx1024Byte : 120
Rx1518Byte : 3
RxMaxByte : 0
RxTooLong : 0
RxGoodByte : 176030
RxBadByte : 0
RxOverFlow : 0
Filtered : 22
TxBroad : 63
TxPause : 0
TxMulti : 19
TxUnderRun : 0
Tx64Byte : 17
Tx128Byte : 1031
Tx256Byte : 113
Tx512Byte : 52
Tx1024Byte : 31
Tx1518Byte : 121
TxMaxByte : 0
TxOverSize : 0
TxByte : 336289
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 1
link: port:2 link:up speed:1000baseT full-duplex auto

Port 3:
mib: Port 3 MIB counters
RxBroad : 209
RxPause : 0
RxMulti : 18
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 215
Rx128Byte : 0
Rx256Byte : 16
Rx512Byte : 0
Rx1024Byte : 0
Rx1518Byte : 0
RxMaxByte : 0
RxTooLong : 0
RxGoodByte : 16616
RxBadByte : 0
RxOverFlow : 0
Filtered : 216
TxBroad : 0
TxPause : 0
TxMulti : 0
TxUnderRun : 0
Tx64Byte : 0
Tx128Byte : 0
Tx256Byte : 0
Tx512Byte : 0
Tx1024Byte : 0
Tx1518Byte : 0
TxMaxByte : 0
TxOverSize : 0
TxByte : 0
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 2
link: port:3 link:up speed:1000baseT full-duplex auto

Port 4:
mib: Port 4 MIB counters
RxBroad : 0
RxPause : 0
RxMulti : 0
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 0
Rx128Byte : 0
Rx256Byte : 0
Rx512Byte : 0
Rx1024Byte : 0
Rx1518Byte : 0
RxMaxByte : 0
RxTooLong : 0
RxGoodByte : 0
RxBadByte : 0
RxOverFlow : 0
Filtered : 0
TxBroad : 0
TxPause : 0
TxMulti : 0
TxUnderRun : 0
Tx64Byte : 0
Tx128Byte : 0
Tx256Byte : 0
Tx512Byte : 0
Tx1024Byte : 0
Tx1518Byte : 0
TxMaxByte : 0
TxOverSize : 0
TxByte : 0
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 1
link: port:4 link:down

Port 5:
mib: Port 5 MIB counters
RxBroad : 0
RxPause : 0
RxMulti : 0
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 0
Rx128Byte : 0
Rx256Byte : 0
Rx512Byte : 0
Rx1024Byte : 0
Rx1518Byte : 0
RxMaxByte : 0
RxTooLong : 0
RxGoodByte : 0
RxBadByte : 0
RxOverFlow : 0
Filtered : 0
TxBroad : 0
TxPause : 0
TxMulti : 0
TxUnderRun : 0
Tx64Byte : 0
Tx128Byte : 0
Tx256Byte : 0
Tx512Byte : 0
Tx1024Byte : 0
Tx1518Byte : 0
TxMaxByte : 0
TxOverSize : 0
TxByte : 0
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 1
link: port:5 link:down

Port 6:
mib: Port 6 MIB counters
RxBroad : 0
RxPause : 0
RxMulti : 0
RxFcsErr : 0
RxAlignErr : 0
RxRunt : 0
RxFragment : 0
Rx64Byte : 0
Rx128Byte : 0
Rx256Byte : 0
Rx512Byte : 0
Rx1024Byte : 0
Rx1518Byte : 0
RxMaxByte : 0
RxTooLong : 0
RxGoodByte : 0
RxBadByte : 0
RxOverFlow : 0
Filtered : 0
TxBroad : 0
TxPause : 0
TxMulti : 0
TxUnderRun : 0
Tx64Byte : 0
Tx128Byte : 0
Tx256Byte : 0
Tx512Byte : 0
Tx1024Byte : 0
Tx1518Byte : 0
TxMaxByte : 0
TxOverSize : 0
TxByte : 0
TxCollision : 0
TxAbortCol : 0
TxMultiCol : 0
TxSingleCol : 0
TxExcDefer : 0
TxDefer : 0
TxLateCol : 0

pvid: 0
link: port:6 link:up speed:1000baseT full-duplex 

VLAN 1:
vid: 1
ports: 0t 2 4 5
VLAN 2:
vid: 2
ports: 3 6t
root@OpenWrt:~#

The only port that has PVID 2 (which is corresponds to eth0.2 for your wan interface) appears to be down. Your swconfig has that as logical port 1, and your LAN (eth0.1) uses logical ports 2-5.

Something isn't right.

The pvid 2 is up, please see below:

pvid: 2
link: port:3 link:up speed:1000baseT full-duplex auto

It wasn't previously.

what do you see in the logs for DHCP?

I can make pvid1 being assigned to port 2 only, but that may not change the function

Verify that logical port 3 (associated with PVID 2 in your later post but strangely not in the OP with the actual OpenWrt configuration file) does indeed go up and down based on the physical connection to your ONU.

Please find the DHCP logs below, the DHCP request, seems to being sent and received by br-lan interface ?

root@OpenWrt:~# logread|grep DHCP
May 6 09:24:41 OpenWrt daemon.info dnsmasq[2103]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth no-DNSSEC loop-detect
May 6 09:24:41 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCP, IP range 192.168.254.100 -- 192.168.254.249, lease time 12h
May 6 09:25:20 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPREQUEST(br-lan) 192.168.1.143 22:41:f2:c6:25:19
May 6 09:25:20 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPNAK(br-lan) 192.168.1.143 22:41:f2:c6:25:19 wrong network
May 6 09:25:23 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPDISCOVER(br-lan) 22:41:f2:c6:25:19
May 6 09:25:23 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPOFFER(br-lan) 192.168.254.243 22:41:f2:c6:25:19
May 6 09:25:23 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPDISCOVER(br-lan) 22:41:f2:c6:25:19
May 6 09:25:23 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPOFFER(br-lan) 192.168.254.243 22:41:f2:c6:25:19
May 6 09:25:23 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPREQUEST(br-lan) 192.168.254.243 22:41:f2:c6:25:19
May 6 09:25:23 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPACK(br-lan) 192.168.254.243 22:41:f2:c6:25:19
May 6 09:26:03 OpenWrt daemon.info dnsmasq[2794]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth no-DNSSEC loop-detect
May 6 09:26:03 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCP, IP range 192.168.254.100 -- 192.168.254.249, lease time 12h
May 6 09:41:45 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPREQUEST(br-lan) 192.168.1.104 a4:4c:c8:6c:cd:9c
May 6 09:41:45 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPNAK(br-lan) 192.168.1.104 a4:4c:c8:6c:cd:9c wrong network
May 6 09:41:55 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPDISCOVER(br-lan) 192.168.1.104 a4:4c:c8:6c:cd:9c
May 6 09:41:55 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPOFFER(br-lan) 192.168.254.106 a4:4c:c8:6c:cd:9c
May 6 09:41:55 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPREQUEST(br-lan) 192.168.254.106 a4:4c:c8:6c:cd:9c
May 6 09:41:55 OpenWrt daemon.warn dnsmasq-dhcp[2794]: Ignoring domain internal.towerswatson.com for DHCP host name LPC-D5K81QH2
May 6 09:41:55 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPACK(br-lan) 192.168.254.106 a4:4c:c8:6c:cd:9c LPC-D5K81QH2

I verified, it goes up and down, based on the connection

logread -e dhcpc

The other DHCP activity is from your LAN devices.

logread is giving the below error

logread -e dhcpc
logread: invalid option -- e

placing the general grep

root@OpenWrt:~# logread|grep dhcp
May 6 09:24:41 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCP, IP range 192.168.254.100 -- 192.168.254.249, lease time 12h
May 6 09:24:41 OpenWrt daemon.info dnsmasq-dhcp[2103]: read /etc/ethers - 0 addresses
May 6 09:25:20 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPREQUEST(br-lan) 192.168.1.143 22:41:f2:c6:25:19
May 6 09:25:20 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPNAK(br-lan) 192.168.1.143 22:41:f2:c6:25:19 wrong network
May 6 09:25:23 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPDISCOVER(br-lan) 22:41:f2:c6:25:19
May 6 09:25:23 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPOFFER(br-lan) 192.168.254.243 22:41:f2:c6:25:19
May 6 09:25:23 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPDISCOVER(br-lan) 22:41:f2:c6:25:19
May 6 09:25:23 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPOFFER(br-lan) 192.168.254.243 22:41:f2:c6:25:19
May 6 09:25:23 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPREQUEST(br-lan) 192.168.254.243 22:41:f2:c6:25:19
May 6 09:25:23 OpenWrt daemon.info dnsmasq-dhcp[2103]: DHCPACK(br-lan) 192.168.254.243 22:41:f2:c6:25:19
May 6 09:25:51 OpenWrt daemon.notice netifd: wan (2333): udhcpc (v1.19.4) started
May 6 09:26:03 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCP, IP range 192.168.254.100 -- 192.168.254.249, lease time 12h
May 6 09:26:03 OpenWrt daemon.info dnsmasq-dhcp[2794]: read /etc/ethers - 0 addresses
May 6 09:41:45 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPREQUEST(br-lan) 192.168.1.104 a4:4c:c8:6c:cd:9c
May 6 09:41:45 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPNAK(br-lan) 192.168.1.104 a4:4c:c8:6c:cd:9c wrong network
May 6 09:41:55 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPDISCOVER(br-lan) 192.168.1.104 a4:4c:c8:6c:cd:9c
May 6 09:41:55 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPOFFER(br-lan) 192.168.254.106 a4:4c:c8:6c:cd:9c
May 6 09:41:55 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPREQUEST(br-lan) 192.168.254.106 a4:4c:c8:6c:cd:9c
May 6 09:41:55 OpenWrt daemon.warn dnsmasq-dhcp[2794]: Ignoring domain internal.towerswatson.com for DHCP host name LPC-D5K81QH2
May 6 09:41:55 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPACK(br-lan) 192.168.254.106 a4:4c:c8:6c:cd:9c LPC-D5K81QH2
May 6 09:47:15 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPREQUEST(br-lan) 192.168.254.106 a4:4c:c8:6c:cd:9c
May 6 09:47:15 OpenWrt daemon.warn dnsmasq-dhcp[2794]: Ignoring domain internal.towerswatson.com for DHCP host name LPC-D5K81QH2
May 6 09:47:15 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPACK(br-lan) 192.168.254.106 a4:4c:c8:6c:cd:9c LPC-D5K81QH2
May 6 09:48:37 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPREQUEST(br-lan) 192.168.254.106 a4:4c:c8:6c:cd:9c
May 6 09:48:37 OpenWrt daemon.warn dnsmasq-dhcp[2794]: Ignoring domain internal.towerswatson.com for DHCP host name LPC-D5K81QH2
May 6 09:48:37 OpenWrt daemon.info dnsmasq-dhcp[2794]: DHCPACK(br-lan) 192.168.254.106 a4:4c:c8:6c:cd:9c LPC-D5K81QH2

logread | grep dhcpc

What versio nof OpenWrt are you using?

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik

ubus call system board
1 Like

i have to dig a bit more to get the openwrt version , the output I get to check the version are placed below:

root@OpenWrt:~# cat /etc/openwrt_version
QCA9558.LN
root@OpenWrt:~# cat /etc/openwrt_release
DISTRIB_ID="QSDK"
DISTRIB_RELEASE="QCA9558.LN"
DISTRIB_REVISION="r41027"
DISTRIB_CODENAME="premium_beeliner_router"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="QSDK Premium Beeliner Router QCA9558.LN"

It is openwrt + qsdk